起航选股公式

发布时间:2020-06-28

选股公式源码

OSC:=100*(CLOSE-MA(CLOSE,20));
MAOSC:=EXPMEMA(OSC,6);
BIAS:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
BIASMA:=MA(BIAS,6);
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
LIN:=IF(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,1,0);
E:=-100*(HHV(HIGH,84)-CLOSE)/(HHV(HIGH,84)-LLV(LOW,84));
DJ1:=CROSS(OSC,MAOSC) AND LIN AND REF(EVERY(C<O,3),1) AND REF((E<-98)*50,1);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
DJ2:=CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND REF((E<-98)*50,1) AND REF(EVERY(C<O,3),1);
F1:=100*(C-REF(C,1))/REF(C,1);
KX:=IF(C<REF(O,1) AND F1<0,1,0);
LH:=IF(C<REF(O,2) AND F1<0,1,0);
BE:=KX=0 AND REF(KX,1)=1 AND LH=0 AND REF(LH,1)=1;
VAR1:=REF(CLOSE,1);
VAR2:=SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100;
SS1:=FILTER(REF(VAR2,1)<20 AND VAR2>REF(VAR2,1),5);
SM01:=MA((2*C+H+L)/4,5);  
SM02:=SM01*(200-102)/100;  
SM03:=(1-7/100)*DMA(C,ABS((2*C+H+L)/4-MA(C,20))/MA(C,20));
SM04:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
SM05:=3*SMA(SM04,3,1)-2*SMA(SMA(SM04,3,1),3,1);  
SM06:=((H+L+C)/3-MA((H+L+C)/3,14))/(0.015*AVEDEV((H+L+C)/3,14));
SM07:=SM02<SM03 AND SM05>REF(SM05,1) AND REF(SM05,1)<REF(SM05,2) AND SM06<-100
AND SM06>REF(SM06,1);  
BZ:=SS1 AND SM07;
CC1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD1:=DMA(CLOSE,CC1);
EE:=(1-14/100)*DD1;
DI:=BETWEEN(C,EE*0.98,EE*1.01);
WZ:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100;
WZBP:=CROSS(-27,WZ) AND COUNT(H=L,5)<1;
QSX:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
KJ:=CROSS(-20,QSX);
XG:(BE AND BZ AND DI) OR WZBP OR KJ OR DJ1 OR DJ2;

选股公式翻译

OSC赋值:100*(收盘价-收盘价的20日简单移动平均)
MAOSC赋值:OSC的6日指数平滑移动平均
BIAS赋值:(收盘价-收盘价的20日简单移动平均)/收盘价的20日简单移动平均*100
BIASMA赋值:BIAS的6日简单移动平均
F赋值:100*(收盘价-1日前的收盘价)/1日前的收盘价
P1赋值:如果收盘价<1日前的开盘价ANDF<0,返回1,否则返回0
P2赋值:如果收盘价<2日前的开盘价ANDF<0,返回1,否则返回0
LIN赋值:如果P1=0ANDREF(P1,1)=1ANDP2=0ANDREF(P2,1)=1,返回1,否则返回0
E赋值:-100*(84日内最高价的最高值-收盘价)/(84日内最高价的最高值-84日内最低价的最低值)
DJ1赋值:OSC上穿MAOSC AND LIN AND 1日前的最近3日一直存在收阴线 AND 1日前的(E<-98)*50
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
X赋值:2日内J的最低值=8日内J的最低值
DJ2赋值:J上穿1日前的J+0.01 AND X AND J<20 AND 1日前的(E<-98)*50 AND 1日前的最近3日一直存在收阴线
F1赋值:100*(收盘价-1日前的收盘价)/1日前的收盘价
KX赋值:如果收盘价<1日前的开盘价ANDF1<0,返回1,否则返回0
LH赋值:如果收盘价<2日前的开盘价ANDF1<0,返回1,否则返回0
BE赋值:KX=0 AND 1日前的KX=1 AND LH=0 AND 1日前的LH=1
VAR1赋值:1日前的收盘价
VAR2赋值:收盘价-VAR1和0的较大值的7日[1日权重]移动平均/收盘价-VAR1的绝对值的7日[1日权重]移动平均*100
SS1赋值:1日前的VAR2<20ANDVAR2>1日前的VAR2的5日过滤
SM01赋值:(2*收盘价+最高价+最低价)/4的5日简单移动平均
SM02赋值:SM01*(200-102)/100
SM03赋值:(1-7/100)*以(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均为权重收盘价的动态移动平均
SM04赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
SM05赋值:3*SM04的3日[1日权重]移动平均-2*SM04的3日[1日权重]移动平均的3日[1日权重]移动平均
SM06赋值:((最高价+最低价+收盘价)/3-(最高价+最低价+收盘价)/3的14日简单移动平均)/(0.015*(最高价+最低价+收盘价)/3的14日平均绝对偏差)
SM07赋值:SM021日前的SM05 AND 1日前的SM05<2日前的SM05 AND SM06<-100AND SM06>1日前的SM06
BZ赋值:SS1 AND SM07
CC1赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均
DD1赋值:以CC1为权重收盘价的动态移动平均
EE赋值:(1-14/100)*DD1
DI赋值:收盘价位于EE*0.98和EE*1.01之间
WZ赋值:(收盘价-收盘价的34日简单移动平均)/收盘价的34日简单移动平均*100
WZBP赋值:-27上穿WZ AND 统计5日中满足最高价=最低价的天数<1
QSX赋值:(收盘价-收盘价的40日简单移动平均)/收盘价的40日简单移动平均*100
KJ赋值:-20上穿QSX
输出XG:(BE AND BZ AND DI) OR WZBP OR KJ OR DJ1 OR DJ2

演示图片


相关选股公式

  1. 拉升找买点选股公式
  2. 短跌选股公式
  3. 中跌选股公式
  4. 长跌选股公式
  5. 短底抄底选股公式
  6. BIAS绝密买点选股公式
  7. 妖股拉升选股公式
  8. 乖离抄底选股公式
  9. 起死回生选股公式
  10. 乖离率上穿0轴抓涨停选股公式