结构形成选股公式

发布时间:2020-07-02

选股公式源码

DIF:=100*(EMA(CLOSE,12)-EMA(CLOSE,26));
DEA:=EMA(DIF,9);
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(macd,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1));
结构形成:FILTER(TG,20);

选股公式翻译

DIF赋值:100*(收盘价的12日指数移动平均-收盘价的26日指数移动平均)
DEA赋值:DIF的9日指数移动平均
金叉赋值:DIF上穿DEA
M1赋值:上次金叉距今天数
M2赋值:M1+1日前的上次金叉距今天数
M3赋值:M2+M1+2日前的上次金叉距今天数
CH1赋值:M1+1日内收盘价的最高值
DIFH1赋值:M1+1日内DIF的最高值
CH2赋值:M1+1日前的CH1
DIFH2赋值:M1+1日前的DIFH1
CH3赋值:M1+1日前的CH2
DIFH3赋值:M1+1日前的DIFH2
PDIFH2赋值:如果DIFH2>0,返回DIFH2的对数的整数部分-1,否则返回-DIFH2的对数的整数部分-1
MDIFH2赋值:DIFH2/10的PDIFH2乘幂的整数部分
PDIFH3赋值:如果DIFH3>0,返回DIFH3的对数的整数部分-1,否则返回-DIFH3的对数的整数部分-1
MDIFH3赋值:DIFH3/10的PDIFH3乘幂的整数部分
MDIFT2赋值:DIF/10的PDIFH2乘幂的整数部分
MDIFT3赋值:DIF/10的PDIFH3乘幂的整数部分
直接顶背离赋值:(CH1>CH2 ) AND (MDIFT20 AND 1日前的平滑异同平均>0) AND MDIFT2>=1日前的MDIFT2
隔峰顶背离赋值:(CH1>CH3 AND CH3>CH2 ) AND (MDIFT30 AND 1日前的平滑异同平均>0) AND MDIFT3>=1日前的MDIFT3
TG赋值:((MDIFT2<1日前的MDIFT2)*1日前的直接顶背离) OR ((MDIFT3<1日前的MDIFT3)*1日前的隔峰顶背离)
输出结构形成:TG的20日过滤

演示图片


相关选股公式

  1. MACD的选股运用技巧
  2. KDJ指标三金叉见底选股法
  3. KDJ指标选股方法
  4. 底部金叉选股公式
  5. KDJ指标金叉选股法
  6. 零度强势金叉选股法
  7. 章鱼哥选股公式
  8. 金叉介入点选股公式
  9. BBI金叉选股公式
  10. MMS金叉选股公式