顺势选股公式

发布时间:2021-03-21

选股公式源码

N:=29;
XA_1:=REF(CLOSE,30);
XA_2:=REF(CLOSE,1);
XA_3:=MA(CLOSE,10);
XA_4:=MA(CLOSE,20);
XA_5:=COUNT(CROSS(XA_3,XA_4) OR CROSS(XA_4,XA_3),30);
XA_6:=MA(CLOSE,N);
XA_7:=POW(CLOSE-XA_6,2);
XA_8:=MA(XA_7,N);
XA_9:=SQRT(XA_8);
XA_10:=XA_6+2*XA_9;
XA_11:=XA_6-2*XA_9;
XA_12:=(XA_10-XA_11)/XA_11;
XA_13:=MIN(OPEN,REF(CLOSE,1));
XA_14:=AMOUNT;
XA_15:=HHVBARS(AMOUNT,50);
XA_16:=HHVBARS(AMOUNT,XA_15);
XA_17:=REF(HHV(AMOUNT,25),XA_15+1);
XA_18:=XA_15<=0 OR (XA_15>0 AND XA_16<=0 AND XA_14>=XA_17);
XA_19:=COUNT((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>=9.9,150);
(MAX(XA_2,XA_1)-MIN(XA_2,XA_1))/MIN(XA_2,XA_1)<0.15 AND XA_5>=1 AND XA_3>=REF(XA_3,1) AND CLOSE>=MA(CLOSE,5) AND CLOSE>=MA(CLOSE,29) AND CLOSE>=MA(CLOSE,13) AND CLOSE>=MA(CLOSE,47) AND CLOSE>=MA(CLOSE,71) AND CLOSE>=MA(CLOSE,131) AND CLOSE>=MA(CLOSE,271) AND (CLOSE-XA_13)/XA_13>=0.03 AND CLOSE>REF(CLOSE,1) AND XA_18>=1 AND MA(CLOSE,5)>=REF(MA(CLOSE,5),1) AND CLOSE>=HHV(CLOSE,50);

选股公式翻译

N赋值:29
XA_1赋值:30日前的收盘价
XA_2赋值:1日前的收盘价
XA_3赋值:收盘价的10日简单移动平均
XA_4赋值:收盘价的20日简单移动平均
XA_5赋值:统计30日中满足XA_3上穿XA_4ORCROSS(XA_4,XA_3)的天数
XA_6赋值:收盘价的N日简单移动平均
XA_7赋值:收盘价-XA_6的2乘幂
XA_8赋值:XA_7的N日简单移动平均
XA_9赋值:XA_8的开方
XA_10赋值:XA_6+2*XA_9
XA_11赋值:XA_6-2*XA_9
XA_12赋值:(XA_10-XA_11)/XA_11
XA_13赋值:开盘价和1日前的收盘价的较小值
XA_14赋值:成交额(元)
XA_15赋值:50日内成交额(元)距今天数
XA_16赋值:XA_15日内成交额(元)距今天数
XA_17赋值:XA_15+1日前的25日内成交额(元)的最高值
XA_18赋值:XA_15<=0 OR (XA_15>0 AND XA_16<=0 AND XA_14>=XA_17)
XA_19赋值:统计150日中满足(收盘价-1日前的收盘价)/1日前的收盘价*100>=9.9的天数
(XA_2和XA_1的较大值-XA_2和XA_1的较小值)/XA_2和XA_1的较小值<0.15 AND XA_5>=1 AND XA_3>=1日前的XA_3 AND 收盘价>=收盘价的5日简单移动平均 AND 收盘价>=收盘价的29日简单移动平均 AND 收盘价>=收盘价的13日简单移动平均 AND 收盘价>=收盘价的47日简单移动平均 AND 收盘价>=收盘价的71日简单移动平均 AND 收盘价>=收盘价的131日简单移动平均 AND 收盘价>=收盘价的271日简单移动平均 AND (收盘价-XA_13)/XA_13>=0.03 AND 收盘价>1日前的收盘价 AND XA_18>=1 AND 收盘价的5日简单移动平均>=1日前的收盘价的5日简单移动平均 AND 收盘价>=50日内收盘价的最高值

演示图片

s_14076.png

相关选股公式

  1. 短进选股公式
  2. 副军师在此选股公式
  3. 军师在此选股公式
  4. 蚂转强选股公式
  5. 均上攻选股公式
  6. 神奇7日选股公式
  7. 导航标选股公式
  8. W底选股公式
  9. 下单选股公式
  10. 招招先选股公式