实用短牛选股公式

发布时间:2021-03-21

选股公式源码

TT:=240/FROMOPEN;
比:=TT;
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);
买量大:=(买盘-卖盘)/卖盘>0.4;
M8:=CONST(买量大);
买大于卖40%:=M8=1;
妖股起爆:=MA(CLOSE,25)+MA(CLOSE,25)*20/100*0.35;
选股:=CROSS(C,妖股起爆);
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:= (20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
马线:=MA(牛线,6);
预警:买大于卖40% AND 选股 AND 牛线>马线;

选股公式翻译

TT赋值:240/当前离开盘分钟数
比赋值:TT
WJ赋值:(最高价+最低价+收盘价)/3
V1赋值:如果最高价=最低价,返回1,否则返回最高价-开盘价和收盘价的较大值
V2赋值:如果最高价=最低价,返回1,否则返回收盘价和开盘价的较大值-WJ
V3赋值:如果最高价=最低价,返回1,否则返回开盘价和收盘价的较小值-最低价
V4赋值:如果最高价=最低价,返回1,否则返回WJ-收盘价和开盘价的较小值
V5赋值:成交量(手)/如果最高价=最低价,返回4,否则返回最高价-最低价
V6赋值:(V1*V5)
V7赋值:(V2*V5)
V8赋值:(V3*V5)
V9赋值:(V4*V5)
买盘1赋值:外盘*比
卖盘1赋值:内盘*比
买盘2赋值:如果ISLASTBARANDC>300,返回(V9+V8)*TT,否则返回(V9+V8)
卖盘2赋值:如果ISLASTBARANDC>300,返回(V6+V7)*TT,否则返回(V6+V7)
买盘赋值:如果ISLASTBARANDPERIOD=5ANDC<300,返回买盘1,否则返回买盘2
卖盘赋值:如果ISLASTBARANDPERIOD=5ANDC<300,返回卖盘1,否则返回卖盘2
买量大赋值:(买盘-卖盘)/卖盘>0.4
M8赋值:买量大的最后一日取值设为常数
买大于卖40%赋值:M8=1
妖股起爆赋值:收盘价的25日简单移动平均+收盘价的25日简单移动平均*20/100*0.35
选股赋值:收盘价上穿妖股起爆
MID赋值:(3*收盘价+最低价+开盘价+最高价)/6
牛线赋值:(20*MID+19*1日前的MID+18*2日前的MID+17*3日前的MID+16*4日前的MID+15*5日前的MID+14*6日前的MID+13*7日前的MID+12*8日前的MID+11*9日前的MID+10*10日前的MID+9*11日前的MID+8*12日前的MID+7*13日前的MID+6*14日前的MID+5*15日前的MID+4*16日前的MID+3*17日前的MID+2*18日前的MID+20日前的MID)/210
马线赋值:牛线的6日简单移动平均
输出预警:买大于卖40% AND 选股 AND 牛线>马线

演示图片

s_14077.png

相关选股公式

  1. 妖股显现选股公式
  2. 红倍柱选股公式
  3. 天地板妖股选股公式
  4. 妖股初成选股公式
  5. 妖股启动点选股公式
  6. 暴力妖股突破选股公式
  7. 暴妖突破选股公式
  8. 妖股锁筹选股公式
  9. 妖股跑不了选股公式
  10. 妖股起涨选股公式