背驰回调买优化选股公式

发布时间:2021-03-21

选股公式源码

下轨:=MA(REF(LLV(C,30),1),2);
QS:=IF(C>REF(C,1),(2*CLOSE+2*HIGH+OPEN+LOW)/6,(2*OPEN+2*LOW+CLOSE+HIGH)/6);
短线:=MA(SMA(QS,5,1),3);
均角:=ATAN((短线/REF(短线,1)-1)*100)*180/3.14115926;
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
VCR2:=LLV(LOW,10);
VCR3:=HHV(HIGH,25);
动力线:=EMA((CLOSE-VCR2)/(VCR3-VCR2)*4,4)*20;
生命线:=MA(动力线,3);
RSI5:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),5,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
回调买:=(AV + NEWVOL);
XGT:CROSS(回调买,0) AND 下轨<REF(下轨,1) AND 买 AND 均角<-30 AND 动力线<15 ;

选股公式翻译

下轨赋值:1日前的30日内收盘价的最低值的2日简单移动平均
QS赋值:如果收盘价>1日前的收盘价,返回(2*收盘价+2*最高价+开盘价+最低价)/6,否则返回(2*开盘价+2*最低价+收盘价+最高价)/6
短线赋值:QS的5日[1日权重]移动平均的3日简单移动平均
均角赋值:(短线/1日前的短线-1)*100的反正切*180/3.14115926
A3赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
A4赋值:A3的3日[1日权重]移动平均
A5赋值:A4的3日[1日权重]移动平均
A6赋值:3*A4-2*A5
A7赋值:收盘价-1日前的收盘价
A8赋值:100*A7的6日指数移动平均的6日指数移动平均/A7的绝对值的6日指数移动平均的6日指数移动平均
买赋值:2日内A8的最低值=7日内A8的最低值 AND 统计2日中满足A8<0的天数 AND A8上穿A8的2日简单移动平均
VCR2赋值:10日内最低价的最低值
VCR3赋值:25日内最高价的最高值
动力线赋值:(收盘价-VCR2)/(VCR3-VCR2)*4的4日指数移动平均*20
生命线赋值:动力线的3日简单移动平均
RSI5赋值:(((收盘价-1日前的收盘价)和0的较大值的5日[1日权重]移动平均 / (收盘价-1日前的收盘价)的绝对值的5日[1日权重]移动平均) * 100)
TR1赋值:(最高价-最低价)和(最高价-1日前的收盘价)的绝对值的较大值和(最低价-1日前的收盘价)的绝对值的较大值的10日累和
HD赋值:(最高价 - 1日前的最高价)
LD赋值:(1日前的最低价 - 最低价)
DMP赋值:如果((HD>0)AND(HD>LD)),返回HD,否则返回0的10日累和
DMM赋值:如果((LD>0)AND(LD>HD)),返回LD,否则返回0的10日累和
PDI赋值:((DMP * 100) / TR1)
MDI赋值:((DMM * 100) / TR1)
ADX赋值:(((MDI-PDI)的绝对值/(MDI+PDI))*100)的5日简单移动平均
AV赋值:(RSI5 + ADX)
DXR赋值:(((ADX + 5日前的ADX) / 2) + RSI5)
WR10赋值:((100 * (10日内最高价的最高值 - 收盘价)) / (10日内最高价的最高值 - 10日内最低价的最低值))
NEWVOL赋值:(RSI5 - WR10)
回调买赋值:(AV + NEWVOL)
输出XGT:回调买上穿0 AND 下轨<1日前的下轨 AND 买 AND 均角<-30 AND 动力线<15 

演示图片

s_14083.png

相关选股公式

  1. 一招定乾坤选股公式
  2. 活跃度比选股公式
  3. 获利筹码选股公式
  4. RSI买选股公式
  5. R底背选股公式
  6. 量能操作选股公式
  7. 财神到短线选股公式
  8. 专抓起爆点选股公式
  9. 短线投资者的选股标准
  10. 抄底赢家选股公式