线上擒牛选股公式

发布时间:2021-03-21

选股公式源码

VAR0 := (MACD.MACD > REF(MACD.macd,1)) AND (C >= REF(HHV(C,32),1));
VAR1 := C >= REF(HHV(HIGH,12),1);
VAR2 := (OPEN / MA(C,5)) < 0.9996;
VAR3 := ((((OPEN / MA(C,10)) > 0.999) AND ((OPEN / MA(C,10)) < 1.04)) OR (((OPEN / MA(C,20)) > 0.99) AND ((OPEN / MA(C,20)) < 1.04))) OR (((OPEN / MA(C,30)) > 0.99) AND ((OPEN / MA(C,30)) < 1.04));
VAR4 := ((C / REF(C,1)) >= 1.05) OR ((C / OPEN) > 1.05);
VAR5 := REF(HHV(HIGH,30),1);
VAR6 := REF(LLV(LOW,30),1);
VAR7 := ((VAR5 - VAR6) / VAR6) * 100;
VAR8 := REF(HHV(HIGH,13),1);
VAR9 := REF(LLV(LOW,13),1);
VAR10 := ((VAR8 - VAR9) / VAR9) * 100;
VAR11 := MA(C,5);
VAR12 := MA(C,10);
VAR13 := MA(C,20);
VAR14 := ((ATAN(((VAR11 / REF(VAR11,1)) - 1) * 100)) * 180) / 3.1416;
VAR15 := ((ATAN(((VAR12 / REF(VAR12,1)) - 1) * 100)) * 180) / 3.1416;
VAR16 := ((ATAN(((VAR13 / REF(VAR13,1)) - 1) * 100)) * 180) / 3.1416;
VAR17 := ((C - MA(C,60)) / MA(C,60)) * 100;
VAR18 := (COUNT(VAR17 < 35,100)) >= 70;
VAR19 := EMA((SLOPE(C,26) * 20) + C,30);
VAR20 := HHV(VAR19,60);
VAR21 := CROSS(C,VAR20);
VAR22 := ((ATAN(((VAR20 / REF(VAR20,1)) - 1) * 100)) * 180) / 3.1416;
线上擒牛 : (((((((((((VAR0 AND VAR1) AND VAR3) AND VAR2) AND VAR4) AND VAR18) AND VAR21) AND (VAR22 < 45)) AND ((VAR20 / VAR19) < 1.02)) AND ((COUNT((VAR7 < 33) AND (VAR10 < 21),10)) = 10)) AND (VAR16 > 24)) AND ((VAR14 > 57) OR (VAR15 > 52))) AND (REF((COUNT((C / REF(C,1)) > 1.055,3)) < 1,1));

选股公式翻译

赋值: (平滑异同平均的MACD > 1日前的平滑异同平均的MACD) AND (收盘价 >= 1日前的32日内收盘价的最高值)
赋值: 收盘价 >= 1日前的12日内最高价的最高值
赋值: (开盘价 / 收盘价的5日简单移动平均) < 0.9996
赋值: ((((开盘价 / 收盘价的10日简单移动平均) > 0.999) AND ((开盘价 / 收盘价的10日简单移动平均) < 1.04)) OR (((开盘价 / 收盘价的20日简单移动平均) > 0.99) AND ((开盘价 / 收盘价的20日简单移动平均) < 1.04))) OR (((开盘价 / 收盘价的30日简单移动平均) > 0.99) AND ((开盘价 / 收盘价的30日简单移动平均) < 1.04))
赋值: ((收盘价 / 1日前的收盘价) >= 1.05) OR ((收盘价 / 开盘价) > 1.05)
赋值: 1日前的30日内最高价的最高值
赋值: 1日前的30日内最低价的最低值
赋值: ((VAR5 - VAR6) / VAR6) * 100
赋值: 1日前的13日内最高价的最高值
赋值: 1日前的13日内最低价的最低值
赋值: ((VAR8 - VAR9) / VAR9) * 100
赋值: 收盘价的5日简单移动平均
赋值: 收盘价的10日简单移动平均
赋值: 收盘价的20日简单移动平均
赋值: ((((VAR11/1日前的VAR11)-1)*100的反正切) * 180) / 3.1416
赋值: ((((VAR12/1日前的VAR12)-1)*100的反正切) * 180) / 3.1416
赋值: ((((VAR13/1日前的VAR13)-1)*100的反正切) * 180) / 3.1416
赋值: ((收盘价 - 收盘价的60日简单移动平均) / 收盘价的60日简单移动平均) * 100
赋值: (统计100日中满足VAR17<35的天数) >= 70
赋值: (收盘价的26日线性回归斜率*20)+收盘价的30日指数移动平均
赋值: 60日内VAR19的最高值
赋值: 收盘价上穿VAR20
赋值: ((((VAR20/1日前的VAR20)-1)*100的反正切) * 180) / 3.1416
输出线上擒牛 : (((((((((((VAR0 AND VAR1) AND VAR3) AND VAR2) AND VAR4) AND VAR18) AND VAR21) AND (VAR22 < 45)) AND ((VAR20 / VAR19) < 1.02)) AND ((统计10日中满足(VAR7<33)AND(VAR10<21)的天数) = 10)) AND (VAR16 > 24)) AND ((VAR14 > 57) OR (VAR15 > 52))) AND (1日前的(统计3日中满足(收盘价/1日前的收盘价)>1.055的天数)<1)

演示图片

s_14096.png

相关选股公式

  1. MACD钝化结构形成选股公式
  2. 零上第一次金选股公式
  3. 妖牛启动选股公式
  4. MACD凹底淘金选股公式
  5. 钻石拉升选股公式
  6. 回踩起飞选股公式
  7. 背离前启动点选股公式
  8. 等你飞选股公式
  9. 金叉MACD选股公式
  10. MACD日周月共振选股公式