抄底类型选股公式

发布时间:2021-03-28

选股公式源码

X_1:=REF(CLOSE,1);
X_2:=SMA(MAX(CLOSE-X_1,0),2,1)/SMA(ABS(CLOSE-X_1),2,1)*100-50;
X_3:=X_2<(-45);
X_4:=CROSS((-40),X_2);
X_5:=X_3 OR X_4;
X_6:=X_5 AND CLOSE>OPEN;
X_7:=10;
X_9:=100*(HHV(HIGH,X_7)-CLOSE)/(HHV(HIGH,X_7)-LLV(LOW,X_7));
X_10:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));
X_11:=X_9>90 OR X_10>90;
X_12:=5;
X_16:=IF(DATE<1900612,1,1);
X_17:=(HIGH+MAX(CLOSE,OPEN))/2;
X_18:=MA(X_17,3);
X_22:=(HIGH+LOW+CLOSE+OPEN)/4;
X_23:=MA(X_22,3);
X_24:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2) AND REF(MIN(CLOSE,OPEN),1)>REF(MAX(CLOSE,OPEN),2);
X_26:=(X_23-(REF(X_23,1)-X_23)-LOW)/LOW*100;
X_27:=(X_18+(X_18-REF(X_18,1))-LOW)/LOW*100;
X_30:=IF(X_24,X_27,X_26);
X_33:=SMA(LOW,4,3);
X_36:=REF(LOW,1)-HHV(MAX(REF(LOW,2),REF(LOW,1))-MIN(REF(LOW,2),REF(LOW,1)),2);
X_37:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2);
X_38:=LOW<=X_36+X_36*0.01 AND OPEN>REF(OPEN,2) AND OPEN>=REF(LOW,3) AND COUNT(CLOSE>OPEN,7)>3;
X_39:=(X_36-LOW)/LOW*100;
X_41:=(X_33-LOW)/LOW>X_12/1000;
X_42:=X_41;
X_43:=(REF(HIGH,1)-OPEN)/OPEN*100-(REF(MAX(CLOSE,OPEN),2)-REF(MAX(CLOSE,OPEN),1))/REF(MAX(CLOSE,OPEN),1)*100;
X_44:=IF(X_37,X_39,X_43);
X_45:=X_39+X_44>2;
X_46:=IF(X_37,X_38,X_45) AND X_30>2;
X_47:=X_16 AND X_42 AND X_46;
信号:REF(X_47,1) AND LOW<REF(LOW/0.995,1) AND X_6 AND X_11,COLORYELLOW;

选股公式翻译

X_1赋值:1日前的收盘价
X_2赋值:收盘价-X_1和0的较大值的2日[1日权重]移动平均/收盘价-X_1的绝对值的2日[1日权重]移动平均*100-50
X_3赋值:X_2<(-45)
X_4赋值:(-40)上穿X_2
X_5赋值:X_3 OR X_4
X_6赋值:X_5 AND 收阳线
X_7赋值:10
X_9赋值:100*(X_7日内最高价的最高值-收盘价)/(X_7日内最高价的最高值-X_7日内最低价的最低值)
X_10赋值:100*(6日内最高价的最高值-收盘价)/(6日内最高价的最高值-6日内最低价的最低值)
X_11赋值:X_9>90 OR X_10>90
X_12赋值:5
X_16赋值:如果日期<1900612,返回1,否则返回1
X_17赋值:(最高价+收盘价和开盘价的较大值)/2
X_18赋值:X_17的3日简单移动平均
X_22赋值:(最高价+最低价+收盘价+开盘价)/4
X_23赋值:X_22的3日简单移动平均
X_24赋值:1日前的(收盘价+开盘价)/2>2日前的(收盘价+开盘价)/2 AND 1日前的收盘价和开盘价的较小值>2日前的收盘价和开盘价的较大值
X_26赋值:(X_23-(1日前的X_23-X_23)-最低价)/最低价*100
X_27赋值:(X_18+(X_18-1日前的X_18)-最低价)/最低价*100
X_30赋值:如果X_24,返回X_27,否则返回X_26
X_33赋值:最低价的4日[3日权重]移动平均
X_36赋值:1日前的最低价-2日内2日前的最低价和1日前的最低价的较大值-2日前的最低价和1日前的最低价的较小值的最高值
X_37赋值:1日前的(收盘价+开盘价)/2>2日前的(收盘价+开盘价)/2
X_38赋值:最低价<=X_36+X_36*0.01 AND 开盘价>2日前的开盘价 AND 开盘价>=3日前的最低价 AND 统计7日中满足收阳线的天数>3
X_39赋值:(X_36-最低价)/最低价*100
X_41赋值:(X_33-最低价)/最低价>X_12/1000
X_42赋值:X_41
X_43赋值:(1日前的最高价-开盘价)/开盘价*100-(2日前的收盘价和开盘价的较大值-1日前的收盘价和开盘价的较大值)/1日前的收盘价和开盘价的较大值*100
X_44赋值:如果X_37,返回X_39,否则返回X_43
X_45赋值:X_39+X_44>2
X_46赋值:如果X_37,返回X_38,否则返回X_45 AND X_30>2
X_47赋值:X_16 AND X_42 AND X_46
输出信号:1日前的X_47 AND 最低价<1日前的最低价/0.995 AND X_6 AND X_11,画黄色

演示图片

s_14108.png

相关选股公式

  1. 三阴抄底选股公式
  2. 抄底赢家选股公式
  3. 圣剑抄底选股公式
  4. CCIRSI抄底选股公式
  5. 抄底抓牛选股公式
  6. 真敢全仓抄底选股公式
  7. 潜龙抄底选股公式
  8. 抄底吃大波段选股公式
  9. 参考抄底选股公式
  10. 急跌抄底选股公式