涨买入选股公式

发布时间:2021-09-05

选股公式源码

DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIFF,5);
A1:=DIFF>DEA;
MACD金叉:=IF(A1,1,0),COLORYELLOW;
RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
A2:=K>D;
KDJ金叉:=IF(A2,2,0),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
A3:=RSI1>RSI2;
RSI金叉:=IF(A3,3,0),COLORYELLOW;
RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
A4:=LWR1>LWR2;
LWR金叉:=IF(A4,4,0),COLORYELLOW;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
A5:=CLOSE>BBI;
BBI金叉:=IF(A5,5,0),COLORYELLOW;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
A6:=MMS>MMM;
买入:IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0),COLORBLUE,LINETHICK2;

选股公式翻译

DIFF赋值:收盘价的8日指数移动平均-收盘价的13日指数移动平均
DEA赋值:DIFF的5日指数移动平均
A1赋值:DIFF>DEA
MACD金叉赋值:如果A1,返回1,否则返回0,画黄色
RSV1赋值:(收盘价-8日内最低价的最低值)/(8日内最高价的最高值-8日内最低价的最低值)*100
K赋值:RSV1的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
A2赋值:K>D
KDJ金叉赋值:如果A2,返回2,否则返回0,画黄色
LC赋值:1日前的收盘价
RSI1赋值:(收盘价-LC和0的较大值的5日[1日权重]移动平均)/(收盘价-LC的绝对值的5日[1日权重]移动平均)*100
RSI2赋值:(收盘价-LC和0的较大值的13日[1日权重]移动平均)/(收盘价-LC的绝对值的13日[1日权重]移动平均)*100
A3赋值:RSI1>RSI2
RSI金叉赋值:如果A3,返回3,否则返回0,画黄色
RSV赋值:-(13日内最高价的最高值-收盘价)/(13日内最高价的最高值-13日内最低价的最低值)*100
LWR1赋值:RSV的3日[1日权重]移动平均
LWR2赋值:LWR1的3日[1日权重]移动平均
A4赋值:LWR1>LWR2
LWR金叉赋值:如果A4,返回4,否则返回0,画黄色
BBI赋值:(收盘价的3日简单移动平均+收盘价的6日简单移动平均+收盘价的12日简单移动平均+收盘价的24日简单移动平均)/4
A5赋值:收盘价>BBI
BBI金叉赋值:如果A5,返回5,否则返回0,画黄色
MTM赋值:收盘价-1日前的收盘价
MMS赋值:100*MTM的5日指数移动平均的3日指数移动平均/MTM的绝对值的5日指数移动平均的3日指数移动平均
MMM赋值:100*MTM的13日指数移动平均的8日指数移动平均/MTM的绝对值的13日指数移动平均的8日指数移动平均
A6赋值:MMS>MMM
输出涨买入:如果(A1ANDA2ANDA3ANDA4ANDA5ANDA6)ANDREF(A1ANDA2ANDA3ANDA4ANDA5ANDA6,1)=0,返回7,否则返回0,画蓝色,线宽为2

演示图片

s_14397.png

相关选股公式

  1. 突破当天买入选股公式
  2. 核弹选股公式
  3. 超资介入选股公式
  4. 极限抄底选股公式
  5. 起死回升选股公式
  6. 底部擒涨停选股公式
  7. 趋势大破选股公式
  8. 凤凰涅槃选股公式
  9. N字突破买点选股公式
  10. 涨停起爆选股公式