唯我独尊选股公式

发布时间:2021-10-05

选股公式源码

X_1:=CROSS(KDJ.K#WEEK,KDJ.D#WEEK);
X_2:=KD.K#WEEK(9,3,3);
X_3:=KD.D#WEEK(9,3,3);
X_4:=FILTER(CROSS(X_2,X_3) AND REF(X_3,1)<30,13);
X_5:=FILTER(CROSS(X_2,X_3) AND REF(X_3,1)>30,13);
X_6:=X_4;
X_7:=MACD.DIF#WEEK(12,26,9);
X_8:=macd.DEA#WEEK(12,26,9);
X_9:=10;
X_10:=5;
X_11:=FILTER(CROSS(X_7,X_8) AND REF(X_8,1)<0,13);
X_12:=X_11;
X_13:=(HHV(HIGH,X_9)-CLOSE)/(HHV(HIGH,X_9)-LLV(LOW,X_9))*200-125;
X_14:=SMA(X_13,X_10,1)+15;
X_15:=(CLOSE-LLV(LOW,X_9))/(HHV(HIGH,X_9)-LLV(LOW,X_9))*200-105;
X_16:=SMA(X_15,X_10,1)+15;
X_17:=CROSS(X_16,X_14);
X_18:=X_12 AND X_11 AND X_1;
选股:X_18;

选股公式翻译

X_1赋值:KDJ的K[取周线数据]上穿KDJ的D[取周线数据]
X_2赋值:随机指标KD的K[取周线数据](9,3,3)
X_3赋值:随机指标KD的D[取周线数据](9,3,3)
X_4赋值:X_2上穿X_3ANDREF(X_3,1)<30的13日过滤
X_5赋值:X_2上穿X_3ANDREF(X_3,1)>30的13日过滤
X_6赋值:X_4
X_7赋值:平滑异同平均的DIF[取周线数据](12,26,9)
X_8赋值:平滑异同平均的DEA[取周线数据](12,26,9)
X_9赋值:10
X_10赋值:5
X_11赋值:X_7上穿X_8ANDREF(X_8,1)<0的13日过滤
X_12赋值:X_11
X_13赋值:(X_9日内最高价的最高值-收盘价)/(X_9日内最高价的最高值-X_9日内最低价的最低值)*200-125
X_14赋值:X_13的X_10日[1日权重]移动平均+15
X_15赋值:(收盘价-X_9日内最低价的最低值)/(X_9日内最高价的最高值-X_9日内最低价的最低值)*200-105
X_16赋值:X_15的X_10日[1日权重]移动平均+15
X_17赋值:X_16上穿X_14
X_18赋值:X_12 AND X_11 AND X_1
输出选股:X_18

演示图片

s_14416.png

相关选股公式

  1. 超资介入选股公式
  2. 底部擒涨停选股公式
  3. 趋势大破选股公式
  4. 强势黑马爆点选股公式
  5. 双龙抄底选股公式
  6. 底部出手选股公式
  7. 大三浪主升选股公式
  8. 悄悄潜伏选股公式
  9. 美人腿选股公式
  10. 龙头战法选股公式