底部出手选股公式

发布时间:2021-10-31

选股公式源码

difF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
主力潜伏:=COUNT(macd<0,10)=10;
TYP:=(HIGH+LOW+CLOSE)/3;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X3:=IF(DATE<99999999,1,1);
BA:=IF((DATETODAY(DATE))<99999999,1,1);
K1:=SMA(RSV,3,1);
D:=SMA(K1,3,1);
J1:=3*K1-2*D;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=(DIF1-DEA1)*2;
何氏抄底:=REF(J1,1)<10  AND REF(MACD1,1)<REF(MACD1,2) AND MACD1>REF(MACD1,1) AND MACD1<0 AND  CCI>REF(CCI,1)*BA AND (REF(CCI,2)<-100 OR REF(CCI,3)<-100)*X3;
底涨:何氏抄底 AND 主力潜伏;

选股公式翻译

DIFF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIFF的9日指数移动平均
MACD赋值:2*(DIFF-DEA)
主力潜伏赋值:统计10日中满足MACD<0的天数=10
TYP赋值:(最高价+最低价+收盘价)/3
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
X3赋值:如果日期<99999999,返回1,否则返回1
BA赋值:如果(日期对应的转换天数)<99999999,返回1,否则返回1
K1赋值:RSV的3日[1日权重]移动平均
D赋值:K1的3日[1日权重]移动平均
J1赋值:3*K1-2*D
CCI赋值:(TYP-TYP的14日简单移动平均)/(0.015*TYP的14日平均绝对偏差)
DIF1赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA1赋值:DIF1的9日指数移动平均
MACD1赋值:(DIF1-DEA1)*2
何氏抄底赋值:1日前的J1<10 AND 1日前的MACD1<2日前的MACD1 AND MACD1>1日前的MACD1 AND MACD1<0 AND CCI>1日前的CCI*BA AND (2日前的CCI<-100 OR 3日前的CCI<-100)*X3
输出底涨:何氏抄底 AND 主力潜伏

演示图片

s_14469.png

相关选股公式

  1. 牛股低吸优化版选股公式
  2. 狙击强势股选股公式
  3. 股市战斗机选股公式
  4. 金坑抄底选股公式
  5. 板后反包选股公式
  6. 提前准备抄底选股公式
  7. 神机妙算选股公式
  8. 特高抄底选股公式
  9. 底部主升起爆选股公式
  10. 抄底至宝选股公式