猎鹰行动选股公式

发布时间:2021-11-14

选股公式源码

GK1:=(C+L+H)/3;
GK2:=EMA(GK1,6);
GK3:=EMA(GK2,5);
HJ1:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
HJ2:=FILTER(HJ1,10);
HJ3:=BArslAst(HJ2);
HJ4:=REF(HIGH,HJ3+2);
HJ5:=REF(HIGH,HJ3+1);
HJ6:=REF(HIGH,HJ3);
HJ7:=MAX(HJ4,HJ5);
HJ8:=MAX(HJ7,HJ6);
HJ9:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
MV1:=HJ3<150;
MV2:=(OPEN-HJ8)/HJ8*100<30;
MV3:=(CLOSE-LLV(LOW,HJ3))/LLV(LOW,HJ3)*100<50;
MV4:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
MV5:=VOL/MA(VOL,5)<3.5;
MV6:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
BA:=HJ9 AND MV1 AND MV2 AND MV3 AND MV4 AND MV5 AND MV6;
BL:=FILTER(BA,15);
PL1:=(((CLOSE-MA(CLOSE,54))/MA(CLOSE,54))<0.1);
PL2:=(((CLOSE-MA(CLOSE,20))/MA(CLOSE,10))<0.3);
OUU:=(((PL1=1) AND (PL2=1))*0.2);
IH:=((((OUU=0) AND (REF(OUU,1)=0.2)) AND (REF((COUNT((OUU=0.2),10)=10),1)=1))*-0.1);
NY:=IH=-0.1;
XDF:=(BL OR NY);
VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);
FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
DRA:=XDF AND C/REF(C,1)>1.025 AND FLIGA AND VARAA;
YF:=FINANCE(55)/FINANCE(20)>0.005;
猎鹰:CROSS(GK2,GK3) AND YF AND DRA AND FINANCE(44)>5;

选股公式翻译

GK1赋值:(收盘价+最低价+最高价)/3
GK2赋值:GK1的6日指数移动平均
GK3赋值:GK2的5日指数移动平均
HJ1赋值:(3日前的收盘价-收盘价)/3日前的收盘价*100>5
HJ2赋值:HJ1的10日过滤
HJ3赋值:上次HJ2距今天数
HJ4赋值:HJ3+2日前的最高价
HJ5赋值:HJ3+1日前的最高价
HJ6赋值:HJ3日前的最高价
HJ7赋值:HJ4和HJ5的较大值
HJ8赋值:HJ7和HJ6的较大值
HJ9赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>5
MV1赋值:HJ3<150
MV2赋值:(开盘价-HJ8)/HJ8*100<30
MV3赋值:(收盘价-HJ3日内最低价的最低值)/HJ3日内最低价的最低值*100<50
MV4赋值:(收盘价-5日前的开盘价)/5日前的开盘价*100<30
MV5赋值:成交量(手)/成交量(手)的5日简单移动平均<3.5
MV6赋值:(收盘价-89日前的收盘价)/89日前的收盘价*100<80
BA赋值:HJ9 AND MV1 AND MV2 AND MV3 AND MV4 AND MV5 AND MV6
BL赋值:BA的15日过滤
PL1赋值:(((收盘价-收盘价的54日简单移动平均)/收盘价的54日简单移动平均)<0.1)
PL2赋值:(((收盘价-收盘价的20日简单移动平均)/收盘价的10日简单移动平均)<0.3)
OUU赋值:(((PL1=1) AND (PL2=1))*0.2)
IH赋值:((((OUU=0) AND (1日前的OUU=0.2)) AND (1日前的(统计10日中满足(OUU=0.2)的天数=10)=1))*-0.1)
NY赋值:IH=-0.1
XDF赋值:(BL OR NY)
VARA赋值:以成交量(手)/当前流通股本(手)为权重成交额(元)/成交量(手)/100的动态移动平均
VARAA赋值:现价/(1日前的收盘价)>1.05 AND (现价/开盘价>1.05)
FLIGA赋值:(成交量(手)/1日前的成交量(手)>1.2 AND 统计1日中满足收阳线的天数) OR (最低价>1日前的最高价 AND 统计1日中满足收阴线的天数 AND 成交量(手)/1日前的成交量(手)>1.2)
DRA赋值:XDF AND 收盘价/1日前的收盘价>1.025 AND FLIGA AND VARAA
YF赋值:研发费用/营业收入>0.005
输出猎鹰:GK2上穿GK3 AND YF AND DRA AND 收入同比%>5

演示图片

s_14525.png

相关选股公式

  1. 赵龙虎选股公式
  2. 钻石底风向标选股公式
  3. 天外飞仙选股公式
  4. 慢慢富起来选股公式
  5. 乾坤猎牛选股公式
  6. 牛什么牛选股公式
  7. 小目标选股公式
  8. 雄霸天下选股公式
  9. 更上层楼选股公式
  10. 妖起来选股公式