横盘区间突破选股公式

发布时间:2021-11-21

选股公式源码

MA5:=MA(C,5);
MA20:=MA(C,20);
MA60:=MA(C,60);
涨幅:=(C-REF(C,1))/REF(C,1)>0.03;
实体涨幅1:=(C-O)/O>0.01;
放量:=(VOL-REF(MA(VOL,5),1))/REF(MA(VOL,5),1)>0.5;
站上均线:=C>MA5 AND C>MA20 AND C>MA60;
突破最高价:=C>HHV(REF(C,1),39);
区间涨幅1:=(REF(C,1)-REF(C,41))/REF(C,41)>-0.08 AND (REF(C,1)-REF(C,41))/REF(C,41)<0.08;
区间振幅:=(REF(HHV(H,40),1)-REF(LLV(L,40),1))/REF(LLV(L,40),1)<0.16;
横盘突破:涨幅 AND 实体涨幅1 AND 放量 AND 站上均线 AND 突破最高价 AND 区间涨幅1 AND 区间振幅 ;

选股公式翻译

MA5赋值:收盘价的5日简单移动平均
MA20赋值:收盘价的20日简单移动平均
MA60赋值:收盘价的60日简单移动平均
涨幅赋值:(收盘价-1日前的收盘价)/1日前的收盘价>0.03
实体涨幅1赋值:(收盘价-开盘价)/开盘价>0.01
放量赋值:(成交量(手)-1日前的成交量(手)的5日简单移动平均)/1日前的成交量(手)的5日简单移动平均>0.5
站上均线赋值:收盘价>MA5 AND 收盘价>MA20 AND 收盘价>MA60
突破最高价赋值:收盘价>39日内1日前的收盘价的最高值
区间涨幅1赋值:(1日前的收盘价-41日前的收盘价)/41日前的收盘价>-0.08 AND (1日前的收盘价-41日前的收盘价)/41日前的收盘价<0.08
区间振幅赋值:(1日前的40日内最高价的最高值-1日前的40日内最低价的最低值)/1日前的40日内最低价的最低值<0.16
输出横盘突破:涨幅 AND 实体涨幅1 AND 放量 AND 站上均线 AND 突破最高价 AND 区间涨幅1 AND 区间振幅 

演示图片

s_14538.png

相关选股公式

  1. 黑马寻牛选股公式
  2. 游资进场选股公式
  3. 波段红绿灯选股公式
  4. 多头擒妖选股公式
  5. 霸气平台突破选股公式
  6. 蓄势突破选股公式
  7. 尾盘擒妖选股公式
  8. 潜伏准备选股公式
  9. 突破平台整理选股公式
  10. 主板捉妖选股公式