强势小盘选股公式

发布时间:2021-11-21

选股公式源码

MA21:=MA(CLOSE,21);
BTMA21:= CLOSE>MA21 AND REF(CLOSE,1)>REF(MA21,1) AND REF(CLOSE,2)>REF(MA21,2) AND REF(CLOSE,3)>REF(MA21,3);
VOL120:=MA(VOL,120);
VOL1:= VOL > VOL120 AND REF(VOL,1) > REF(VOL120,1) AND ( REF(VOL,2) > REF(VOL120,2) OR REF(VOL,3) > REF(VOL120,3) OR REF(VOL,4) > REF(VOL120,4) );
VOL2:= VOL > VOL120 AND REF(VOL,1) < REF(VOL120,1) AND ( REF(VOL,2) > REF(VOL120,2) OR REF(VOL,3) > REF(VOL120,3) );
VOL3:= VOL < VOL120 AND REF(VOL,1) > REF(VOL120,1) AND  REF(VOL,2) > REF(VOL120,2) AND ( REF(VOL,3) > REF(VOL120,3) OR REF(VOL,4) > REF(VOL120,4) OR REF(VOL,5) > REF(VOL120,5));
VOL4:= VOL < VOL120 AND REF(VOL,1) > REF(VOL120,1) AND  REF(VOL,2) < REF(VOL120,2) AND ( REF(VOL,3) > REF(VOL120,3) OR REF(VOL,4) > REF(VOL120,4));
VOL5:= VOL < VOL120 AND REF(VOL,1) < REF(VOL120,1) AND  REF(VOL,2) > REF(VOL120,2) AND REF(VOL,3) > REF(VOL120,3) AND (REF(VOL,4) > REF(VOL120,4) OR REF(VOL,5) > REF(VOL120,5) OR REF(VOL,6) > REF(VOL120,6));
VOL6:= VOL < VOL120 AND REF(VOL,1) < REF(VOL120,1) AND  REF(VOL,2) > REF(VOL120,2) AND REF(VOL,3) < REF(VOL120,3) AND (REF(VOL,4) > REF(VOL120,4) OR REF(VOL,5) > REF(VOL120,5) );
BTVOL120:=VOL1 OR VOL2 OR VOL3 OR VOL4 OR VOL5 OR VOL6;
小盘:=(CAPITAL<10000000);
强势选股:小盘 AND BTMA21 AND BTVOL120;

选股公式翻译

MA21赋值:收盘价的21日简单移动平均
BTMA21赋值: 收盘价>MA21 AND 1日前的收盘价>1日前的MA21 AND 2日前的收盘价>2日前的MA21 AND 3日前的收盘价>3日前的MA21
VOL120赋值:成交量(手)的120日简单移动平均
VOL1赋值: 成交量(手) > VOL120 AND 1日前的成交量(手) > 1日前的VOL120 AND ( 2日前的成交量(手) > 2日前的VOL120 OR 3日前的成交量(手) > 3日前的VOL120 OR 4日前的成交量(手) > 4日前的VOL120 )
VOL2赋值: 成交量(手) > VOL120 AND 1日前的成交量(手) < 1日前的VOL120 AND ( 2日前的成交量(手) > 2日前的VOL120 OR 3日前的成交量(手) > 3日前的VOL120 )
VOL3赋值: 成交量(手) < VOL120 AND 1日前的成交量(手) > 1日前的VOL120 AND 2日前的成交量(手) > 2日前的VOL120 AND ( 3日前的成交量(手) > 3日前的VOL120 OR 4日前的成交量(手) > 4日前的VOL120 OR 5日前的成交量(手) > 5日前的VOL120)
VOL4赋值: 成交量(手) < VOL120 AND 1日前的成交量(手) > 1日前的VOL120 AND 2日前的成交量(手) < 2日前的VOL120 AND ( 3日前的成交量(手) > 3日前的VOL120 OR 4日前的成交量(手) > 4日前的VOL120)
VOL5赋值: 成交量(手) < VOL120 AND 1日前的成交量(手) < 1日前的VOL120 AND 2日前的成交量(手) > 2日前的VOL120 AND 3日前的成交量(手) > 3日前的VOL120 AND (4日前的成交量(手) > 4日前的VOL120 OR 5日前的成交量(手) > 5日前的VOL120 OR 6日前的成交量(手) > 6日前的VOL120)
VOL6赋值: 成交量(手) < VOL120 AND 1日前的成交量(手) < 1日前的VOL120 AND 2日前的成交量(手) > 2日前的VOL120 AND 3日前的成交量(手) < 3日前的VOL120 AND (4日前的成交量(手) > 4日前的VOL120 OR 5日前的成交量(手) > 5日前的VOL120 )
BTVOL120赋值:VOL1 OR VOL2 OR VOL3 OR VOL4 OR VOL5 OR VOL6
小盘赋值:(当前流通股本(手)<10000000)
输出强势选股:小盘 AND BTMA21 AND BTVOL120

演示图片

s_14539.png

相关选股公式

  1. 赵龙虎选股公式
  2. 钻石底风向标选股公式
  3. 天外飞仙选股公式
  4. 慢慢富起来选股公式
  5. 乾坤猎牛选股公式
  6. 牛什么牛选股公式
  7. 小目标选股公式
  8. 雄霸天下选股公式
  9. 更上层楼选股公式
  10. 妖起来选股公式