一路飞扬选股公式

发布时间:2021-11-21

选股公式源码

VAR11:=3*SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,5,1)-2*Sma(SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,180,1),15,1);
超级主升:=EMA(VAR11,5);
主升1:=超级主升-100;
D1:=EMA(C,5);
D2:=(EMA(C,1)+EMA(C,5)+EMA(C,10)+EMA(C,15)+EMA(C,20)+EMA(C,25)+EMA(C,30)+EMA(C,35)+EMA(C,40)+EMA(C,45)+EMA(C,50)+EMA(C,55)+EMA(C,60)+EMA(C,65)+EMA(C,70)+EMA(C,75)+EMA(C,80)+EMA(C,85)+EMA(C,90)+EMA(C,95)+EMA(C,100)+EMA(C,105)+EMA(C,110)+EMA(C,115)+EMA(C,120)+EMA(C,125)+EMA(C,130)+EMA(C,135)+EMA(C,140)+EMA(C,150))/30;
DDE:=(D1/D2)*100;
主升2:=DDE-110;
A:=(H+L+2*C)/4;
A1:=(A-REF(A,3))/3+A;
MA5:=EMA(A1,7);
J:=EMA(HHV(A1,20),60);
CB5:=EMA(COst(80),30);
HMX:=EMA(1.4*EMA(FORCAST(A1,20),40),20);
金牛线:=(J+CB5+HMX)/3;
UP:=EMA(EMA(C*1.38,50),50);
白色:=SMA(HIGH,21,2)*1.05;
黄色:=SMA(LOW,21,2)*0.95;
中线:=(白色+黄色)/2;
UP1:=中线+2*STD(中线,20);
CC:=Abs((2*CLOSE+HIGH+LOW)/4-MA(A1,20))/MA(A1,20);
DD:=DMA(CLOSE,CC);
通道3:=(1+9/100)*DD;
界限:=(REF((金牛线+UP+EMA(UP1*1.04,40)+通道3)/4,10)+MA(C,20)*1.04)/2;
AHC1:=H*VOL;
AHC24:=EMA((EXPMA(AHC1,180)/EXPMA(VOL,180)+EXPMA(AHC1,360)/EXPMA(VOL,360)+EXPMA(AHC1,720)/EXPMA(VOL,720)+EXPMA(AHC1,1440)/EXPMA(VOL,1440))/4,34);
C上X:=1.06*AHC24;
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
上X:=1.06*AHC22;
AHC23:=EMA((EXPMA(AHC1,5)/EXPMA(VOL,5)+EXPMA(AHC1,10)/EXPMA(VOL,10)+EXPMA(AHC1,20)/EXPMA(VOL,20)+EXPMA(AHC1,40)/EXPMA(VOL,40))/4,34);
D上X:=1.06*AHC23;
T:=(C上X+D上X+上X)/3*1.05;
主升3:=(MA5*2/(界限+T)-1)*100;
cbx80:=MA(COST(80),20);
主升4:=(MA5/CBX80-1)*100;
FT:=((HHV(H,42)-LLV(L,42)))/2+LLV(L,42);
FT1:=ABS(HHV(H,40)-LLV(L,40)-LLV(L,40))+FT*0.5;
主升5:=(FT/FT1-1)*100;
P:=EMA(EMA(C*1.14,55),20);
主升6:=(MA5/P-1)*100;
K线:=(EMA(HHV(H,60),60)+EMA(FT,453)*1.62)/2;
主升7:=(MA5/金K线-1)*100;
主升:=(主升1+主升2+主升3+主升4+主升5+主升6+主升7);
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
一路飞扬:CROSS(主升,0);

选股公式翻译

VAR11赋值:3*(收盘价-480日内最低价的最低值)/(480日内最高价的最高值-480日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-480日内最低价的最低值)/(480日内最高价的最高值-480日内最低价的最低值)*100的180日[1日权重]移动平均的15日[1日权重]移动平均
超级主升赋值:VAR11的5日指数移动平均
主升1赋值:超级主升-100
D1赋值:收盘价的5日指数移动平均
D2赋值:(收盘价的1日指数移动平均+收盘价的5日指数移动平均+收盘价的10日指数移动平均+收盘价的15日指数移动平均+收盘价的20日指数移动平均+收盘价的25日指数移动平均+收盘价的30日指数移动平均+收盘价的35日指数移动平均+收盘价的40日指数移动平均+收盘价的45日指数移动平均+收盘价的50日指数移动平均+收盘价的55日指数移动平均+收盘价的60日指数移动平均+收盘价的65日指数移动平均+收盘价的70日指数移动平均+收盘价的75日指数移动平均+收盘价的80日指数移动平均+收盘价的85日指数移动平均+收盘价的90日指数移动平均+收盘价的95日指数移动平均+收盘价的100日指数移动平均+收盘价的105日指数移动平均+收盘价的110日指数移动平均+收盘价的115日指数移动平均+收盘价的120日指数移动平均+收盘价的125日指数移动平均+收盘价的130日指数移动平均+收盘价的135日指数移动平均+收盘价的140日指数移动平均+收盘价的150日指数移动平均)/30
DDE赋值:(D1/D2)*100
主升2赋值:DDE-110
A赋值:(最高价+最低价+2*收盘价)/4
A1赋值:(A-3日前的A)/3+A
MA5赋值:A1的7日指数移动平均
J赋值:20日内A1的最高值的60日指数移动平均
CB5赋值:获利盘为80%的成本分布的30日指数移动平均
HMX赋值:1.4*A1的20日线性回归预测值的40日指数移动平均的20日指数移动平均
金牛线赋值:(J+CB5+HMX)/3
UP赋值:收盘价*1.38的50日指数移动平均的50日指数移动平均
白色赋值:最高价的21日[2日权重]移动平均*1.05
黄色赋值:最低价的21日[2日权重]移动平均*0.95
中线赋值:(白色+黄色)/2
UP1赋值:中线+2*中线的20日估算标准差
CC赋值:(2*收盘价+最高价+最低价)/4-A1的20日简单移动平均的绝对值/A1的20日简单移动平均
DD赋值:以CC为权重收盘价的动态移动平均
通道3赋值:(1+9/100)*DD
界限赋值:(10日前的(金牛线+UP+UP1*1.04的40日指数移动平均+通道3)/4+收盘价的20日简单移动平均*1.04)/2
AHC1赋值:最高价*成交量(手)
AHC24赋值:(AHC1的180日指数移动平均/成交量(手)的180日指数移动平均+AHC1的360日指数移动平均/成交量(手)的360日指数移动平均+AHC1的720日指数移动平均/成交量(手)的720日指数移动平均+AHC1的1440日指数移动平均/成交量(手)的1440日指数移动平均)/4的34日指数移动平均
C上X赋值:1.06*AHC24
AHC22赋值:(AHC1的27日指数移动平均/成交量(手)的27日指数移动平均+AHC1的54日指数移动平均/成交量(手)的54日指数移动平均+AHC1的108日指数移动平均/成交量(手)的108日指数移动平均+AHC1的316日指数移动平均/成交量(手)的316日指数移动平均)/4的34日指数移动平均
上X赋值:1.06*AHC22
AHC23赋值:(AHC1的5日指数移动平均/成交量(手)的5日指数移动平均+AHC1的10日指数移动平均/成交量(手)的10日指数移动平均+AHC1的20日指数移动平均/成交量(手)的20日指数移动平均+AHC1的40日指数移动平均/成交量(手)的40日指数移动平均)/4的34日指数移动平均
D上X赋值:1.06*AHC23
T赋值:(C上X+D上X+上X)/3*1.05
主升3赋值:(MA5*2/(界限+T)-1)*100
CBX80赋值:获利盘为80%的成本分布的20日简单移动平均
主升4赋值:(MA5/CBX80-1)*100
FT赋值:((42日内最高价的最高值-42日内最低价的最低值))/2+42日内最低价的最低值
FT1赋值:40日内最高价的最高值-40日内最低价的最低值-40日内最低价的最低值的绝对值+FT*0.5
主升5赋值:(FT/FT1-1)*100
P赋值:收盘价*1.14的55日指数移动平均的20日指数移动平均
主升6赋值:(MA5/P-1)*100
金K线赋值:(60日内最高价的最高值的60日指数移动平均+FT的453日指数移动平均*1.62)/2
主升7赋值:(MA5/金K线-1)*100
主升赋值:(主升1+主升2+主升3+主升4+主升5+主升6+主升7)
趋势赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
输出一路飞扬:主升上穿0

演示图片

s_14540.png

相关选股公式

  1. 转牛势选股公式
  2. 大底天下选股公式
  3. 股价趋势拐点选股公式
  4. 测量小底选股公式
  5. 异动捉牛选股公式
  6. 蓄势突破选股公式
  7. 财富龙头超牛选股公式
  8. 中线掘金术选股公式
  9. 潜伏准备选股公式
  10. 妖股火坑跳选股公式