超资介入选股公式

发布时间:2021-11-21

选股公式源码

涨幅:=9;高度:=20;跨度:=10;N4:=34;
短线:=EMA(CLOSE,17);
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线:=EMA(KKC,50);
中期:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
KDD:=REF(中期,1)<1 AND 中期>1;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA
((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
支撑:=LLV(持股,3);
中期线:=MA(持股,12);
VAR1:=1;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
短期线:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1*30;
AAA:=(3*C+L+O+H)/6;
C2:=EMA(AAA,6);
C3:=EMA(AAA,5);
SHORT:=12;
LONG:=26;
MID:=9;
dif:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
KAAA1:=EXIst(KDD,3);
KBBB1:=C/REF(C,1)>1+0.01*涨幅;
KAAA2:=支撑>中期线 AND 持股=支撑;
KBBB2:=CROSS(C2,C3);
KCCC2:=EXIST(C/REF(C,1)>1+0.01*涨幅,跨度);
KDDD2:=BArslAST(中期线>短期线)<跨度;
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*涨幅;
KCCC3:=中线/长线<1+0.01*高度;
超资介入: IF(KBBB1+KCCC2+KBBB3=3,1,0);

选股公式翻译

涨幅赋值:9
高度赋值:20
跨度赋值:10
N4赋值:34
短线赋值:收盘价的17日指数移动平均
A赋值:(3*收盘价+最低价+开盘价+最高价)/6
X赋值:(20*A+19*1日前的A+18*2日前的A+17*3日前的A+16*4日前的A+15*5日前的A+14*6日前的A+13*7日前的A+12*8日前的A+11*9日前的A+10*10日前的A+9*11日前的A+8*12日前的A+7*13日前的A+6*14日前的A+5*15日前的A+4*16日前的A+3*17日前的A+2*18日前的A+20日前的A)/210
中线赋值:X的13日指数移动平均
KKA赋值:收盘价的5日指数移动平均
KKB赋值:KKA的8日指数移动平均
KKC赋值:KKB的13日指数移动平均
长线赋值:KKC的50日指数移动平均
中期赋值:100*(收盘价-N4日内最低价的最低值)/(N4日内收盘价的最高值-N4日内最低价的最低值)
KDD赋值:1日前的中期<1 AND 中期>1
持股赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
支撑赋值:3日内持股的最低值
中期线赋值:持股的12日简单移动平均
VAR1赋值:1
VAR2赋值:10日内最低价的最低值
VAR3赋值:25日内最高价的最高值
短期线赋值:(收盘价-VAR2)/(VAR3-VAR2)*4的4日指数移动平均*VAR1*30
AAA赋值:(3*收盘价+最低价+开盘价+最高价)/6
C2赋值:AAA的6日指数移动平均
C3赋值:AAA的5日指数移动平均
SHORT赋值:12
LONG赋值:26
MID赋值:9
DIF赋值:收盘价的SHORT日指数移动平均-收盘价的LONG日指数移动平均
DEA赋值:DIF的MID日指数移动平均
MACD赋值:(DIF-DEA)*2
N赋值:9
M1赋值:3
M2赋值:3
RSV赋值:(收盘价-N日内最低价的最低值)/(N日内最高价的最高值-N日内最低价的最低值)*100
K赋值:RSV的M1日[1日权重]移动平均
D赋值:K的M2日[1日权重]移动平均
J赋值:3*K-2*D
KAAA1赋值:最近3日存在KDD
KBBB1赋值:收盘价/1日前的收盘价>1+0.01*涨幅
KAAA2赋值:支撑>中期线 AND 持股=支撑
KBBB2赋值:C2上穿C3
KCCC2赋值:最近跨度日存在收盘价/1日前的收盘价>1+0.01*涨幅
KDDD2赋值:上次中期线>短期线距今天数<跨度
KAAA3赋值:1日前的收盘价<1日前的中线 AND 收盘价>中线
KBBB3赋值:收盘价/1日前的收盘价>1+0.01*涨幅
KCCC3赋值:中线/长线<1+0.01*高度
输出超资介入: 如果KBBB1+KCCC2+KBBB3=3,返回1,否则返回0

演示图片

s_14548.png

相关选股公式

  1. 回马枪优化选股公式
  2. 游资进场选股公式
  3. 多头擒妖选股公式
  4. 霸气平台突破选股公式
  5. 短线多头追涨选股公式
  6. 雄霸天下选股公式
  7. 更上层楼选股公式
  8. 蓄势突破选股公式
  9. 亮剑选股公式
  10. 短线抓牛利器选股公式