归壹突破选股公式

发布时间:2021-11-27

选股公式源码

XA_1:=12;
XA_2:=26;
XA_3:=9;
XA_4:=EMA(CLOSE,XA_1)-EMA(CLOSE,XA_2);
XA_5:=EMA(XA_4,XA_3);
XA_6:=(XA_4-XA_5)*2;
XA_7:=CROSS(XA_4,XA_5);
XA_8:=CROSS(XA_5,XA_4);
XA_9:=BArslAst(XA_7);
XA_10:=CROSS(MA(CLOSE,8),MA(CLOSE,4));
XA_11:=CROSS(MA(CLOSE,10),MA(CLOSE,5));
XA_12:=CROSS(MA(CLOSE,12),MA(CLOSE,5));
XA_13:=CROSS(MA(CLOSE,13),MA(CLOSE,5));
XA_14:=MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND REF(MA(CLOSE,5),1)<REF(MA(CLOSE,5),2);
XA_15:=BARSLAST(CROSS(MA(CLOSE,13),MA(CLOSE,34)));
XA_16:=EVERY(XA_6>0,XA_9) AND XA_9>=9 AND COUNT(XA_10,XA_15)=1 AND XA_10 OR (EVERY(XA_6>0,XA_9) AND XA_9>=9 AND COUNT(XA_11,XA_15)=1 AND XA_11) OR (EVERY(XA_6>0,XA_9) AND XA_9>=9 AND COUNT(XA_12,XA_15)=1 AND XA_12) OR (EVERY(XA_6>0,XA_9) AND XA_9>=9 AND COUNT(XA_13,XA_15)=1 AND XA_13);
XA_17:=EXIST(XA_16,4) AND CLOSE>MA(CLOSE,13) AND XA_6>REF(XA_6,1) AND MA(CLOSE,5)>MA(CLOSE,55) AND EXIST(XA_14,3);
XA_18:=EVERY(XA_6>0,XA_9) AND XA_9>=14 AND COUNT(XA_11,XA_15)=1 AND XA_11 OR (EVERY(XA_6>0,XA_9) AND XA_9>=14 AND COUNT(XA_12,XA_15)=1 AND XA_12) OR (EVERY(XA_6>0,XA_9) AND XA_9>=14 AND COUNT(XA_13,XA_15)=1 AND XA_13);
XA_19:=EXIST(XA_18,2) AND CLOSE>MA(CLOSE,13) AND XA_6>REF(XA_6,1);
TP:EXIST(XA_17,7) AND XA_6>REF(HHV(XA_6,XA_9),BARSLAST(XA_17)+1) OR (EXIST(XA_19,7) AND XA_6>REF(HHV(XA_6,XA_9),BARSLAST(XA_19)+1));

选股公式翻译

XA_1赋值:12
XA_2赋值:26
XA_3赋值:9
XA_4赋值:收盘价的XA_1日指数移动平均-收盘价的XA_2日指数移动平均
XA_5赋值:XA_4的XA_3日指数移动平均
XA_6赋值:(XA_4-XA_5)*2
XA_7赋值:XA_4上穿XA_5
XA_8赋值:XA_5上穿XA_4
XA_9赋值:上次XA_7距今天数
XA_10赋值:收盘价的8日简单移动平均上穿收盘价的4日简单移动平均
XA_11赋值:收盘价的10日简单移动平均上穿收盘价的5日简单移动平均
XA_12赋值:收盘价的12日简单移动平均上穿收盘价的5日简单移动平均
XA_13赋值:收盘价的13日简单移动平均上穿收盘价的5日简单移动平均
XA_14赋值:收盘价的5日简单移动平均>1日前的收盘价的5日简单移动平均 AND 1日前的收盘价的5日简单移动平均<2日前的收盘价的5日简单移动平均
XA_15赋值:上次收盘价的13日简单移动平均上穿收盘价的34日简单移动平均距今天数
XA_16赋值:最近XA_9日一直存在XA_6>0 AND XA_9>=9 AND 统计XA_15日中满足XA_10的天数=1 AND XA_10 OR (最近XA_9日一直存在XA_6>0 AND XA_9>=9 AND 统计XA_15日中满足XA_11的天数=1 AND XA_11) OR (最近XA_9日一直存在XA_6>0 AND XA_9>=9 AND 统计XA_15日中满足XA_12的天数=1 AND XA_12) OR (最近XA_9日一直存在XA_6>0 AND XA_9>=9 AND 统计XA_15日中满足XA_13的天数=1 AND XA_13)
XA_17赋值:最近4日存在XA_16 AND 收盘价>收盘价的13日简单移动平均 AND XA_6>1日前的XA_6 AND 收盘价的5日简单移动平均>收盘价的55日简单移动平均 AND 最近3日存在XA_14
XA_18赋值:最近XA_9日一直存在XA_6>0 AND XA_9>=14 AND 统计XA_15日中满足XA_11的天数=1 AND XA_11 OR (最近XA_9日一直存在XA_6>0 AND XA_9>=14 AND 统计XA_15日中满足XA_12的天数=1 AND XA_12) OR (最近XA_9日一直存在XA_6>0 AND XA_9>=14 AND 统计XA_15日中满足XA_13的天数=1 AND XA_13)
XA_19赋值:最近2日存在XA_18 AND 收盘价>收盘价的13日简单移动平均 AND XA_6>1日前的XA_6
输出TP:最近7日存在XA_17 AND XA_6>上次XA_17距今天数+1日前的XA_9日内XA_6的最高值 OR (最近7日存在XA_19 AND XA_6>上次XA_19距今天数+1日前的XA_9日内XA_6的最高值)

演示图片

s_14564.png

相关选股公式

  1. 黑马寻牛选股公式
  2. 波段红绿灯选股公式
  3. 霸气平台突破选股公式
  4. 蓄势突破选股公式
  5. 潜伏准备选股公式
  6. 突破平台整理选股公式
  7. 龙脉突破选股公式
  8. 倍量阴线擒涨停选股公式
  9. 突破杀选股公式
  10. 突破买入选股公式