放量粘合选股公式

发布时间:2021-11-27

选股公式源码

{通达信去掉*、S、st}
S2:=IF(NAMELIKE('*'),0,1);
S3:=IF(NAMELIKE('S'),0,1);
{通达信去掉停牌}
S4:=DYNAINFO(17)>0;
{均线粘合}
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
MAX_MA:=MAX(MA5,MAX(MA10,MAX(MA20,MA30)));
MIN_MA:=MIN(MA5,MIN(MA10,MIN(MA20,MA30)));
粘合度:=(MAX_MA-MIN_MA)/MIN_MA*100;
{均线角度}
角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;
角度MA30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
角度MA60:=ATAN((MA60/REF(MA60,1)-1)*100)*180/3.1416;
X1:=粘合度<=5;
X2:=角度MA5>0 AND 角度MA10>0 AND 角度MA20>0 AND 角度MA60>0;
X3:=V/MA(V,5)>1.5;
XG:X1 AND X2 AND X3;

选股公式翻译

S2赋值:如果模糊匹配品种名称,返回0,否则返回1
S3赋值:如果模糊匹配品种名称,返回0,否则返回1
S4赋值:量比>0
MA5赋值:收盘价的5日简单移动平均
MA10赋值:收盘价的10日简单移动平均
MA20赋值:收盘价的20日简单移动平均
MA30赋值:收盘价的30日简单移动平均
MA60赋值:收盘价的60日简单移动平均
MAX_MA赋值:MA5和MA10和MA20和MA30的较大值的较大值的较大值
MIN_MA赋值:MA5和MA10和MA20和MA30的较小值的较小值的较小值
粘合度赋值:(MAX_MA-MIN_MA)/MIN_MA*100
角度MA5赋值:(MA5/1日前的MA5-1)*100的反正切*180/3.1416
角度MA10赋值:(MA10/1日前的MA10-1)*100的反正切*180/3.1416
角度MA20赋值:(MA20/1日前的MA20-1)*100的反正切*180/3.1416
角度MA30赋值:(MA30/1日前的MA30-1)*100的反正切*180/3.1416
角度MA60赋值:(MA60/1日前的MA60-1)*100的反正切*180/3.1416
X1赋值:粘合度<=5
X2赋值:角度MA5>0 AND 角度MA10>0 AND 角度MA20>0 AND 角度MA60>0
X3赋值:成交量(手)/成交量(手)的5日简单移动平均>1.5
输出XG:X1 AND X2 AND X3

演示图片

s_14569.png

相关选股公式

  1. 买入价格选股公式
  2. 强势角度选股公式
  3. 倍量星选股公式
  4. 放量突破布林线中轨选股公式
  5. 横盘区间突破选股公式
  6. 连续小阳战法选股公式
  7. 强势抓板选股公式
  8. 放量关注选股公式
  9. 主力疯狂做多选股公式
  10. 换手率金叉选股公式