主力做底选股公式

发布时间:2022-09-11

选股公式源码

VAR1:=1;
VAR3:=MA(CLOSE,13);
VAR4:=100-Abs((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
主力筹码趋向:=(100-VARA)*VAR1,,COLORRED,LINETHICK2;
VARD:=主力筹码趋向>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR11:=EMA(VARF,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
stICKLINE(VAR20,0,80,1,0),COLORFF00FF,LINETHICK3;

选股公式翻译

VAR1赋值:1
VAR3赋值:收盘价的13日简单移动平均
VAR4赋值:100-(收盘价-VAR3)/VAR3*100的绝对值
VAR5赋值:75日内最低价的最低值
VAR6赋值:75日内最高价的最高值
VAR7赋值:(VAR6-VAR5)/100
VAR8赋值:(收盘价-VAR5)/VAR7的20日[1日权重]移动平均
VAR9赋值:(开盘价-VAR5)/VAR7的20日[1日权重]移动平均
VARA赋值:3*VAR8-2*VAR8的15日[1日权重]移动平均
VARB赋值:3*VAR9-2*VAR9的15日[1日权重]移动平均
VARC赋值:100-VARB
主力筹码趋向赋值:(100-VARA)*VAR1,,画红色,线宽为2
VARD赋值:主力筹码趋向>VAR4
VARE赋值:1日前的最低价*0.9
VARF赋值:最低价*0.9
VAR11赋值:VARF的30日指数移动平均
VAR12赋值:收盘价-1日前的收盘价
VAR13赋值:VAR12和0的较大值
VAR14赋值:VAR12的绝对值
VAR15赋值:VAR13的7日[1日权重]移动平均/VAR14的7日[1日权重]移动平均*100
VAR16赋值:VAR13的13日[1日权重]移动平均/VAR14的13日[1日权重]移动平均*100
VAR17赋值:收盘价的有效数据周期数
VAR18赋值:VAR12和0的较大值的6日[1日权重]移动平均/VAR12的绝对值的6日[1日权重]移动平均*100
VAR19赋值:(-200)*(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)+100
VAR1A赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100
VAR1B赋值:(VAR1A的4日[1日权重]移动平均-50)*2的3日[1日权重]移动平均
VAR1C赋值:(大盘的收盘价-14日内大盘的最低价的最低值)/(14日内大盘的最高价的最高值-14日内大盘的最低价的最低值)*100
VAR1D赋值:VAR1C的4日[1日权重]移动平均
VAR1E赋值:VAR1D的3日[1日权重]移动平均
VAR1F赋值:(30日内最高价的最高值-收盘价)/收盘价*100
VAR20赋值:VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-收盘价>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50
当满足条件VAR20时,在0和80位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFF00FF,线宽为3

演示图片

s_15090.png

相关选股公式

  1. 突破筹码压力选股公式
  2. 强势主力选股公式
  3. 游资进场选股公式
  4. 筹码上破选股公式
  5. 筹码红柱选股公式
  6. 疯牛搏杀选股公式
  7. 竞价筹码选股公式
  8. 极限抢筹选股公式
  9. 共振必妖选股公式
  10. 速升选股公式