雄霸天下选股公式

发布时间:2022-09-11

选股公式源码

X_1:=(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
X_2:=SMA(X_1,5,1);
X_3:=Sma(X_2,5,1);
X_4:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.08 AND X_2>30;
X_5:=AMOUNT;
X_6:=1.9;
X_7:=X_5>=REF(X_5,1)*X_6 AND IF(CLOSE<OPEN,CLOSE>REF(CLOSE,1),1);
X_8:=VOL/CAPITAL*100<10;
X_9:=MA(CLOSE,233)>=REF(MA(CLOSE,233),1);
X_10:=MA(CLOSE,34)>=REF(MA(CLOSE,34),1);
X_11:=CROSS(MACD.DIF,macd.DEA);
X_12:=CROSS(X_3,X_2);
X_13:=X_11 AND X_12 AND X_4 AND X_9 AND X_10 AND X_8;
X_14:=X_12 AND REF(X_11,1) AND X_4 AND X_9 AND X_8;
X_15:=X_11 AND X_12 AND CLOSE>MA(CLOSE,34) AND X_9 AND X_8 AND X_4;
X_16:=X_9 AND REF(X_11,1) AND REF(X_12,1) AND X_4 AND X_10 AND X_8;
X_17:=X_11 AND REF(X_12,1) AND REF(X_7,1) AND X_10 AND X_4 AND X_8;
X_18:=X_11 AND X_12 AND MACD.DIF>0 AND X_8 AND X_9 AND X_4;
XG:X_13 OR X_14 OR X_15 OR X_16 OR X_17 OR X_18;

选股公式翻译

X_1赋值:(13日内最高价的最高值-收盘价)/(13日内最高价的最高值-13日内最低价的最低值)*100
X_2赋值:X_1的5日[1日权重]移动平均
X_3赋值:X_2的5日[1日权重]移动平均
X_4赋值:(收盘价-1日前的收盘价)/1日前的收盘价>0.08 AND X_2>30
X_5赋值:成交额(元)
X_6赋值:1.9
X_7赋值:X_5>=1日前的X_5*X_6 AND 如果收阴线,返回收盘价>1日前的收盘价,否则返回1
X_8赋值:成交量(手)/当前流通股本(手)*100<10
X_9赋值:收盘价的233日简单移动平均>=1日前的收盘价的233日简单移动平均
X_10赋值:收盘价的34日简单移动平均>=1日前的收盘价的34日简单移动平均
X_11赋值:平滑异同平均线的DIF上穿平滑异同平均线的DEA
X_12赋值:X_3上穿X_2
X_13赋值:X_11 AND X_12 AND X_4 AND X_9 AND X_10 AND X_8
X_14赋值:X_12 AND 1日前的X_11 AND X_4 AND X_9 AND X_8
X_15赋值:X_11 AND X_12 AND 收盘价>收盘价的34日简单移动平均 AND X_9 AND X_8 AND X_4
X_16赋值:X_9 AND 1日前的X_11 AND 1日前的X_12 AND X_4 AND X_10 AND X_8
X_17赋值:X_11 AND 1日前的X_12 AND 1日前的X_7 AND X_10 AND X_4 AND X_8
X_18赋值:X_11 AND X_12 AND 平滑异同平均线的DIF>0 AND X_8 AND X_9 AND X_4
输出XG:X_13 OR X_14 OR X_15 OR X_16 OR X_17 OR X_18

演示图片

s_15091.png

相关选股公式

  1. 妖王潜力选股公式
  2. 大单资金量振选股公式
  3. 涨在即选股公式
  4. 老妖异动选股公式
  5. 潜伏主升选股公式
  6. 一进二神器选股公式
  7. 买卖启动选股公式
  8. 今日之升选股公式
  9. 倚天屠龙记选股公式
  10. 赵龙虎选股公式