龙头抓大牛选股公式

发布时间:2022-09-11

选股公式源码

VAR2X:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR3X:=SMA(VAR2X,4,1);
VAR4X:=Sma(VAR3X,2,1);
VAR5X:=SMA(VAR4X,2,1);
VAR7:=CROSS(VAR4X,VAR5X) AND VAR4X<35;
VAR8:=VAR7 AND VOL>REF(VOL,1)*2 AND VOL>REF(MA(VOL,5),1)*2;
VAR01:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR02:=SMA(VAR01,3,1);
VAR03:=SMA(VAR02,3,1);
VAR04:=SMA(VAR03,3,1);
VAR06:=CROSS(VAR03,VAR04) AND VAR03<25;
VAR07:=VAR06 AND VOL>REF(VOL,1)*2 AND VOL>REF(MA(VOL,5),1)*2;
HAN:=DATE<1231230;
VAR2XM:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
VAR3XM:=SMA(VAR2XM,5,1);
VAR4XM:=SMA(VAR3XM,3,1);
VAR5XM:=SMA(VAR4XM,3,1);
VAR7M:=CROSS(VAR4XM,VAR5XM) AND VAR4XM<35;
VAR8M:=VAR7M AND VOL>REF(VOL,1)*2 AND VOL>REF(MA(VOL,5),1)*2;
VAR01M:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR02M:=SMA(VAR01M,3,1);
VAR03M:=SMA(VAR02M,3,1);
VAR04M:=SMA(VAR03M,3,1);
VAR06M:=CROSS(VAR03M,VAR04M) AND VAR03M<25;
VAR07M:=VAR06M AND VOL>REF(VOL,1)*2 AND VOL>REF(MA(VOL,5),1)*2;
ASDM:=stICKLINE(VAR8M OR VAR07M,-2,25,4,0);
ASDMM:=STICKLINE(VAR8 OR VAR07,0,20,6,0)*HAN;
MHY:=STICKLINE(ASDM AND ASDMM,0,20,6,0)*HAN;
底部:=FILTER(MHY,15);
抓大牛:底部,COLORGREEN;

选股公式翻译

VAR2X赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR3X赋值:VAR2X的4日[1日权重]移动平均
VAR4X赋值:VAR3X的2日[1日权重]移动平均
VAR5X赋值:VAR4X的2日[1日权重]移动平均
VAR7赋值:VAR4X上穿VAR5X AND VAR4X<35
VAR8赋值:VAR7 AND 成交量(手)>1日前的成交量(手)*2 AND 成交量(手)>1日前的成交量(手)的5日简单移动平均*2
VAR01赋值:(收盘价-36日内最低价的最低值)/(36日内最高价的最高值-36日内最低价的最低值)*100
VAR02赋值:VAR01的3日[1日权重]移动平均
VAR03赋值:VAR02的3日[1日权重]移动平均
VAR04赋值:VAR03的3日[1日权重]移动平均
VAR06赋值:VAR03上穿VAR04 AND VAR03<25
VAR07赋值:VAR06 AND 成交量(手)>1日前的成交量(手)*2 AND 成交量(手)>1日前的成交量(手)的5日简单移动平均*2
HAN赋值:日期<1231230
VAR2XM赋值:(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100
VAR3XM赋值:VAR2XM的5日[1日权重]移动平均
VAR4XM赋值:VAR3XM的3日[1日权重]移动平均
VAR5XM赋值:VAR4XM的3日[1日权重]移动平均
VAR7M赋值:VAR4XM上穿VAR5XM AND VAR4XM<35
VAR8M赋值:VAR7M AND 成交量(手)>1日前的成交量(手)*2 AND 成交量(手)>1日前的成交量(手)的5日简单移动平均*2
VAR01M赋值:(收盘价-36日内最低价的最低值)/(36日内最高价的最高值-36日内最低价的最低值)*100
VAR02M赋值:VAR01M的3日[1日权重]移动平均
VAR03M赋值:VAR02M的3日[1日权重]移动平均
VAR04M赋值:VAR03M的3日[1日权重]移动平均
VAR06M赋值:VAR03M上穿VAR04M AND VAR03M<25
VAR07M赋值:VAR06M AND 成交量(手)>1日前的成交量(手)*2 AND 成交量(手)>1日前的成交量(手)的5日简单移动平均*2
ASDM赋值:当满足条件VAR8MORVAR07M时,在-2和25位置之间画柱状线,宽度为4,0不为0则画空心柱.
ASDMM赋值:当满足条件VAR8ORVAR07时,在0和20位置之间画柱状线,宽度为6,0不为0则画空心柱.*HAN
MHY赋值:当满足条件ASDMANDASDMM时,在0和20位置之间画柱状线,宽度为6,0不为0则画空心柱.*HAN
底部赋值:MHY的15日过滤
输出抓大牛:底部,画绿色

演示图片

s_15092.png

相关选股公式

  1. 验证底部选股公式
  2. 底部涨停买选股公式
  3. 测量小底选股公式
  4. 天天满仓选股公式
  5. 底部低吸选股公式
  6. 精准的波段底部选股公式
  7. 阶段绝底选股公式
  8. 组合底部选股公式
  9. 买卖区间选股公式
  10. 鼎牛涨停狙击选股公式