慢慢富起来选股公式

发布时间:2022-10-30

选股公式源码

DIF:=(CLOSE-SMA(CLOSE,13,1))/Sma(CLOSE,13,1)*(-100);
DEA:=REF(DIF,1)>13 AND REF(DIF,1)/DIF>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
KOV1:=IF(DEA AND REF(CLOSE,1)<=COst(5),28,0);
KOV2:=IF(DEA AND REF(CLOSE,1)<=COST(5),18,0);
QL1:=IF(DEA AND REF(CLOSE,1)<=COST(5),1,0);
N1:=9;Q:=20;
VAR1:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
MX1:=SMA(VAR1,10,1);
RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV,3,1);
D1:=SMA(K1,3,1);
VAR2:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR3:=REF(VAR2,1);
VAR4:=SMA(MAX(VAR2-VAR3,0),10,1)/SMA(Abs(VAR2-VAR3),10,1)*100;
DD1:=IF(COUNT(VAR4<20,5)>=1 AND COUNT(VAR2=LLV(VAR2,5),10)>=1 AND
CLOSE>OPEN AND CLOSE>REF(OPEN,1) AND VOL>1.5*MA(VOL,5),60,0);
MAV:=(2*C+H+L)/4;
VAR5:=LLV(LOW,34);
VAR6:=HHV(HIGH,34);
SK1:=EMA((MAV-VAR5)/(VAR6-VAR5)*100,13);
SD1:=EMA(0.667*REF(SK1,1)+0.333*SK1,2);
VAR7:=SMA(MAX(CLOSE-REF(CLOSE,1),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
WTBFW:=IF(REF(VAR7,1)<20 AND (C/REF(C,1)-1)*100>9 AND C=H,85,0);
VAR11:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR12:=REF(VAR11,1);
VAR13:=SMA(MAX(VAR11-VAR12,0),10,1)/SMA(ABS(VAR11-VAR12),10,1)*100;
VAR14:=REVERSE(VAR13)+100;
DBBY:=IF(COUNT(VAR13<=14,2),30,0);
MJ1:=IF(CROSS(VAR13,DBBY) AND VOL>1.5*MA(VOL,5),60,0);
擒庄:=QL1 AND DBBY;
擒庄2:=QL1 AND DD1;
A1:=((MA(C,60)-L)/MA(C,20))*200;
B1:=((MA(C,60)-L)/MA(C,60))*200;
C1:=((MA(C,30)-L)/MA(C,60))*200;
M1:=REF(CLOSE,1);
M2:=SMA(MAX(CLOSE-M1,0),7,1)/SMA(ABS(CLOSE-M1),7,1)*100;
G1:=FILTER(REF(M2,1)<20 AND M2>REF(M2,1),5);
TU:=C/MA(C,40)<0.74;
PER1:=5;
MMA:=EMA(C,PER1);
SMMA:=EMA(MMA,PER1);
IMPETMMA:=MMA - REF(MMA,1);
IMPETSMMA:=SMMA - REF(SMMA,1);
DIVMA:= ABS(MMA - SMMA);
TDJ:=(H-L)/REF(C,1)>0.05;
AVERIMPET:= (IMPETMMA+IMPETSMMA)/2;
TDF:= POW(DIVMA,1)*POW(AVERIMPET,3);
NTDF:=TDF/HHV(ABS(TDF),PER1*3);
YUL:=COUNT(TDJ,5)>1;
QD1:=TU AND TDJ AND YUL;
QD2:=CROSS(NTDF,-0.9);
BD1:=FILTER((G1 AND C1>20 OR C>REF(C,1)) AND REF(QD1,1),10);
XX1:=FILTER(REF(QD1,1) AND (QD2 OR C>REF(C,1)) AND "MACD.macd">-1.5,10);
YD1:=COUNT(XX1,13)>=1 AND BD1;
有龙1:=DBBY AND DD1;
有龙2:=DBBY AND YD1;
Z_1:=VOL/CAPITAL*100<11 OR REF(VOL/CAPITAL*100,1)>6 AND VOL/CAPITAL*100/REF(VOL/CAPITAL*100,1)<1.99 OR VOL/CAPITAL<REF(HHV(VOL/CAPITAL,90),1);
Z_2:=CLOSE/REF(CLOSE,1)>1.03 AND CLOSE/HHV(HIGH,34)<1 AND NOT(CLOSE<OPEN);
Z_3:=MAX(FORCAST(COST(24)/LOW,3),SMA(COST(24)/LOW,3,1))>1.3;
ZDD:=Z_1 AND Z_2 AND Z_3 ;
VAR1G:=(((CLOSE/MA(CLOSE,40))*100)<78);
VAR2G:=(((CLOSE/MA(CLOSE,60))*100)<74);
VAR3G:=(HIGH>(LOW*1.051));
VAR4G:=(VAR3G AND (COUNT(VAR3G,5) > 1));
VARAA:=IF((VAR4G AND (VAR1G OR VAR2G)),2,0);
VARBB:=C/REF(C,25)<=1.1;
VARCC:=(SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100)<15;
CPX:=SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1);
VARV5:=SMA(CPX,2,1);
CPXCD:=CPX>REF(CPX,1) AND REF(CPX,1)<REF(CPX,2) AND CPX<23;
JPD:=VARAA AND VARBB AND VARCC AND CPXCD;
DAD:=ZDD OR JPD;
乘龙:=DBBY AND DAD;
起来:(擒庄 OR 擒庄2 OR 有龙1 OR 有龙1 OR 有龙2 OR 乘龙) AND C>O;

选股公式翻译

DIF赋值:(收盘价-收盘价的13日[1日权重]移动平均)/收盘价的13日[1日权重]移动平均*(-100)
DEA赋值:1日前的DIF>13 AND 1日前的DIF/DIF>1.23 AND 收盘价/1日前的收盘价>1.03
KOV1赋值:如果DEAANDREF(收盘价,1)<=获利盘为5%的成本分布,返回28,否则返回0
KOV2赋值:如果DEAANDREF(收盘价,1)<=获利盘为5%的成本分布,返回18,否则返回0
QL1赋值:如果DEAANDREF(收盘价,1)<=获利盘为5%的成本分布,返回1,否则返回0
N1赋值:9
Q赋值:20
VAR1赋值:(收盘价-N1日内最低价的最低值)/(N1日内最高价的最高值-N1日内最低价的最低值)*100
MX1赋值:VAR1的10日[1日权重]移动平均
RSV赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100
K1赋值:RSV的3日[1日权重]移动平均
D1赋值:K1的3日[1日权重]移动平均
VAR2赋值:(最高价+最低价+开盘价+2*收盘价)/5
VAR3赋值:1日前的VAR2
VAR4赋值:VAR2-VAR3和0的较大值的10日[1日权重]移动平均/VAR2-VAR3的绝对值的10日[1日权重]移动平均*100
DD1赋值:如果统计5日中满足VAR4<20的天数>=1ANDCOUNT(VAR2=5日内VAR2的最低值,10)>=1ANDCLOSE>OPENANDCLOSE>1日前的开盘价ANDVOL>1.5*成交量(手)的5日简单移动平均,返回60,否则返回0
MAV赋值:(2*收盘价+最高价+最低价)/4
VAR5赋值:34日内最低价的最低值
VAR6赋值:34日内最高价的最高值
SK1赋值:(MAV-VAR5)/(VAR6-VAR5)*100的13日指数移动平均
SD1赋值:0.667*1日前的SK1+0.333*SK1的2日指数移动平均
VAR7赋值:收盘价-1日前的收盘价和0的较大值的7日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的7日[1日权重]移动平均*100
WTBFW赋值:如果1日前的VAR7<20AND(收盘价/1日前的收盘价-1)*100>9ANDC=最高价,返回85,否则返回0
VAR11赋值:(最高价+最低价+开盘价+2*收盘价)/5
VAR12赋值:1日前的VAR11
VAR13赋值:VAR11-VAR12和0的较大值的10日[1日权重]移动平均/VAR11-VAR12的绝对值的10日[1日权重]移动平均*100
VAR14赋值:VAR13的相反数+100
DBBY赋值:如果统计2日中满足VAR13<=14的天数,返回30,否则返回0
MJ1赋值:如果VAR13上穿DBBYANDVOL>1.5*成交量(手)的5日简单移动平均,返回60,否则返回0
擒庄赋值:QL1 AND DBBY
擒庄2赋值:QL1 AND DD1
A1赋值:((收盘价的60日简单移动平均-最低价)/收盘价的20日简单移动平均)*200
B1赋值:((收盘价的60日简单移动平均-最低价)/收盘价的60日简单移动平均)*200
C1赋值:((收盘价的30日简单移动平均-最低价)/收盘价的60日简单移动平均)*200
M1赋值:1日前的收盘价
M2赋值:收盘价-M1和0的较大值的7日[1日权重]移动平均/收盘价-M1的绝对值的7日[1日权重]移动平均*100
G1赋值:1日前的M2<20ANDM2>1日前的M2的5日过滤
TU赋值:收盘价/收盘价的40日简单移动平均<0.74
PER1赋值:5
MMA赋值:收盘价的PER1日指数移动平均
SMMA赋值:MMA的PER1日指数移动平均
IMPETMMA赋值:MMA - 1日前的MMA
IMPETSMMA赋值:SMMA - 1日前的SMMA
DIVMA赋值: MMA-SMMA的绝对值
TDJ赋值:(最高价-最低价)/1日前的收盘价>0.05
AVERIMPET赋值: (IMPETMMA+IMPETSMMA)/2
TDF赋值: DIVMA的1乘幂*AVERIMPET的3乘幂
NTDF赋值:TDF/PER1*3日内TDF的绝对值的最高值
YUL赋值:统计5日中满足TDJ的天数>1
QD1赋值:TU AND TDJ AND YUL
QD2赋值:NTDF上穿-0.9
BD1赋值:(G1ANDC1>20ORC>1日前的收盘价)ANDREF(QD1,1)的10日过滤
XX1赋值:1日前的QD1AND(QD2ORC>1日前的收盘价)AND"平滑异同平均线的MACD">-1.5的10日过滤
YD1赋值:统计13日中满足XX1的天数>=1 AND BD1
有龙1赋值:DBBY AND DD1
有龙2赋值:DBBY AND YD1
Z_1赋值:成交量(手)/当前流通股本(手)*100<11 OR 1日前的成交量(手)/当前流通股本(手)*100>6 AND 成交量(手)/当前流通股本(手)*100/1日前的成交量(手)/当前流通股本(手)*100<1.99 OR 成交量(手)/当前流通股本(手)<1日前的90日内成交量(手)/当前流通股本(手)的最高值
Z_2赋值:收盘价/1日前的收盘价>1.03 AND 收盘价/34日内最高价的最高值<1 AND 取反
Z_3赋值:获利盘为24%的成本分布/最低价的3日线性回归预测值和获利盘为24%的成本分布/最低价的3日[1日权重]移动平均的较大值>1.3
ZDD赋值:Z_1 AND Z_2 AND Z_3 
VAR1G赋值:(((收盘价/收盘价的40日简单移动平均)*100)<78)
VAR2G赋值:(((收盘价/收盘价的60日简单移动平均)*100)<74)
VAR3G赋值:(最高价>(最低价*1.051))
VAR4G赋值:(VAR3G AND (统计5日中满足VAR3G的天数 > 1))
VARAA赋值:如果(VAR4GAND(VAR1GORVAR2G)),返回2,否则返回0
VARBB赋值:收盘价/25日前的收盘价<=1.1
VARCC赋值:(收盘价-2日前的收盘价和0的较大值的7日[1日权重]移动平均/收盘价-2日前的收盘价的绝对值的7日[1日权重]移动平均*100)<15
CPX赋值:(收盘价-8日内最低价的最低值)/(8日内最高价的最高值-8日内最低价的最低值)*100的2日[1日权重]移动平均
VARV5赋值:CPX的2日[1日权重]移动平均
CPXCD赋值:CPX>1日前的CPX AND 1日前的CPX<2日前的CPX AND CPX<23
JPD赋值:VARAA AND VARBB AND VARCC AND CPXCD
DAD赋值:ZDD OR JPD
乘龙赋值:DBBY AND DAD
输出起来:(擒庄 OR 擒庄2 OR 有龙1 OR 有龙1 OR 有龙2 OR 乘龙) AND 收阳线

演示图片

s_15129.png

相关选股公式

  1. 妖王潜力选股公式
  2. 涨在即选股公式
  3. 老妖异动选股公式
  4. 潜伏主升选股公式
  5. 一进二神器选股公式
  6. 今日之升选股公式
  7. 倚天屠龙记选股公式
  8. 赵龙虎选股公式
  9. 钻石底风向标选股公式
  10. 天外飞仙选股公式