一进二神器选股公式

发布时间:2023-01-28

选股公式源码

X_1:=BARSCOUNT(CLOSE);
X_2:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1) AND LOW=HIGH;
X_3:=EVERY(X_2,X_1) OR X_1=1;
X_4:=NOT(X_3 OR NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) OR INBLOCK(4));
X_5:=2;
X_6:=CLOSE>=ZTPRICE(REF(CLOSE,1),0.1);
X_7:=COUNT(X_6,X_5)=1 AND X_6;
X_8:=VOL/700000000;
X_9:=1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1);
X_10:=2.5*MAX(X_8,X_9);
X_11:=DMA(CLOSE,X_10);
X_12:=SMA(20*(X_11/REF(X_11,1)-1),2,1);
X_13:=EMA(X_12,2);
X_14:=0.24;
X_15:=CLOSE>=REF(CLOSE,1);
X_16:=IF(X_12>X_14 AND X_13>=0.005 AND X_15,1,0);
X_17:=CROSS(X_16,0.5) AND COUNT(X_16>0.5,10)=1;
X_18:=KDJ.J-REF(KDJ.J,1)>30 AND CLOSE/REF(CLOSE,1)>1.043 AND MACD.macd>0 AND MACD.DEA>0;
X_19:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAst(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_20:=FILTER(X_19,28)*100 AND LOW>REF(CLOSE,1)*0.93;
X_21:=X_18 OR X_20 AND X_17;
X_22:=9;
X_23:=10;
X_24:=CLOSE/REF(CLOSE,1)>1+0.01*X_22;
X_25:=EXIST(CLOSE/REF(CLOSE,1)>1+0.01*X_22,X_23);
X_26:=CLOSE/REF(CLOSE,1)>1+0.01*X_22;
X_27:=IF(X_24+X_25+X_26=3,1,0);
X_28:=(HIGH-CLOSE)/(CLOSE-OPEN)<0.33;
X_29:=CLOSE/REF(CLOSE,1)-1>=0.0502 AND CLOSE>REF(CLOSE,1) AND (OPEN-LOW)/(CLOSE-OPEN)>=1.48 AND LOW<REF(LOW,1) AND LOW<REF(LOW,2);
X_30:=CLOSE/REF(CLOSE,1)-1>=0.08;
X_31:=VOL>REF(VOL,1)*1.9 AND CLOSE>REF(CLOSE,1) AND CLOSE/REF(CLOSE,1)-1>=0.049 AND X_28;
X_32:=CLOSE/REF(CLOSE,1)-1>=0.0502 AND CLOSE>REF(CLOSE,1) AND VOL>REF(VOL,1) AND VOL>REF(VOL,1)*2.5 AND X_28;
X_33:=EMA(2.055*EMA(EMA(HIGH,34),34)-EMA(EMA(LOW,34),34),5);
X_34:=IF(FILTER(X_31 OR X_32 OR X_29 OR X_30 AND X_33>CLOSE,34),1,0) AND X_27;
X_35:=X_21 OR X_34;
X_36:=X_35-X_35*0.14 AND X_7;
X_37:=HIGH=CLOSE;
X_38:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>=0.93 AND X_37;
X_39:=BArslAST(X_36);
二板:X_39 AND X_38 AND X_39<=1 AND CLOSE/REF(CLOSE,1)>1.05 AND X_4;

选股公式翻译

X_1赋值:收盘价的有效数据周期数
X_2赋值:收盘价=计算涨停价 AND 最低价=最高价
X_3赋值:最近X_1日一直存在X_2 OR X_1=1
X_4赋值:取反
X_5赋值:2
X_6赋值:收盘价>=计算涨停价
X_7赋值:统计X_5日中满足X_6的天数=1 AND X_6
X_8赋值:成交量(手)/700000000
X_9赋值:1.1*(最高价和1日前的收盘价的较大值/最低价和1日前的收盘价的较小值-1)
X_10赋值:2.5*X_8和X_9的较大值
X_11赋值:以X_10为权重收盘价的动态移动平均
X_12赋值:20*(X_11/1日前的X_11-1)的2日[1日权重]移动平均
X_13赋值:X_12的2日指数移动平均
X_14赋值:0.24
X_15赋值:收盘价>=1日前的收盘价
X_16赋值:如果X_12>X_14ANDX_13>=0.005ANDX_15,返回1,否则返回0
X_17赋值:X_16上穿0.5 AND 统计10日中满足X_16>0.5的天数=1
X_18赋值:KDJ的J-1日前的KDJ的J>30 AND 收盘价/1日前的收盘价>1.043 AND 平滑异同平均线的MACD>0 AND 平滑异同平均线的DEA>0
X_19赋值:收盘价/1日前的收盘价>1.048 AND 收盘价=最高价 AND 成交量(手)的4日线性回归预测值位于0.2*成交量(手)的12日线性回归预测值和2.1*成交量(手)的12日线性回归预测值之间
X_20赋值:X_19的28日过滤*100 AND 最低价>1日前的收盘价*0.93
X_21赋值:X_18 OR X_20 AND X_17
X_22赋值:9
X_23赋值:10
X_24赋值:收盘价/1日前的收盘价>1+0.01*X_22
X_25赋值:最近X_23日存在收盘价/1日前的收盘价>1+0.01*X_22
X_26赋值:收盘价/1日前的收盘价>1+0.01*X_22
X_27赋值:如果X_24+X_25+X_26=3,返回1,否则返回0
X_28赋值:(最高价-收盘价)/(收盘价-开盘价)<0.33
X_29赋值:收盘价/1日前的收盘价-1>=0.0502 AND 收盘价>1日前的收盘价 AND (开盘价-最低价)/(收盘价-开盘价)>=1.48 AND 最低价<1日前的最低价 AND 最低价<2日前的最低价
X_30赋值:收盘价/1日前的收盘价-1>=0.08
X_31赋值:成交量(手)>1日前的成交量(手)*1.9 AND 收盘价>1日前的收盘价 AND 收盘价/1日前的收盘价-1>=0.049 AND X_28
X_32赋值:收盘价/1日前的收盘价-1>=0.0502 AND 收盘价>1日前的收盘价 AND 成交量(手)>1日前的成交量(手) AND 成交量(手)>1日前的成交量(手)*2.5 AND X_28
X_33赋值:2.055*最高价的34日指数移动平均的34日指数移动平均-最低价的34日指数移动平均的34日指数移动平均的5日指数移动平均
X_34赋值:如果X_31ORX_32ORX_29ORX_30ANDX_33>收盘价的34日过滤,返回1,否则返回0 AND X_27
X_35赋值:X_21 OR X_34
X_36赋值:X_35-X_35*0.14 AND X_7
X_37赋值:最高价=收盘价
X_38赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>=0.93 AND X_37
X_39赋值:上次X_36距今天数
输出二板:X_39 AND X_38 AND X_39<=1 AND 收盘价/1日前的收盘价>1.05 AND X_4

演示图片

s_15203.png

相关选股公式

  1. 狂龙回首选股公式
  2. 牛妖回头选股公式
  3. 三浪起爆选股公式
  4. 坐火箭升级版选股公式
  5. 起飞加速选股公式
  6. 搏涨成交量选股公式
  7. 擒牛成交量选股公式
  8. 红色神剑选股公式
  9. 妖成龙选股公式
  10. 精品擒妖选股公式