量化侦察兵选股公式

发布时间:2023-02-26

选股公式源码

X_1:=1231212;
X_2:=IF(DATE<X_1,1,DRAWNULL);
X_3:=REF((LOW+OPEN+CLOSE+HIGH)/4,1)*X_2;
X_4:=SMA(Abs(LOW-X_3),13,1)/SMA(MAX(LOW-X_3,0),10,1)*X_2;
X_5:=EMA(X_4,10)*X_2;
X_6:=LLV(LOW,33)*X_2;
X_7:=EMA(IF(LOW<=X_6,X_5,0),3)*X_2;
X_8:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2))*X_2;
X_9:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2))*X_2;
X_10:=(REF(X_9,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2))*X_2;
X_11:=(REF(X_10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2))*X_2;
X_12:=(REF(X_11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2))*X_2;
X_13:=(REF(X_12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2))*X_2;
X_14:=(REF(X_13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2))*X_2;
X_15:=(REF(X_14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2))*X_2;
X_16:=(REF(X_15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2))*X_2;
X_17:=(REF(X_16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2))*X_2;
X_18:=(REF(X_17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2))*X_2;
X_19:=(REF(X_18,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2))*X_2;
X_20:=(REF(X_19,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2))*X_2;
X_21:=REF(X_9 OR X_10 OR X_11 OR X_12 OR X_13 OR X_14 OR X_15 OR X_16 OR X_17 OR X_18 OR X_19 OR X_20,1) AND X_8;
X_22:=EMA(CLOSE,12)-EMA(CLOSE,26)*X_2;
X_23:=EMA(X_22,9)*X_2;
X_24:=(X_22-X_23)*2*X_2;
X_25:=BArslAST(REF(CROSS(X_22,X_23),1))*X_2;
X_26:=BARSLAST(REF(CROSS(X_23,X_22),1))*X_2;
X_27:=REF(CLOSE,X_25+1)>CLOSE AND X_22>REF(X_22,X_25+1) AND CROSS(X_22,X_23)*X_2;
XG:X_27;

选股公式翻译

X_1赋值:1231212
X_2赋值:如果日期1日前的收盘价 AND 收盘价>2日前的收盘价)*X_2
X_9赋值:(收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价)*X_2
X_10赋值:(1日前的X_9 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)*X_2
X_11赋值:(1日前的X_10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)*X_2
X_12赋值:(1日前的X_11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)*X_2
X_13赋值:(1日前的X_12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)*X_2
X_14赋值:(1日前的X_13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)*X_2
X_15赋值:(1日前的X_14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)*X_2
X_16赋值:(1日前的X_15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)*X_2
X_17赋值:(1日前的X_16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)*X_2
X_18赋值:(1日前的X_17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)*X_2
X_19赋值:(1日前的X_18 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)*X_2
X_20赋值:(1日前的X_19 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)*X_2
X_21赋值:1日前的X_9ORX_10ORX_11ORX_12ORX_13ORX_14ORX_15ORX_16ORX_17ORX_18ORX_19ORX_20 AND X_8
X_22赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均*X_2
X_23赋值:X_22的9日指数移动平均*X_2
X_24赋值:(X_22-X_23)*2*X_2
X_25赋值:上次1日前的X_22上穿X_23距今天数*X_2
X_26赋值:上次1日前的X_23上穿X_22距今天数*X_2
X_27赋值:X_25+1日前的收盘价>收盘价 AND X_22>X_25+1日前的X_22 AND X_22上穿X_23*X_2
输出XG:X_27

演示图片

s_15295.png

相关选股公式

  1. 魔笛量化波段选股公式
  2. 尾盘量化选股公式
  3. 量化交易选股公式
  4. 五线看牛熊选股公式
  5. 量化擒龙选股公式
  6. 量化V型反转选股公式
  7. MACD底背离量化选股公式