山谷淘金选股公式

发布时间:2023-03-26

选股公式源码

CC1:=IF(NAMELIKE('S')||NAMELIKE('*S')||CODELIKE('688'),0,1) AND DYNAINFO(4)>0;
CC2:=BARSCOUNT(C)>40;
VAR1:=REF(LOW,1);
VAR2:=SMA(Abs(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.3,VAR2*10,VAR2/10),3);
VAR4:=LLV(LOW,30);
VAR5:=HHV(VAR3,30);
VAR6:=IF(MA(CLOSE,58),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
VAR8:=IF(VAR7>100,100,VAR7);
VAR9:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=VAR9<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
XG:(VAR11 AND COUNT(VAR11,18)=1) AND CC1 AND CC2;

选股公式翻译

CC1赋值:如果模糊匹配品种名称或者模糊匹配品种名称或者模糊匹配品种代码,返回0,否则返回1 AND 开盘价>0
CC2赋值:收盘价的有效数据周期数>40
VAR1赋值:1日前的最低价
VAR2赋值:最低价-VAR1的绝对值的3日[1日权重]移动平均/最低价-VAR1和0的较大值的3日[1日权重]移动平均*100
VAR3赋值:如果收盘价*1.3,返回VAR2*10,否则返回VAR2/10的3日指数移动平均
VAR4赋值:30日内最低价的最低值
VAR5赋值:30日内VAR3的最高值
VAR6赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
VAR7赋值:如果最低价<=VAR4,返回(VAR3+VAR5*2)/2,否则返回0的3日指数移动平均/618*VAR6
VAR8赋值:如果VAR7>100,返回100,否则返回VAR7
VAR9赋值:100-3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR10赋值:100-3*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR11赋值:VAR9<1日前的VAR10 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价
输出XG:(VAR11 AND 统计18日中满足VAR11的天数=1) AND CC1 AND CC2

演示图片

s_15362.png

相关选股公式

  1. 太极乾坤选股公式
  2. 尾进明早出挣选股公式
  3. 圣火选股公式
  4. 强庄起爆点选股公式
  5. 大阳不破选股公式
  6. 花开富贵选股公式
  7. 万手单选股公式
  8. 顺势寻牛选股公式
  9. 杀庄逃庄选股公式
  10. 金品选股公式