牛熊趋势共振选股公式

发布时间:2023-03-26

选股公式源码

HH:=HHV(H,9);
LL:=LLV(L,9);
FG:=(HH-LL)/100;
RSV:=(C-LL)/(HH-LL)*100;
K1:=SMA(RSV,3,1);
DA:=SMA(K1,3,1);
J1:=3*K1-2*DA;
K:=K1*FG+LL;
D:=DA*FG+LL;
J:=J1*FG+LL;
ZIF:=EMA(C,12)-EMA(C,26);
ZEA:=EMA(ZIF,9);
ZBC:=2*(ZIF-ZEA);
ZJS:=1.25*ZIF-0.25*ZEA;
ZXH:=(ZJS*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORWHITE;
ZPH:=(ZIF*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORYELLOW;
ZQS:=(ZEA*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORCYAN;
ZNX:=(ZXH+ZQS)/2,COLORMAGENTA;
ZJD:=ATAN((ZPH-REF(ZPH,1))/REF(ZPH,1)*100)*180/3.14159;
NL:=(VOL+REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5))/3.3;
XG1:=V>NL AND REF(J1<50,1) AND CROSS(K,D) AND CROSS(ZXH,ZQS);
XG2:=V>NL AND REF(J1<50,1) AND CROSS(K,D) AND ZXH>ZPH AND ZXH>REF(ZXH,1);
共振买:XG1 OR XG2;

选股公式翻译

HH赋值:9日内最高价的最高值
LL赋值:9日内最低价的最低值
FG赋值:(HH-LL)/100
RSV赋值:(收盘价-LL)/(HH-LL)*100
K1赋值:RSV的3日[1日权重]移动平均
DA赋值:K1的3日[1日权重]移动平均
J1赋值:3*K1-2*DA
K赋值:K1*FG+LL
D赋值:DA*FG+LL
J赋值:J1*FG+LL
ZIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
ZEA赋值:ZIF的9日指数移动平均
ZBC赋值:2*(ZIF-ZEA)
ZJS赋值:1.25*ZIF-0.25*ZEA
ZXH赋值:(ZJS*13*27-27*11*收盘价的12日指数移动平均+13*25*收盘价的26日指数移动平均)/28,画白色
ZPH赋值:(ZIF*13*27-27*11*收盘价的12日指数移动平均+13*25*收盘价的26日指数移动平均)/28,画黄色
ZQS赋值:(ZEA*13*27-27*11*收盘价的12日指数移动平均+13*25*收盘价的26日指数移动平均)/28,画青色
ZNX赋值:(ZXH+ZQS)/2,画洋红色
ZJD赋值:(ZPH-1日前的ZPH)/1日前的ZPH*100的反正切*180/3.14159
NL赋值:(成交量(手)+2日前的成交量(手)+3日前的成交量(手)+4日前的成交量(手)+5日前的成交量(手))/3.3
XG1赋值:成交量(手)>NL AND 1日前的J1<50 AND K上穿D AND ZXH上穿ZQS
XG2赋值:成交量(手)>NL AND 1日前的J1<50 AND K上穿D AND ZXH>ZPH AND ZXH>1日前的ZXH
输出共振买:XG1 OR XG2

演示图片

s_15365.png

相关选股公式

  1. 趋势大道选股公式
  2. 起爆捉妖选股公式
  3. 趋势量能选股公式
  4. 庄家共振选股公式
  5. 黄金共振波选股公式
  6. 异动成功出击选股公式
  7. 金牛顶底趋势选股公式
  8. 趋势跟庄选股公式
  9. 主导资金动向选股公式
  10. 强势打板选股公式