倚天出鞘选股公式

发布时间:2023-05-28

选股公式源码

涨停:=C/REF(C,1)>1.0970 AND C=H AND C/REF(C,1)< 1.11;
周期:=BArslAST(REF(涨停,1) AND NOT(涨停));
支撑:=REF(C,周期+2);
压力:=MAX(HHV(O,周期),HHV(C,周期));
进攻线:=MAX(MAX(REF(C,周期),REF(C,周期+1)),MAX(REF(O,周期),REF(O,周期+1)));
不破:=LLV(O,周期)>支撑 AND LLV(C,周期)>支撑;
能破:=C*1.11>压力;
强势:=HHV(HIGH,15)*1.1>HHV(HIGH,30);
低位:=HHV(C,10)/LLV(C,10)< 1.5;
买入信号:=周期>0 AND 周期<=30 AND 不破 AND 低位 AND 强势 AND 能破AND C>进攻线 AND REF(C,1)<=进攻线;
倚天出鞘:买入信号 AND COUNT(买入信号,周期)<=2;

选股公式翻译

涨停赋值:收盘价/1日前的收盘价>1.0970 AND 收盘价=最高价 AND 收盘价/1日前的收盘价< 1.11
周期赋值:上次1日前的涨停ANDNOT(涨停)距今天数
支撑赋值:周期+2日前的收盘价
压力赋值:周期日内开盘价的最高值和周期日内收盘价的最高值的较大值
进攻线赋值:周期日前的收盘价和周期+1日前的收盘价的较大值和周期日前的开盘价和周期+1日前的开盘价的较大值的较大值
不破赋值:周期日内开盘价的最低值>支撑 AND 周期日内收盘价的最低值>支撑
能破赋值:收盘价*1.11>压力
强势赋值:15日内最高价的最高值*1.1>30日内最高价的最高值
低位赋值:10日内收盘价的最高值/10日内收盘价的最低值< 1.5
买入信号赋值:周期>0 AND 周期<=30 AND 不破 AND 低位 AND 强势 AND 能破AND 收盘价>进攻线 AND 1日前的收盘价<=进攻线
输出倚天出鞘:买入信号 AND 统计周期日中满足买入信号的天数<=2

演示图片

s_15477.png

相关选股公式

  1. 猛虎抓龙头选股公式
  2. 游资涨停选股公式
  3. 准备启动买入选股公式
  4. 弯腰捡金选股公式
  5. 龙头首阴选股公式
  6. 捕捉涨停专用选股公式
  7. 三妖齐聚选股公式
  8. 红色神剑选股公式
  9. 烂板回调选股公式
  10. 涨停一绝选股公式