短期博利选股公式

发布时间:2023-08-06

选股公式源码

TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
VARR0:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VARR3:=SMA(VARR0,3,1);
VARR1:=SMA(VARR3,4,1)-10;
VARR4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
VARR5:=SMA(VARR4,3,1);
VARR2:=SMA(VARR5,4,1)-90;
AR1:=1;
AR2:=(3);
AR3:=(((2*CLOSE)+HIGH)+LOW)/4;
AR4:=LLV(LOW,36);
AR5:=HHV(HIGH,36);
AR6:=EMA((((AR3-AR4)/(AR5-AR4))*100),10);
AR7:=(EMA(((0.667*(REF(AR6,1)))+(0.333*AR6)),2))*AR1;
AR8:=(HHV(HIGH,7))-(LLV(LOW,7));
AR9:=(HHV(HIGH,7))-CLOSE;
AR10:=CLOSE-(LLV(LOW,7));
AR11:=((AR9/AR8)*100)-60;
AR12:=((CLOSE-(LLV(LOW,40)))/((HHV(HIGH,60))-(LLV(LOW,40))))*100;
AR13:=SMA(((AR10/AR8)*100),3,1);
AR14:=(SMA(AR13,3,1))-(SMA(AR11,7,1));
AR15:=IF((AR14>100),(AR14-100),0);
AR16:=(EMA((((AR3-AR4)/(AR5-AR4))*100),3))*AR1;
AR17:=(EMA(AR16,5))*AR1;
VA:=VARR1-REF(VARR1,1);
底部:=FILTERX(REF((AR16-AR17)>0 AND REF(VARR1,1)>VARR1,1) AND REF(VARR1,1)<VARR1 AND VARR1<0,255);
抄底:=REF(C,BArslAST(底部));
均值:=(REF(H,1)+REF(H,2)+REF(H,3)+REF(H,4)+REF(L,1)+REF(L,2)+REF(L,3)+REF(L,4))/8;
利润20:=均值>抄底*0.09 AND 均值<抄底*1.01
AND REF(HHV(H,4),1)>抄底 AND REF(LLV(L,4),1)<抄底
AND REF(COUNT(H>抄底,4)>=2,1)
AND REF(C,1)>抄底,COLORRED;
XG:FILTER(利润20,5) AND COUNT(cci<0,3)=3 AND REF(CCI,1)>REF(CCI,2),COLORRED;

选股公式翻译

TYP赋值:(最高价+最低价+收盘价)/3
CCI赋值:(TYP-TYP的14日简单移动平均)/(0.015*TYP的14日平均绝对偏差)
VARR0赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100
VARR3赋值:VARR0的3日[1日权重]移动平均
VARR1赋值:VARR3的4日[1日权重]移动平均-10
VARR4赋值:(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)*100
VARR5赋值:VARR4的3日[1日权重]移动平均
VARR2赋值:VARR5的4日[1日权重]移动平均-90
AR1赋值:1
AR2赋值:(3)
AR3赋值:(((2*收盘价)+最高价)+最低价)/4
AR4赋值:36日内最低价的最低值
AR5赋值:36日内最高价的最高值
AR6赋值:(((AR3-AR4)/(AR5-AR4))*100)的10日指数移动平均
AR7赋值:(((0.667*(1日前的AR6))+(0.333*AR6))的2日指数移动平均)*AR1
AR8赋值:(7日内最高价的最高值)-(7日内最低价的最低值)
AR9赋值:(7日内最高价的最高值)-收盘价
AR10赋值:收盘价-(7日内最低价的最低值)
AR11赋值:((AR9/AR8)*100)-60
AR12赋值:((收盘价-(40日内最低价的最低值))/((60日内最高价的最高值)-(40日内最低价的最低值)))*100
AR13赋值:((AR10/AR8)*100)的3日[1日权重]移动平均
AR14赋值:(AR13的3日[1日权重]移动平均)-(AR11的7日[1日权重]移动平均)
AR15赋值:如果(AR14>100),返回(AR14-100),否则返回0
AR16赋值:((((AR3-AR4)/(AR5-AR4))*100)的3日指数移动平均)*AR1
AR17赋值:(AR16的5日指数移动平均)*AR1
VA赋值:VARR1-1日前的VARR1
底部赋值:1日前的(AR16-AR17)>0ANDREF(VARR1,1)>VARR1ANDREF(VARR1,1)抄底*0.09 AND 均值<抄底*1.01AND 1日前的4日内最高价的最高值>抄底 AND 1日前的4日内最低价的最低值<抄底AND 1日前的统计4日中满足最高价>抄底的天数>=2AND 1日前的收盘价>抄底,画红色
输出XG:利润20的5日过滤 AND 统计3日中满足CCI<0的天数=3 AND 1日前的CCI>2日前的CCI,画红色

演示图片

s_15591.png

相关选股公式

  1. 白武士抄底选股公式
  2. 战神抄底选股公式
  3. 换手率抄底选股公式
  4. 金钻抄底选股公式
  5. 泽熙抄底选股公式
  6. 妖股波段选股公式
  7. 底部龙头选股公式
  8. 底部放量选股公式
  9. 缺口抄底选股公式
  10. 散户游击战选股公式