股道漫步趋势选股公式

发布时间:2023-09-03

选股公式源码

X_1:=EMA(CLOSE,6)-EMA(CLOSE,38);
X_2:=EMA(EMA(EMA(EMA(CLOSE,3),3),3)+X_1,9);
X_3:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X_4:=EMA(X_3,13);
X_5:=EMA(X_4,3);
X_6:=EMA(X_5,3);
X_7:=EMA(X_6,3);
X_8:=EMA(X_7,3);
X_9:=EMA(X_8,3);
X_10:=(20*X_3+19*REF(X_3,1)+18*REF(X_3,2)+17*REF(X_3,3)+16*REF(X_3,4)+15*REF(X_3,5)+14*REF(X_3,6)+13*REF(X_3,7)+12*REF(X_3,8)+11*REF(X_3,9)+10*REF(X_3,10)+9*REF(X_3,11)+8*REF(X_3,12)+7*REF(X_3,13)+6*REF(X_3,14)+5*REF(X_3,15)+4*REF(X_3,16)+3*REF(X_3,17)+2*REF(X_3,18)+REF(X_3,20))/210;
X_11:=EMA(SLOPE(CLOSE,22)*20+CLOSE,60);
X_12:=MA(X_10,20);
X_13:=CLOSE>=X_2 AND COUNT(X_2>=X_11 AND X_11>=X_12,5)=5;
X_14:=OPEN>=MA(OPEN,3);
X_15:=REF(OPEN,1)>=REF(CLOSE,1);
X_16:=X_13 AND X_14 AND X_15;
X_17:=MA(CLOSE,5);
X_18:=MA(CLOSE,6);
X_19:=MA(CLOSE,7);
X_20:=MA(CLOSE,8);
X_21:=MA(CLOSE,9);
X_22:=MA(CLOSE,10);
X_23:=MA(CLOSE,11);
X_24:=MA(CLOSE,12);
X_25:=MA(CLOSE,13);
X_26:=MA(CLOSE,14);
X_27:=MA(CLOSE,15);
X_28:=MA(CLOSE,16);
X_29:=MA(CLOSE,17);
X_30:=MA(CLOSE,18);
X_31:=MA(CLOSE,19);
X_32:=MA(CLOSE,20);
X_33:=MA(CLOSE,21);
X_34:=MA(CLOSE,22);
X_35:=MA(CLOSE,23);
X_36:=MA(CLOSE,24);
X_37:=MA(CLOSE,25);
X_38:=MA(CLOSE,26);
X_39:=MA(CLOSE,27);
X_40:=MA(CLOSE,28);
X_41:=MA(CLOSE,29);
X_42:=MA(CLOSE,30);
X_43:=MA(CLOSE,31);
X_44:=MAX(MAX(MAX(MAX(X_17,X_18),X_19),X_20),X_21);
X_45:=MAX(MAX(MAX(MAX(X_22,X_23),X_24),X_25),X_26);
X_46:=MAX(MAX(MAX(MAX(X_27,X_28),X_29),X_30),X_31);
X_47:=MAX(MAX(MAX(MAX(MAX(X_32,X_33),X_34),X_35),X_36),X_37);
X_48:=MAX(MAX(MAX(MAX(MAX(X_38,X_39),X_40),X_41),X_42),X_43);
X_49:=MAX(MAX(MAX(MAX(X_44,X_45),X_46),X_47),X_48);
X_50:=IF(X_49=X_17,5,IF(X_49=X_18,6,IF(X_49=X_19,7,IF(X_49=X_20,8,IF(X_49=X_21,9,IF(X_49=X_22,10,IF(X_49=X_23,11,IF(X_49=X_24,12,IF(X_49=X_25,13,IF(X_49=X_26,14,IF(X_49=X_27,15,IF(X_49=X_28,16,IF(X_49=X_29,17,IF(X_49=X_30,18,IF(X_49=X_31,19,IF(X_49=X_32,20,IF(X_49=X_33,21,IF(X_49=X_34,22,IF(X_49=X_35,23,IF(X_49=X_36,24,IF(X_49=X_37,25,DRAWNULL)))))))))))))))))))));
X_51:=IF(X_49=MA(CLOSE,X_50),X_50,IF(X_49=X_38,26,IF(X_49=X_39,27,IF(X_49=X_40,28,IF(X_49=X_41,29,IF(X_49=X_42,30,IF(X_49=X_43,31,32)))))));
X_52:=IF(BARSCOUNT(CLOSE)>=31,(X_49*3+MA(CLOSE,31))/4,MAX(MA(CLOSE,5),MA(CLOSE,BARSCOUNT(CLOSE))));
X_53:=X_52;
X_54:=EMA(CLOSE,8);
X_55:=(REF(OPEN,5)+REF(CLOSE,5))/2;
X_56:=(HIGH+LOW+CLOSE+OPEN)/4;
X_57:=MAX(X_55,MAX(X_56,HHV(HIGH,5)));
X_58:=MIN(X_55,MIN(X_56,LLV(LOW,5)));
X_59:=X_57=X_55;
X_60:=X_59;
X_61:=REF(X_57,BArslAST(X_60));
X_62:=EMA(CLOSE,5)-EMA(CLOSE,55);
X_63:=EMA(X_62,10);
X_64:=X_62-X_63;
X_65:=CLOSE>X_61 AND X_64>0;
X_66:=EMA(CLOSE,8);
X_67:=EMA(CLOSE,14);
X_68:=EMA(CLOSE,30);
X_69:=EMA(CLOSE,60);
X_70:=REF(HHV((HIGH+CLOSE+LOW+HIGH)/4,7),BARSLAST(CROSS(X_22,X_17)));
X_71:=REF(LLV(MIN(OPEN,CLOSE),10),BARSLAST(CROSS(X_17,X_22)));
X_72:=REF(HHV(MAX(CLOSE,OPEN),7),BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5))));
X_73:=REF(LLV(MIN(CLOSE,OPEN),10),BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10))));
X_74:=IF(CLOSE>500,X_72,X_70);
X_75:=IF(CLOSE>500,X_73,X_71);
X_76:=IF(X_74=CONST(X_74),CONST(X_74),DRAWNULL);
X_77:=EMA(CLOSE,1);
X_78:=EMA(X_77,5);
X_79:=EMA(HHV(X_78,5),1);
X_80:=EMA(HHV(X_79,17),1);
X_81:=EMA(HHV(X_80,17),2);
X_82:=EMA(HHV(X_81,17),3);
X_83:=BARSSINCE(CLOSE>0)>30 AND IF(NAMELIKE(1),0,1) AND IF(NAMELIKE(2),0,1) AND DYNAINFO(17)>0 AND NOT(CODELIKE(3)) AND CLOSE<50;
X_84:=REF(CLOSE,1)*1.01>=X_53 AND REF(CLOSE,1)*1.01>=X_76;
X_85:=CLOSE>=REF(CLOSE,1)*1.01 AND CLOSE>OPEN AND (COUNT(CLOSE>=X_53,3)=3 OR COUNT(CLOSE>=X_76,3)=3);
X_86:=X_66>X_67 AND X_67>X_68 AND X_69>=REF(X_69,1);
X_87:=IF(X_85 AND X_86,0.5,0);
X_88:=SMA(MAX(CLOSE-REF(CLOSE,1),0),14,1)/SMA(Abs(CLOSE-REF(CLOSE,1)),14,1)*100;
X_89:=SMA(MAX(CLOSE-REF(CLOSE,1),0),75,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),75,1)*100;
X_90:=EMA(CLOSE,3);
X_91:=EMA(SLOPE(CLOSE,22)*20+CLOSE,55);
X_92:=MA(X_91,1);
X_93:=X_92*0.985;
X_94:=IF(X_90>X_92,X_92,X_93);
X_95:=EMA((OPEN+HIGH+LOW)/3,4);
X_96:=ATAN((X_95/REF(X_95,1)-1)*100)*180/3.1416;
X_97:=ATAN((X_94/REF(X_94,1)-1)*100)*180/3.1416;
X_98:=100*(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21));
X_99:=100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42));
X_100:=VOL>=HHV(VOL,3) AND VOL>MA(VOL,3) AND VOL>MA(VOL,40) AND VOL>MA(VOL,89) AND MA(VOL,3)>=REF(MA(VOL,3),1);
X_101:=CLOSE>OPEN AND CLOSE/REF(CLOSE,1)>1.01 AND IF(X_54>=X_53,X_54>=X_53,X_53/X_54<1.005) AND CLOSE>=X_76 AND CLOSE>=HHV(CLOSE,10) AND CLOSE>=X_82;
X_102:=X_67>X_68 AND X_67>REF(X_67,1) AND X_68>REF(X_68,1);
X_103:=VOL<MA(VOL,3) AND VOL<MA(VOL,40) AND VOL<MA(VOL,89);
X_104:=COUNT(X_97>=45,5)>=1 OR COUNT(X_96>=45,5)>=1;
X_105:=IF(EXIST(X_100,21) AND X_101 AND X_65 AND X_102 AND EXIST(X_103,21),1.5,0);
股道漫步趋势:X_16 AND FILTER(X_105=1.5 AND EXIST(X_87=0.5,21) AND X_83 AND X_104,21);

选股公式翻译

X_1赋值:收盘价的6日指数移动平均-收盘价的38日指数移动平均
X_2赋值:收盘价的3日指数移动平均的3日指数移动平均的3日指数移动平均+X_1的9日指数移动平均
X_3赋值:(3*收盘价+最低价+开盘价+最高价)/6
X_4赋值:X_3的13日指数移动平均
X_5赋值:X_4的3日指数移动平均
X_6赋值:X_5的3日指数移动平均
X_7赋值:X_6的3日指数移动平均
X_8赋值:X_7的3日指数移动平均
X_9赋值:X_8的3日指数移动平均
X_10赋值:(20*X_3+19*1日前的X_3+18*2日前的X_3+17*3日前的X_3+16*4日前的X_3+15*5日前的X_3+14*6日前的X_3+13*7日前的X_3+12*8日前的X_3+11*9日前的X_3+10*10日前的X_3+9*11日前的X_3+8*12日前的X_3+7*13日前的X_3+6*14日前的X_3+5*15日前的X_3+4*16日前的X_3+3*17日前的X_3+2*18日前的X_3+20日前的X_3)/210
X_11赋值:收盘价的22日线性回归斜率*20+收盘价的60日指数移动平均
X_12赋值:X_10的20日简单移动平均
X_13赋值:收盘价>=X_2 AND 统计5日中满足X_2>=X_11ANDX_11>=X_12的天数=5
X_14赋值:开盘价>=开盘价的3日简单移动平均
X_15赋值:1日前的开盘价>=1日前的收盘价
X_16赋值:X_13 AND X_14 AND X_15
X_17赋值:收盘价的5日简单移动平均
X_18赋值:收盘价的6日简单移动平均
X_19赋值:收盘价的7日简单移动平均
X_20赋值:收盘价的8日简单移动平均
X_21赋值:收盘价的9日简单移动平均
X_22赋值:收盘价的10日简单移动平均
X_23赋值:收盘价的11日简单移动平均
X_24赋值:收盘价的12日简单移动平均
X_25赋值:收盘价的13日简单移动平均
X_26赋值:收盘价的14日简单移动平均
X_27赋值:收盘价的15日简单移动平均
X_28赋值:收盘价的16日简单移动平均
X_29赋值:收盘价的17日简单移动平均
X_30赋值:收盘价的18日简单移动平均
X_31赋值:收盘价的19日简单移动平均
X_32赋值:收盘价的20日简单移动平均
X_33赋值:收盘价的21日简单移动平均
X_34赋值:收盘价的22日简单移动平均
X_35赋值:收盘价的23日简单移动平均
X_36赋值:收盘价的24日简单移动平均
X_37赋值:收盘价的25日简单移动平均
X_38赋值:收盘价的26日简单移动平均
X_39赋值:收盘价的27日简单移动平均
X_40赋值:收盘价的28日简单移动平均
X_41赋值:收盘价的29日简单移动平均
X_42赋值:收盘价的30日简单移动平均
X_43赋值:收盘价的31日简单移动平均
X_44赋值:X_17和X_18的较大值和X_19的较大值和X_20的较大值和X_21的较大值
X_45赋值:X_22和X_23的较大值和X_24的较大值和X_25的较大值和X_26的较大值
X_46赋值:X_27和X_28的较大值和X_29的较大值和X_30的较大值和X_31的较大值
X_47赋值:X_32和X_33的较大值和X_34的较大值和X_35的较大值和X_36的较大值和X_37的较大值
X_48赋值:X_38和X_39的较大值和X_40的较大值和X_41的较大值和X_42的较大值和X_43的较大值
X_49赋值:X_44和X_45的较大值和X_46的较大值和X_47的较大值和X_48的较大值
X_50赋值:如果X_49=X_17,返回5,否则返回如果X_49=X_18,返回6,否则返回如果X_49=X_19,返回7,否则返回如果X_49=X_20,返回8,否则返回如果X_49=X_21,返回9,否则返回如果X_49=X_22,返回10,否则返回如果X_49=X_23,返回11,否则返回如果X_49=X_24,返回12,否则返回如果X_49=X_25,返回13,否则返回如果X_49=X_26,返回14,否则返回如果X_49=X_27,返回15,否则返回如果?,返回?,否则返回?
X_51赋值:如果X_49=收盘价的X_50日简单移动平均,返回X_50,否则返回如果X_49=X_38,返回26,否则返回如果X_49=X_39,返回27,否则返回如果X_49=X_40,返回28,否则返回如果X_49=X_41,返回29,否则返回如果X_49=X_42,返回30,否则返回如果X_49=X_43,返回31,否则返回32
X_52赋值:如果收盘价的有效数据周期数>=31,返回(X_49*3+收盘价的31日简单移动平均)/4,否则返回收盘价的5日简单移动平均和收盘价的收盘价的有效数据周期数日简单移动平均的较大值
X_53赋值:X_52
X_54赋值:收盘价的8日指数移动平均
X_55赋值:(5日前的开盘价+5日前的收盘价)/2
X_56赋值:(最高价+最低价+收盘价+开盘价)/4
X_57赋值:X_55和X_56和5日内最高价的最高值的较大值的较大值
X_58赋值:X_55和X_56和5日内最低价的最低值的较小值的较小值
X_59赋值:X_57=X_55
X_60赋值:X_59
X_61赋值:上次X_60距今天数日前的X_57
X_62赋值:收盘价的5日指数移动平均-收盘价的55日指数移动平均
X_63赋值:X_62的10日指数移动平均
X_64赋值:X_62-X_63
X_65赋值:收盘价>X_61 AND X_64>0
X_66赋值:收盘价的8日指数移动平均
X_67赋值:收盘价的14日指数移动平均
X_68赋值:收盘价的30日指数移动平均
X_69赋值:收盘价的60日指数移动平均
X_70赋值:上次X_22上穿X_17距今天数日前的7日内(最高价+收盘价+最低价+最高价)/4的最高值
X_71赋值:上次X_17上穿X_22距今天数日前的10日内开盘价和收盘价的较小值的最低值
X_72赋值:上次收盘价的10日简单移动平均上穿收盘价的5日简单移动平均距今天数日前的7日内收盘价和开盘价的较大值的最高值
X_73赋值:上次收盘价的5日简单移动平均上穿收盘价的10日简单移动平均距今天数日前的10日内收盘价和开盘价的较小值的最低值
X_74赋值:如果收盘价>500,返回X_72,否则返回X_70
X_75赋值:如果收盘价>500,返回X_73,否则返回X_71
X_76赋值:如果X_74=X_74的最后一日取值设为常数,返回X_74的最后一日取值设为常数,否则返回无效数
X_77赋值:收盘价的1日指数移动平均
X_78赋值:X_77的5日指数移动平均
X_79赋值:5日内X_78的最高值的1日指数移动平均
X_80赋值:17日内X_79的最高值的1日指数移动平均
X_81赋值:17日内X_80的最高值的2日指数移动平均
X_82赋值:17日内X_81的最高值的3日指数移动平均
X_83赋值:首次收盘价>0距今天数>30 AND 如果模糊匹配品种名称,返回0,否则返回1 AND 如果模糊匹配品种名称,返回0,否则返回1 AND 量比>0 AND 取反 AND 收盘价<50
X_84赋值:1日前的收盘价*1.01>=X_53 AND 1日前的收盘价*1.01>=X_76
X_85赋值:收盘价>=1日前的收盘价*1.01 AND 收阳线ANDSE (统计3日中满足收盘价>=X_53的天数=3 OR 统计3日中满足收盘价>=X_76的天数=3)
X_86赋值:X_66>X_67 AND X_67>X_68 AND X_69>=1日前的X_69
X_87赋值:如果X_85ANDX_86,返回0.5,否则返回0
X_88赋值:收盘价-1日前的收盘价和0的较大值的14日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的14日[1日权重]移动平均*100
X_89赋值:收盘价-1日前的收盘价和0的较大值的75日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的75日[1日权重]移动平均*100
X_90赋值:收盘价的3日指数移动平均
X_91赋值:收盘价的22日线性回归斜率*20+收盘价的55日指数移动平均
X_92赋值:X_91的1日简单移动平均
X_93赋值:X_92*0.985
X_94赋值:如果X_90>X_92,返回X_92,否则返回X_93
X_95赋值:(开盘价+最高价+最低价)/3的4日指数移动平均
X_96赋值:(X_95/1日前的X_95-1)*100的反正切*180/3.1416
X_97赋值:(X_94/1日前的X_94-1)*100的反正切*180/3.1416
X_98赋值:100*(21日内最高价的最高值-收盘价)/(21日内最高价的最高值-21日内最低价的最低值)
X_99赋值:100*(42日内最高价的最高值-收盘价)/(42日内最高价的最高值-42日内最低价的最低值)
X_100赋值:成交量(手)>=3日内成交量(手)的最高值 AND 成交量(手)>成交量(手)的3日简单移动平均 AND 成交量(手)>成交量(手)的40日简单移动平均 AND 成交量(手)>成交量(手)的89日简单移动平均 AND 成交量(手)的3日简单移动平均>=1日前的成交量(手)的3日简单移动平均
X_101赋值:收阳线ANDSE 收盘价/1日前的收盘价>1.01 AND 如果X_54>=X_53,返回X_54>=X_53,否则返回X_53/X_54<1.005 AND 收盘价>=X_76 AND 收盘价>=10日内收盘价的最高值 AND 收盘价>=X_82
X_102赋值:X_67>X_68 AND X_67>1日前的X_67 AND X_68>1日前的X_68
X_103赋值:成交量(手)<成交量(手)的3日简单移动平均 AND 成交量(手)<成交量(手)的40日简单移动平均 AND 成交量(手)<成交量(手)的89日简单移动平均
X_104赋值:统计5日中满足X_97>=45的天数>=1 OR 统计5日中满足X_96>=45的天数>=1
X_105赋值:如果最近21日存在X_100ANDX_101ANDX_65ANDX_102ANDEXIST(X_103,21),返回1.5,否则返回0
输出股道漫步趋势:X_16 AND X_105=1.5ANDEXIST(X_87=0.5,21)ANDX_83ANDX_104的21日过滤

演示图片

s_15641.png

相关选股公式

  1. 太极乾坤选股公式
  2. 尾进明早出挣选股公式
  3. 圣火选股公式
  4. 强庄起爆点选股公式
  5. 大阳不破选股公式
  6. 花开富贵选股公式
  7. 万手单选股公式
  8. 顺势寻牛选股公式
  9. 杀庄逃庄选股公式
  10. 金品选股公式