突破回踩选股公式

发布时间:2024-01-07

选股公式源码

VAR1:=DYNAINFO(17)>0;
VAR2:=IF(INBLOCK(1),0,1) AND IF(INBLOCK(2),0,1);
VAR3:=FINANCE(40)/100000000<1000;
VAR4:=IF(CODELIKE(3) OR CODELIKE(4),0,1);
VAR5:=IF(NAMELIKE(5),0,1);
VAR6:=VAR2 AND VAR1 AND VAR3 AND DYNAINFO(17)>0 AND VAR4 AND VAR5;
VAR7:=MA(CLOSE,5);
VAR8:=CLOSE>VAR7 AND VAR7>REF(VAR7,1) AND REF(VAR7,1)<REF(VAR7,2);
VAR9:=EMA(CLOSE,5)-EMA(CLOSE,15);
VAR10:=EMA(VAR9,5);
VAR11:=2*(VAR9-VAR10);
VAR12:=NOT(HIGH>MAX(OPEN,CLOSE)*1.02);
VAR13:=VOL*10000/FINANCE(7);
VAR14:=VOL/CONST(HHV(VOL,90))*100;
VAR15:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
突破回踩:MA(CLOSE,20)>MA(CLOSE,30) AND MA(CLOSE,30)>MA(CLOSE,60) AND MA(CLOSE,5)>MA(CLOSE,20) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)<MA(CLOSE,10) AND VOL>MA(VOL,5) AND VAR8=1 AND VAR11>0 AND NOT(COUNT(REF(HIGH,1)/REF(CLOSE,2)>1.11,360)) AND VAR6 AND VAR12 AND VAR13>=3 AND VAR14<70 AND VAR15>5;

选股公式翻译

VAR1赋值:量比>0
VAR2赋值:如果属于某板块,返回0,否则返回1 AND 如果属于某板块,返回0,否则返回1
VAR3赋值:流通市值/100000000<1000
VAR4赋值:如果模糊匹配品种代码ORCODELIKE(4),返回0,否则返回1
VAR5赋值:如果模糊匹配品种名称,返回0,否则返回1
VAR6赋值:VAR2 AND VAR1 AND VAR3 AND 量比>0 AND VAR4 AND VAR5
VAR7赋值:收盘价的5日简单移动平均
VAR8赋值:收盘价>VAR7 AND VAR7>1日前的VAR7 AND 1日前的VAR7<2日前的VAR7
VAR9赋值:收盘价的5日指数移动平均-收盘价的15日指数移动平均
VAR10赋值:VAR9的5日指数移动平均
VAR11赋值:2*(VAR9-VAR10)
VAR12赋值:取反
VAR13赋值:成交量(手)*10000/流通股本(股)
VAR14赋值:成交量(手)/90日内成交量(手)的最高值的最后一日取值设为常数*100
VAR15赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
输出突破回踩:收盘价的20日简单移动平均>收盘价的30日简单移动平均 AND 收盘价的30日简单移动平均>收盘价的60日简单移动平均 AND 收盘价的5日简单移动平均>收盘价的20日简单移动平均 AND 收盘价的10日简单移动平均>收盘价的20日简单移动平均 AND 收盘价的5日简单移动平均<收盘价的10日简单移动平均 AND 成交量(手)>成交量(手)的5日简单移动平均 AND VAR8=1 AND VAR11>0 AND 取反 AND VAR6 AND VAR12 AND VAR13>=3 AND VAR14<70 AND VAR15>5

演示图片

s_15899.png

相关选股公式

  1. N型突破选股公式
  2. 放量突破机会选股公式
  3. 财务突破买点选股公式
  4. 起爆狙击选股公式
  5. 回踩确认选股公式
  6. 一阳突破选股公式
  7. 金牛突破选股公式
  8. 突破主升狙击选股公式
  9. 出击捉庄选股公式
  10. 倍量突破选股公式