智能MACD选股公式

发布时间:2024-01-21

选股公式源码

Var1:=(HIGH+LOW+CLOSE)/3;
Var2:=(EMA(Var1,2)+EMA(Var1,5)+EMA(Var1,8))/3;
Var3:=(EMA(Var1,6)+EMA(Var1,9)+EMA(Var1,12))/3;
Var4:=BARSCOUNT(CLOSE);
Var5:=HHV(HIGH,200);
Var6:=LLV(LOW,200);
Var7:=(Var5-Var6)/40;
Var8:=HIGH+Var7;
Var9:=LOW-Var7;
sjzc:=IF((Var4+0)/34=FLOOR((Var4+0)/34),50,0),COLORred;
XG:sjzc;

选股公式翻译

VAR1赋值:(最高价+最低价+收盘价)/3
VAR2赋值:(VAR1的2日指数移动平均+VAR1的5日指数移动平均+VAR1的8日指数移动平均)/3
VAR3赋值:(VAR1的6日指数移动平均+VAR1的9日指数移动平均+VAR1的12日指数移动平均)/3
VAR4赋值:收盘价的有效数据周期数
VAR5赋值:200日内最高价的最高值
VAR6赋值:200日内最低价的最低值
VAR7赋值:(VAR5-VAR6)/40
VAR8赋值:最高价+VAR7
VAR9赋值:最低价-VAR7
SJZC赋值:如果(VAR4+0)/34=(VAR4+0)/34的向下舍入,返回50,否则返回0,画红色
输出XG:SJZC

演示图片

s_15908.png

相关选股公式

  1. 九天揽月选股公式
  2. 绝密爆点选股公式
  3. 探底棒选股公式
  4. 红色神剑选股公式
  5. 黎明之星选股公式
  6. MACD绿柱翻红选股公式
  7. MACD资金量能选股公式
  8. 金叉发财选股公式
  9. 主控力度选股公式
  10. 无敌战狼选股公式