短线主力资金选股公式

发布时间:2023-11-26

选股公式源码

M1:=5;
M2:=10;
M4:=60;
VOLUME:=VOL;
MAVOL1:=MA(VOLUME,M1);
MAVOL2:=MA(VOLUME,M2);
MAVOL4:=MA(VOLUME,M4);
A1:=COUNT(CROSS(MAVOL1,MAVOL2),2)=1;
A2:=COUNT(CROSS(MAVOL1,MAVOL4),2)=1;
XG1:=A1 AND A2;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR3:=SMA(Abs(HIGH-VAR1),13,1)/SMA(MIN(HIGH-VAR1,0),10,1);
VAR4:=EMA(VAR3,10);
VAR5:=HHV(HIGH,33);
VAR6:=EMA(IF(HIGH>=VAR5,VAR4,0),3);
XG2:=VAR6< REF(VAR6,1) ;
XG3:=XG2 AND REF(XG2,1)=0 AND VAR6< 0;
选股:XG1 AND XG3;

选股公式翻译

M1赋值:5
M2赋值:10
M4赋值:60
VOLUME赋值:成交量(手)
MAVOL1赋值:VOLUME的M1日简单移动平均
MAVOL2赋值:VOLUME的M2日简单移动平均
MAVOL4赋值:VOLUME的M4日简单移动平均
A1赋值:统计2日中满足MAVOL1上穿MAVOL2的天数=1
A2赋值:统计2日中满足MAVOL1上穿MAVOL4的天数=1
XG1赋值:A1 AND A2
VAR1赋值:1日前的(最低价+开盘价+收盘价+最高价)/4
VAR3赋值:最高价-VAR1的绝对值的13日[1日权重]移动平均/最高价-VAR1和0的较小值的10日[1日权重]移动平均
VAR4赋值:VAR3的10日指数移动平均
VAR5赋值:33日内最高价的最高值
VAR6赋值:如果最高价>=VAR5,返回VAR4,否则返回0的3日指数移动平均
XG2赋值:VAR6< 1日前的VAR6 
XG3赋值:XG2 AND 1日前的XG2=0 AND VAR6< 0
输出选股:XG1 AND XG3

演示图片

s_15806.png

相关选股公式

  1. 主导资金动向选股公式
  2. 敌我争霸选股公式
  3. 高盈亏比选股公式
  4. 子午线选股公式
  5. 金牌短线选股公式
  6. 短线小天使选股公式
  7. 资金流入力度选股公式
  8. 放量上攻OBV选股公式
  9. 叠倍量选股公式
  10. 出击捉庄选股公式