龙头诀选股公式

发布时间:2020-06-28

选股公式源码

XA_1:=100-90*(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21));
XA_2:=100-MA(100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6)),34);
XA_3:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_4:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
XA_5:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
XA_6:=REF(XA_5,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_7:=REF(XA_6,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_8:=REF(XA_7,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_9:=REF(XA_8,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_10:=REF(XA_9,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_11:=REF(XA_10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_12:=REF(XA_11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_13:=REF(XA_12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_14:=REF(XA_13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_15:=REF(XA_14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_16:=REF(XA_15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_17:=XA_5 OR XA_6 OR XA_7 OR XA_8 OR XA_9 OR XA_10 OR XA_11 OR XA_12 OR XA_13 OR XA_14 OR XA_15 OR XA_16;
XA_18:=XA_4 AND REF(XA_17,1);
XA_19:=REF(HIGH+LOW,1)/2;
XA_20:=SUM(MAX(0,HIGH-XA_19),26)/SUM(MAX(0,XA_19-LOW),26)*100;
龙头诀选股预警:CROSS(XA_1,MA(XA_2,6)) AND XA_18 AND XA_20>REF(XA_20,1) AND XA_3>5;

选股公式翻译

XA_1:=100-90*(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21));
XA_2:=100-MA(100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6)),34);
XA_3:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_4:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
XA_5:=CLOSE=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_7:=REF(XA_6,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_8:=REF(XA_7,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_9:=REF(XA_8,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_10:=REF(XA_9,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_11:=REF(XA_10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_12:=REF(XA_11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_13:=REF(XA_12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_14:=REF(XA_13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_15:=REF(XA_14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
XA_16:=REF(XA_15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
XA_17:=XA_5 OR XA_6 OR XA_7 OR XA_8 OR XA_9 OR XA_10 OR XA_11 OR XA_12 OR XA_13 OR XA_14 OR XA_15 OR XA_16;
XA_18:=XA_4 AND REF(XA_17,1);
XA_19:=REF(HIGH+LOW,1)/2;
XA_20:=SUM(MAX(0,HIGH-XA_19),26)/SUM(MAX(0,XA_19-LOW),26)*100;
龙头诀选股预警:CROSS(XA_1,MA(XA_2,6)) AND XA_18 AND XA_20>REF(XA_20,1) AND XA_3>5;

演示图片


相关选股公式

  1. 波谷选股公式
  2. 乘风选股公式
  3. 上拐选股公式
  4. 狂买选股公式
  5. 急买选股公式
  6. 阴阳守恒定律选股公式
  7. 犀牛一号选股公式
  8. 千里挑一选股公式
  9. 底域选股公式
  10. 圆狐底选股公式