慢慢出来个底选股公式

发布时间:2020-06-29

选股公式源码

VAR1:=CLOSE-REF(CLOSE,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
VAR3:=MA(CLOSE,5);
VAR4:=MA(CLOSE,4);
VAR5:=MA(CLOSE,3);
VAR6:=MA(VOL,5);
VAR7:=VAR3>VAR4 AND SLOPE(VAR3,5)<0 AND SLOPE(VAR4,4)<0 AND SLOPE(VAR5,3) AND REF(VAR4>VAR5,1) AND CROSS(VAR5,VAR4) AND VOL>VAR6;
XG:IF(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2)),1,0) AND VAR7;

选股公式翻译

VAR1赋值:收盘价-1日前的收盘价
VAR2赋值:100*VAR1的6日指数移动平均的6日指数移动平均/VAR1的绝对值的6日指数移动平均的6日指数移动平均
VAR3赋值:收盘价的5日简单移动平均
VAR4赋值:收盘价的4日简单移动平均
VAR5赋值:收盘价的3日简单移动平均
VAR6赋值:成交量(手)的5日简单移动平均
VAR7赋值:VAR3>VAR4 AND VAR3的5日线性回归斜率<0 AND VAR4的4日线性回归斜率<0 AND VAR5的3日线性回归斜率 AND 1日前的VAR4>VAR5 AND VAR5上穿VAR4 AND 成交量(手)>VAR6
输出XG:如果2日内VAR2的最低值=7日内VAR2的最低值ANDCOUNT(VAR2<0,2)ANDCROSS(VAR2,VAR2的2日简单移动平均),返回1,否则返回0 AND VAR7

演示图片


相关选股公式

  1. MACD和VOL双重选股公式
  2. 吞没选股公式
  3. 量价狙击选股公式
  4. 老牛AK47捉妖选股公式
  5. 超强趋势上升选股公式
  6. 波段起爆点选股公式
  7. 桩量选股公式
  8. 血战超跌选股公式
  9. 偷偷过左峰选股公式
  10. 抓宝选股公式