太极乾坤选股公式

发布时间:2024-01-21

选股公式源码

VAR1:=(C>OPEN) AND (REF(C,1)<REF(OPEN,1));
VAR2:=((C>OPEN) AND (REF(C,1)<REF(OPEN,1))) AND (C>=((((Abs(REF(OPEN,1)-REF(C,1)))*2)/5)+REF(C,1)));
VAR3:=((C>OPEN) AND (REF(C,1)<REF(OPEN,1))) AND (C>=(((ABS(REF(OPEN,1)-REF(C,1)))/2)+REF(C,1)));
VAR4:=((C>OPEN) AND (REF(C,1)<REF(OPEN,1))) AND (C>=REF(OPEN,1));
VAR5:=((((ABS(OPEN-REF(C,1)))<=0.03) OR ((ABS(LOW-REF(C,1)))<=0.05)) OR (LOW=REF(LOW,1))) OR (OPEN=REF(C,1));
VAR7:=VOL<REF(LLV(VOL,100),1);
VAR8:=(((OPEN-C)/OPEN)>=0.04) AND ((((VOL/MA(VOL,60))<=(2/3)) OR ((VOL/REF(VOL,1))<=1)) OR (VOL<HHV(VOL,5)));
VAR9:=VOL<REF(LLV(VOL,20),1);
VAR10:=((C>OPEN) AND (((OPEN-LOW)/OPEN)>=0.025)) OR ((C<OPEN) AND (((C-LOW)/C)>=0.025));
VAR11:=(((VOL<REF(VOL,1)) AND (REF(VOL,1)<REF(VOL,2))) AND (REF(VOL,2)<REF(VOL,3))) AND (HIGH>LOW);
VAR12:=(VOL/REF(VOL,1))<=0.52;
VAR13:=COUNT(VAR12,2) AND ((VOL/REF(VOL,1))<=0.7);
VAR14:=COUNT(((((VAR7 OR VAR8) OR VAR9) OR VAR10) OR VAR11) OR VAR13,5);
VAR15:=IF(NAMELIKE('DT'),0,1);
VAR16:=IF(NAMELIKE('*ST'),0,1);
VAR17:=((DYNAINFO(7)>2) AND (DYNAINFO(7)<270)) AND (NOT(DYNAINFO(4)=0));
VAR18:=(VAR15 AND VAR16) AND VAR17;
VAR19:=((REF(C,1)-HHV(OPEN,4))/HHV(OPEN,4))<=-0.05;
太:=IF((((VAR19 AND VAR1) AND VAR5) AND VAR14) AND VAR18,1,0);
极:=IF((((VAR19 AND VAR2) AND VAR5) AND VAR14) AND VAR18,1.5,0);
乾:=IF((((VAR19 AND VAR3) AND VAR5) AND VAR14) AND VAR18,2,0);
坤:=IF((((VAR19 AND VAR4) AND VAR5) AND VAR14) AND VAR18,2.5,0);
XG:太 AND 极 OR 乾 OR 坤;

选股公式翻译

VAR1赋值:(收阳线) AND (1日前的收盘价<1日前的开盘价)
VAR2赋值:((收阳线) AND (1日前的收盘价<1日前的开盘价)) AND (收盘价>=((((1日前的开盘价-1日前的收盘价的绝对值)*2)/5)+1日前的收盘价))
VAR3赋值:((收阳线) AND (1日前的收盘价<1日前的开盘价)) AND (收盘价>=(((1日前的开盘价-1日前的收盘价的绝对值)/2)+1日前的收盘价))
VAR4赋值:((收阳线) AND (1日前的收盘价<1日前的开盘价)) AND (收盘价>=1日前的开盘价)
VAR5赋值:((((开盘价-1日前的收盘价的绝对值)<=0.03) OR ((最低价-1日前的收盘价的绝对值)<=0.05)) OR (最低价=1日前的最低价)) OR (开盘价=1日前的收盘价)
VAR7赋值:成交量(手)<1日前的100日内成交量(手)的最低值
VAR8赋值:(((开盘价-收盘价)/开盘价)>=0.04) AND ((((成交量(手)/成交量(手)的60日简单移动平均)<=(2/3)) OR ((成交量(手)/1日前的成交量(手))<=1)) OR (成交量(手)<5日内成交量(手)的最高值))
VAR9赋值:成交量(手)<1日前的20日内成交量(手)的最低值
VAR10赋值:((收阳线) AND (((开盘价-最低价)/开盘价)>=0.025)) OR ((收阴线) AND (((收盘价-最低价)/收盘价)>=0.025))
VAR11赋值:(((成交量(手)<1日前的成交量(手)) AND (1日前的成交量(手)<2日前的成交量(手))) AND (2日前的成交量(手)<3日前的成交量(手))) AND (最高价>最低价)
VAR12赋值:(成交量(手)/1日前的成交量(手))<=0.52
VAR13赋值:统计2日中满足VAR12的天数 AND ((成交量(手)/1日前的成交量(手))<=0.7)
VAR14赋值:统计5日中满足((((VAR7ORVAR8)ORVAR9)ORVAR10)ORVAR11)ORVAR13的天数
VAR15赋值:如果模糊匹配品种名称,返回0,否则返回1
VAR16赋值:如果模糊匹配品种名称,返回0,否则返回1
VAR17赋值:((现价>2) AND (现价<270)) AND (取反)
VAR18赋值:(VAR15 AND VAR16) AND VAR17
VAR19赋值:((1日前的收盘价-4日内开盘价的最高值)/4日内开盘价的最高值)<=-0.05
太赋值:如果(((VAR19ANDVAR1)ANDVAR5)ANDVAR14)ANDVAR18,返回1,否则返回0
极赋值:如果(((VAR19ANDVAR2)ANDVAR5)ANDVAR14)ANDVAR18,返回1.5,否则返回0
乾赋值:如果(((VAR19ANDVAR3)ANDVAR5)ANDVAR14)ANDVAR18,返回2,否则返回0
坤赋值:如果(((VAR19ANDVAR4)ANDVAR5)ANDVAR14)ANDVAR18,返回2.5,否则返回0
输出XG:太 AND 极 OR 乾 OR 坤

演示图片

s_15911.png

相关选股公式

  1. 起飞加速选股公式
  2. 搏涨成交量选股公式
  3. 擒牛成交量选股公式
  4. 妖成龙选股公式
  5. 精品擒妖选股公式
  6. 尾进明早出挣选股公式
  7. 圣火选股公式
  8. 强庄起爆点选股公式
  9. 大阳不破选股公式
  10. 花开富贵选股公式