妖起来选股公式

发布时间:2022-08-21

选股公式源码

X_1:=IF(NAMELIKE(2),0,1);
X_2:=IF(NAMELIKE(3),0,1);
X_3:=DYNAINFO(4)>0;
X_4:=FINANCE(7)<=8000000000;
X_5:=CLOSE/REF(CLOSE,1)>1.0975 AND HIGH=OPEN;
X_6:=X_1 AND X_2 AND X_3 AND X_4 AND NOT(X_5);
X_7:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
X_8:=(HIGH+LOW+CLOSE)/3;
X_9:=IF(CLOSE>OPEN AND HIGH>REF(CLOSE,1),ATAN((HIGH-REF(CLOSE,1))/REF(CLOSE,1)),0);
X_10:=IF(CLOSE>OPEN AND HIGH<REF(CLOSE,1),-ATAN((REF(CLOSE,1)-HIGH)/REF(CLOSE,1)),0);
X_11:=IF(CLOSE>OPEN AND HIGH=REF(CLOSE,1),0,0);
X_12:=IF(CLOSE<OPEN AND HIGH>REF(CLOSE,1),ATAN((HIGH-REF(CLOSE,1))/REF(CLOSE,1)),0);
X_13:=IF(CLOSE<OPEN AND HIGH<REF(CLOSE,1),-ATAN((REF(CLOSE,1)-HIGH)/REF(CLOSE,1)),0);
X_14:=IF(CLOSE<OPEN AND HIGH=REF(CLOSE,1),0,0);
X_15:=X_9+X_10+X_11+X_12+X_13+X_14;
X_16:=MA(X_15,9);
X_17:=MA(X_15,5);
X_18:=MA(X_15,3);
X_19:=ATAN((HIGH-REF(HIGH,1))/REF(HIGH,1)/0.1)/6.28*360;
X_20:=ATAN((LOW-REF(LOW,1))/REF(LOW,1)/0.1)/6.28*360;
X_21:=ATAN((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)/0.1)/6.28*360;
X_22:=ATAN((OPEN-REF(OPEN,1))/REF(OPEN,1)/0.1)/6.28*360;
X_23:=MIN(MIN(MIN(X_21,X_22),X_19),X_20);
X_24:=MAX(MAX(MAX(X_21,X_22),X_19),X_20);
X_25:=MIN(X_21,X_22);
X_26:=MAX(X_21,X_22);
X_27:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-X_8);
X_28:=IF(CLOSE>OPEN AND LOW>REF(CLOSE,1),ATAN((LOW-REF(CLOSE,1))/REF(CLOSE,1)),0);
X_29:=IF(CLOSE>OPEN AND LOW<REF(CLOSE,1),-(ATAN(REF(CLOSE,1)-LOW)/REF(CLOSE,1)),0);
X_30:=IF(CLOSE>OPEN AND LOW=REF(CLOSE,1),0,0);
X_31:=IF(CLOSE<OPEN AND LOW>REF(CLOSE,1),ATAN((LOW-REF(CLOSE,1))/REF(CLOSE,1)),0);
X_32:=IF(CLOSE<OPEN AND LOW<REF(CLOSE,1),-ATAN((REF(CLOSE,1)-LOW)/REF(CLOSE,1)),0);
X_33:=IF(CLOSE<OPEN AND LOW=REF(CLOSE,1),0,0);
X_34:=X_28+X_29+X_30+X_31+X_32+X_33;
X_35:=MA(X_34,9);
X_36:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
X_37:=MA(X_34,5);
X_38:=MA(X_34,3);
X_39:=ATAN(X_16/0.09);
X_40:=ATAN(X_17/0.05);
X_41:=ATAN(X_18/0.03);
X_42:=ATAN((-X_35)/0.09);
X_43:=ATAN((-X_37)/0.05);
X_44:=ATAN((-X_38)/0.03);
X_45:=CLOSE/REF(CLOSE,1)>1.028 AND CLOSE=HIGH AND BETWEEN(FORCAst(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_46:=EXPMEMA(MAX(MAX(HIGH-LOW,Abs(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),15);
X_47:=IF(HIGH=LOW,1,X_8-MIN(CLOSE,OPEN));
X_48:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
X_49:=IF(X_26>0 AND X_25>0,X_26,0);
X_50:=IF(X_26<0 AND X_25<0,X_25,0);
X_51:=IF(X_26>0 AND X_25<0,X_26,0);
X_52:=IF(X_26>0 AND X_25<0,X_25,0);
X_53:=X_7*X_48;
X_54:=X_48*X_27;
X_55:=X_36*X_48;
X_56:=X_47*X_48;
X_57:=X_56+X_55;
X_58:=X_53+X_54;
X_59:=X_57-X_58;
X_60:=X_59;
X_61:=FILTER(X_45,28);
X_62:=(X_41+X_40+X_39)/3/6.28*360;
X_63:=X_62-REF(X_62,1)>0;
X_64:=EMA(CLOSE,5);
X_65:=MA(X_49+X_51,1);
X_66:=MA(X_50+X_52,1);
X_67:=X_65+X_66;
X_68:=FINDHIGH(X_24,1,3,1);
X_69:=FINDHIGH(X_24,1,3,2);
X_70:=BARSCOUNT(X_68)<BARSCOUNT(X_69);
X_71:=IF(X_70,X_68,0);
X_72:=IF(X_70,X_69,0);
X_73:=X_71-X_72;
X_74:=MA(REF(X_68+X_73,1),5);
X_75:=X_74-REF(X_74,1)>0;
X_76:=(CLOSE-X_64)/X_64*100;
X_77:=ATAN((X_64/REF(X_64,1)-1)*100)*180/3.1416;
X_78:=EMA(CLOSE,30);
X_79:=HIGH-REF(HIGH,1);
X_80:=REF(LOW,1)-LOW;
X_81:=EXPMEMA(IF(X_79>0 AND X_79>X_80,X_79,0),15);
X_82:=X_81*100/X_46;
X_83:=X_82-REF(X_82,1)>0;
X_84:=(CLOSE-X_78)/X_78*100;
X_85:=COUNT(CROSS(X_76,0),3)>=1 AND X_84>REF(X_84,1) AND X_64>REF(X_64,1) AND (CLOSE/REF(CLOSE,1)-1)*100>2 AND REF(CLOSE,1)<X_78;
X_86:=FILTER(X_85,10);
X_87:=MA(X_59,5)*20;
X_88:=SMA(X_87,3,1);
X_89:=X_88-REF(X_88,1)>0;
准备:=X_61 AND X_63 AND X_62>30 AND X_6 AND X_75 AND X_83 AND X_89;
启航:=FILTER(CROSS(CLOSE,EMA(HIGH,3)*1.03) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.04,13);
妖起来:准备 AND 启航;

选股公式翻译

X_1赋值:如果模糊匹配品种名称,返回0,否则返回1
X_2赋值:如果模糊匹配品种名称,返回0,否则返回1
X_3赋值:开盘价>0
X_4赋值:流通股本(股)<=8000000000
X_5赋值:收盘价/1日前的收盘价>1.0975 AND 最高价=开盘价
X_6赋值:X_1 AND X_2 AND X_3 AND X_4 AND 取反
X_7赋值:如果最高价=最低价,返回1,否则返回最高价-开盘价和收盘价的较大值
X_8赋值:(最高价+最低价+收盘价)/3
X_9赋值:如果收盘价>OPENANDHIGH>1日前的收盘价,返回(最高价-1日前的收盘价)/1日前的收盘价的反正切,否则返回0
X_10赋值:如果收盘价>OPENANDHIGH<1日前的收盘价,返回-(1日前的收盘价-最高价)/1日前的收盘价的反正切,否则返回0
X_11赋值:如果收盘价>OPENANDHIGH=1日前的收盘价,返回0,否则返回0
X_12赋值:如果收盘价1日前的收盘价,返回(最高价-1日前的收盘价)/1日前的收盘价的反正切,否则返回0
X_13赋值:如果收盘价OPENANDLOW>1日前的收盘价,返回(最低价-1日前的收盘价)/1日前的收盘价的反正切,否则返回0
X_29赋值:如果收盘价>OPENANDLOW<1日前的收盘价,返回-(1日前的收盘价-最低价的反正切/1日前的收盘价),否则返回0
X_30赋值:如果收盘价>OPENANDLOW=1日前的收盘价,返回0,否则返回0
X_31赋值:如果收盘价1日前的收盘价,返回(最低价-1日前的收盘价)/1日前的收盘价的反正切,否则返回0
X_32赋值:如果收盘价1.028 AND 收盘价=最高价 AND 成交量(手)的4日线性回归预测值位于0.2*成交量(手)的12日线性回归预测值和2.1*成交量(手)的12日线性回归预测值之间
X_46赋值:最高价-最低价和最高价-1日前的收盘价的绝对值的较大值和1日前的收盘价-最低价的绝对值的较大值的15日指数平滑移动平均
X_47赋值:如果最高价=最低价,返回1,否则返回X_8-收盘价和开盘价的较小值
X_48赋值:成交量(手)/如果最高价=最低价,返回4,否则返回最高价-最低价
X_49赋值:如果X_26>0ANDX_25>0,返回X_26,否则返回0
X_50赋值:如果X_26<0ANDX_25<0,返回X_25,否则返回0
X_51赋值:如果X_26>0ANDX_25<0,返回X_26,否则返回0
X_52赋值:如果X_26>0ANDX_25<0,返回X_25,否则返回0
X_53赋值:X_7*X_48
X_54赋值:X_48*X_27
X_55赋值:X_36*X_48
X_56赋值:X_47*X_48
X_57赋值:X_56+X_55
X_58赋值:X_53+X_54
X_59赋值:X_57-X_58
X_60赋值:X_59
X_61赋值:X_45的28日过滤
X_62赋值:(X_41+X_40+X_39)/3/6.28*360
X_63赋值:X_62-1日前的X_62>0
X_64赋值:收盘价的5日指数移动平均
X_65赋值:X_49+X_51的1日简单移动平均
X_66赋值:X_50+X_52的1日简单移动平均
X_67赋值:X_65+X_66
X_68赋值:X_24在1日前的3天内第1个最高价
X_69赋值:X_24在1日前的3天内第2个最高价
X_70赋值:X_68的有效数据周期数0
X_76赋值:(收盘价-X_64)/X_64*100
X_77赋值:(X_64/1日前的X_64-1)*100的反正切*180/3.1416
X_78赋值:收盘价的30日指数移动平均
X_79赋值:最高价-1日前的最高价
X_80赋值:1日前的最低价-最低价
X_81赋值:如果X_79>0ANDX_79>X_80,返回X_79,否则返回0的15日指数平滑移动平均
X_82赋值:X_81*100/X_46
X_83赋值:X_82-1日前的X_82>0
X_84赋值:(收盘价-X_78)/X_78*100
X_85赋值:统计3日中满足X_76上穿0的天数>=1 AND X_84>1日前的X_84 AND X_64>1日前的X_64 AND (收盘价/1日前的收盘价-1)*100>2 AND 1日前的收盘价0
准备赋值:X_61 AND X_63 AND X_62>30 AND X_6 AND X_75 AND X_83 AND X_89
启航赋值:收盘价上穿最高价的3日指数移动平均*1.03AND(收盘价-1日前的收盘价)/1日前的收盘价>0.04的13日过滤
输出妖起来:准备 AND 启航

演示图片

s_15074.png

相关选股公式

  1. 妖王潜力选股公式
  2. 金牛院选股公式
  3. 超短王者公式
  4. 海底捞选股公式
  5. 涨在即选股公式
  6. 老妖异动选股公式
  7. 一阳穿30选股公式
  8. 一阳穿60选股公式
  9. 三三一选股公式
  10. 妖来了选股公式