寻龙趋势选股公式

发布时间:2022-11-13

选股公式源码

X_44:=10;
X_45:=10;
X_46:=3;
X_47:=10;
X_48:=2.5;
X_49:=MAX(MAX(HIGH-LOW,Abs(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
X_50:=(HIGH+LOW)/2+MA(X_49,X_47)*X_48;
X_51:=(HIGH+LOW)/2-MA(X_49,X_47)*X_48;
X_52:=REF(X_50,BArslAst(X_50<=REF(X_50,1)));
X_53:=LLV(X_50,X_45*1.5);
X_54:=IF(X_53!=REF(X_53,1) AND X_52<REF(X_52,1),X_52,IF(X_52=X_53,X_52,X_53));
X_55:=BARSLAST(CROSS(0.5,X_50=X_54))+1;
X_56:=CROSS(COUNT(CROSS(CLOSE,X_54) OR CROSS(CLOSE,REF(X_54,2)) AND X_50>X_54,X_55),0.5);
X_57:=BARSLAST(X_56);
X_58:=BARSLAST(CROSS(HHV(X_51,X_57+1),CLOSE));
XG:CROSS(X_58,X_57);

选股公式翻译

X_44赋值:10
X_45赋值:10
X_46赋值:3
X_47赋值:10
X_48赋值:2.5
X_49赋值:最高价-最低价和1日前的收盘价-最高价的绝对值的较大值和1日前的收盘价-最低价的绝对值的较大值
X_50赋值:(最高价+最低价)/2+X_49的X_47日简单移动平均*X_48
X_51赋值:(最高价+最低价)/2-X_49的X_47日简单移动平均*X_48
X_52赋值:上次X_50<=1日前的X_50距今天数日前的X_50
X_53赋值:X_45*1.5日内X_50的最低值
X_54赋值:如果X_53不等于1日前的X_53ANDX_52<1日前的X_52,返回X_52,否则返回如果X_52=X_53,返回X_52,否则返回X_53
X_55赋值:上次0.5上穿X_50=X_54距今天数+1
X_56赋值:统计X_55日中满足收盘价上穿X_54ORCROSS(收盘价,2日前的X_54)ANDX_50>X_54的天数上穿0.5
X_57赋值:上次X_56距今天数
X_58赋值:上次X_57+1日内X_51的最高值上穿收盘价距今天数
输出XG:X_58上穿X_57

演示图片

s_15148.png

相关选股公式

  1. 金牛院选股公式
  2. 超短王者公式
  3. 海底捞选股公式
  4. 一阳穿30选股公式
  5. 一阳穿60选股公式
  6. 三三一选股公式
  7. 妖来了选股公式
  8. 大吉大利选股公式
  9. 一穿五选股公式
  10. 三线粘合剑选股公式