底部五黑马选股公式

发布时间:2023-08-20

选股公式源码

CC:=Abs((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
EE:=(1-14/100)*DD;
抄底用:=BETWEEN(C,EE*0.98,EE*1.01);
TJ1:=C/MA(C,40)<0.74;
TJ2:=(H-L)/REF(C,1)>0.05;
TJ3:=COUNT(TJ2,5)>1;
宝石底:=TJ1 AND TJ2 AND TJ3;
K:=100;
VAR1C:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VAR2C:=DMA(CLOSE,VOL/MA(VOL,33)/33);
VAR3C:=(CLOSE-VAR1C)/VAR1C*100<-11/K*100;
VAR4C:=(VAR1C-VAR2C)/VAR2C*100<-22.3/K*100;
VAR5C:=VAR3C AND VAR4C AND (OPEN>CLOSE OR OPEN<CLOSE) AND
(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 AND
(REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1)) AND
(REF(OPEN,2)>REF(CLOSE,2) OR REF
(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF
(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)
<REF(CLOSE,5)) AND (REF(OPEN,6)>REF(CLOSE,6) OR REF(OPEN,6)<REF(CLOSE,6)) AND (REF(OPEN,7)>REF
(CLOSE,7) OR REF(OPEN,7)<REF(CLOSE,7));
VAR6C:=DMA(CLOSE,VOL/MA(VOL,3)/3);
VAR7C:=DMA(CLOSE,VOL/MA(VOL,33)/33);
VAR8C:=(CLOSE-VAR6C)/VAR6C*100<-5;
VAR9C:=(VAR6C-VAR7C)/VAR7C*100<-18;
VARac:=(INDEXC-LLV(INDEXL,250))/(HHV(INDEXH,250)-LLV(INDEXL,250))*100;
VARBC:=SMA(VARAC,30,1);
VARCC:=SMA(VARBC,50,1);
VARDC:=VAR8C AND VAR9C AND (OPEN>CLOSE OR OPEN<CLOSE) AND
(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05 AND
(REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1));
VAREC:=VARDC AND COUNT(VARDC,2)=1 ;
短线黑马:=VAR5C OR VAREC;
N1:=9;
MTM:=C-REF(C,1);
VAR1:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1);
VAR2:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
EEA:=(C-REF(C,26))/REF(C,26)*10;
子墨抄底:=CROSS(RSI,20) AND VAR1<-45 AND VAR2<12 AND EEA<-2;
昨收:=REF(CLOSE,1);
趋势:=SMA(MAX(CLOSE-昨收,0),8,1)/SMA(ABS(CLOSE-昨收),8,1)*100;
黑马:=CROSS(趋势,15);
底部黑马1:=抄底用 AND 宝石底;
底部黑马2:=抄底用 AND 短线黑马;
底部黑马3:=宝石底 AND 短线黑马;
底部黑马4:=子墨抄底 AND 黑马;
底部黑马5:=短线黑马 AND 黑马;
XG:底部黑马1 OR 底部黑马2 OR 底部黑马3 OR 底部黑马4 OR 底部黑马5;

选股公式翻译

CC赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均
DD赋值:以CC为权重收盘价的动态移动平均
EE赋值:(1-14/100)*DD
抄底用赋值:收盘价位于EE*0.98和EE*1.01之间
TJ1赋值:收盘价/收盘价的40日简单移动平均<0.74
TJ2赋值:(最高价-最低价)/1日前的收盘价>0.05
TJ3赋值:统计5日中满足TJ2的天数>1
宝石底赋值:TJ1 AND TJ2 AND TJ3
K赋值:100
VAR1C赋值:以成交量(手)/成交量(手)的4日简单移动平均/4为权重收盘价的动态移动平均
VAR2C赋值:以成交量(手)/成交量(手)的33日简单移动平均/33为权重收盘价的动态移动平均
VAR3C赋值:(收盘价-VAR1C)/VAR1C*100<-11/K*100
VAR4C赋值:(VAR1C-VAR2C)/VAR2C*100<-22.3/K*100
VAR5C赋值:VAR3C AND VAR4C AND (收阴线OREN 收阳线) AND(开盘价-1日前的收盘价)/1日前的收盘价>-0.07 AND(1日前的收盘价>1日前的开盘价 OR 1日前的收盘价<1日前的开盘价) AND(2日前的开盘价>2日前的收盘价 OR 2日前的开盘价<2日前的收盘价) AND (3日前的开盘价>3日前的收盘价 OR 3日前的开盘价<3日前的收盘价) AND (4日前的开盘价>4日前的收盘价 OR 4日前的开盘价<4日前的收盘价) AND (5日前的开盘价>5日前的收盘价 OR 5日前的开盘价<5日前的收盘价) AND (6日前的开盘价>6日前的收盘价 OR 6日前的开盘价<6日前的收盘价) AND (7日前的开盘价>7日前的收盘价 OR 7日前的开盘价<7日前的收盘价)
VAR6C赋值:以成交量(手)/成交量(手)的3日简单移动平均/3为权重收盘价的动态移动平均
VAR7C赋值:以成交量(手)/成交量(手)的33日简单移动平均/33为权重收盘价的动态移动平均
VAR8C赋值:(收盘价-VAR6C)/VAR6C*100<-5
VAR9C赋值:(VAR6C-VAR7C)/VAR7C*100<-18
VARAC赋值:(大盘的收盘价-250日内大盘的最低价的最低值)/(250日内大盘的最高价的最高值-250日内大盘的最低价的最低值)*100
VARBC赋值:VARAC的30日[1日权重]移动平均
VARCC赋值:VARBC的50日[1日权重]移动平均
VARDC赋值:VAR8C AND VAR9C AND (收阴线OREN 收阳线) AND(开盘价-1日前的收盘价)/1日前的收盘价>-0.05 AND(1日前的收盘价>1日前的开盘价 OR 1日前的收盘价<1日前的开盘价)
VAREC赋值:VARDC AND 统计2日中满足VARDC的天数=1 
短线黑马赋值:VAR5C OR VAREC
N1赋值:9
MTM赋值:收盘价-1日前的收盘价
VAR1赋值:100*MTM的N1日指数移动平均的N1日指数移动平均/MTM的绝对值的N1日指数移动平均的N1日指数移动平均
VAR2赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
赋值: 1日前的收盘价
RSI赋值:收盘价-LC和0的较大值的N1日[1日权重]移动平均/收盘价-LC的绝对值的N1日[1日权重]移动平均*100
EEA赋值:(收盘价-26日前的收盘价)/26日前的收盘价*10
子墨抄底赋值:RSI上穿20 AND VAR1<-45 AND VAR2<12 AND EEA<-2
昨收赋值:1日前的收盘价
趋势赋值:收盘价-昨收和0的较大值的8日[1日权重]移动平均/收盘价-昨收的绝对值的8日[1日权重]移动平均*100
黑马赋值:趋势上穿15
底部黑马1赋值:抄底用 AND 宝石底
底部黑马2赋值:抄底用 AND 短线黑马
底部黑马3赋值:宝石底 AND 短线黑马
底部黑马4赋值:子墨抄底 AND 黑马
底部黑马5赋值:短线黑马 AND 黑马
输出XG:底部黑马1 OR 底部黑马2 OR 底部黑马3 OR 底部黑马4 OR 底部黑马5

演示图片

s_15621.png

相关选股公式

  1. 金牌短线选股公式
  2. 白武士抄底选股公式
  3. 战神抄底选股公式
  4. 换手率抄底选股公式
  5. 金钻抄底选股公式
  6. 泽熙抄底选股公式
  7. 妖股波段选股公式
  8. 短线小天使选股公式
  9. 放量上攻OBV选股公式
  10. 叠倍量选股公式