爆量阳抢筹选股公式

发布时间:2023-09-03

选股公式源码

ZTJ:=ZTPRICE(REF(CLOSE,1),0.1);
DTJ:=DTPRICE(REF(CLOSE,1),0.1);
阳线:=C>O;
上影线:=(H-MAX(C,O))/REF(C,1);
K线实体:=Abs(C-O)/REF(C,1);
涨停:=C/REF(C,1)>1.098&&H=C;
昨日涨停:=REF(C,1)=REF(ZTJ,1);
连板:=EVERY(涨停,2);
五连板:=EVERY(涨停,5);
昨日非涨停:=REF(C,1)/REF(C,2)<1.098&&REF(H,1)>REF(C,1);
不存在五连板:=NOT(EXIST(五连板,90));
不存在二连板:=NOT(EXIST(两连板,7));
最低跌停:=L=DTJ;
双倍放量:=V/REF(V,1)>=2&&V/MA(V,100)>=2;
三倍放量:=V/REF(V,1)>=3&&V/MA(V,100)>1.1;
主力上班量0:=(三倍放量 OR 双倍放量)&&不存在五连板&&不存在二连板&&不存在五连板&&COUNT(最低跌停,10)<2&&昨日非涨停&&阳线;
主力上班量:=FILTER(主力上班量0,3);
SPX0:=H/REF(C,1)>=1.07&&阳线&&昨日非涨停&&H>C&&EXIST(主力上班量,5)&&上影线>0.01&&不存在二连板&&不存在五连板&&V=HHV(V,5);
试盘k线:=FILTER(SPX0,15);
SPZQ:=BArslAST(试盘K线);
KK1:=SUMBARS(试盘K线,1);
昨日长实体涨停:=昨日涨停&&REF(K线实体,1)>0.05;
组合试盘:=昨日长实体涨停&&NOT(EXIST(两连板,10))&&COUNT(主力上班量,2)>=1&&O>REF(C,1)&&上影线>0.02
&&V/REF(V,1)>2&&L>REF(O,1)&&C<O;
ZHSPZQ:=BARSLAST(组合试盘);
试盘无新低:=COUNT(C<REF(O,SPZQ),SPZQ)<2;
起爆点1:=涨停&&EXIST(试盘K线,15)&&试盘无新低&&COUNT(涨停,SPZQ)=1;
起爆点2:=EXIST(组合试盘,15)&&涨停&&C>O&&LLV(L,ZHSPZQ)>=REF(O,ZHSPZQ+1)&&COUNT(涨停,ZHSPZQ)=1;
起爆点3:=EXIST(起爆点1,14)&&涨停&&C>O&&试盘无新低&&COUNT(涨停,SPZQ)=2&&昨日非涨停;
起爆点:=起爆点1 OR 起爆点2 OR 起爆点3;
两连板1:=EVERY(涨停,2)&&EXIST(C>O,2);
三连板:=EVERY(涨停,3);
四连板:=EVERY(涨停,4);
三天两板:=COUNT(涨停&&C>O,3)=2&&C>REF(C,2)&&NOT(EXIST(两连板,3));
强庄10:=EVERY(C>O,6)&&H<HHV(H,90)&&NOT(EXIST(起爆点,60))&&EXIST(V>MA(V,100),5);
强庄1:=FILTER(强庄10,30);
强庄20:=(两连板1 OR 三天两板)&&NOT(三连板)&&NOT(EXIST(四连板,180))&&NOT(EXIST(起爆点,60));
强庄2:=FILTER(强庄20,30);
强庄3:=EVERY(H=ZTJ,2)&&EXIST(C<ZTJ,2)&&EVERY(C/REF(C,1)>0.07,2)&&EVERY(V=HHV(V,60),2)&&NOT(EXIST(强庄2,3))&&NOT(EXIST(起爆点,60));
爆量抢筹:强庄3;

选股公式翻译

ZTJ赋值:计算涨停价
DTJ赋值:计算跌停价
阳线赋值:收阳线
上影线赋值:(最高价-收盘价和开盘价的较大值)/1日前的收盘价
K线实体赋值:收盘价-开盘价的绝对值/1日前的收盘价
涨停赋值:收盘价/1日前的收盘价>1.098并且最高价=收盘价
昨日涨停赋值:1日前的收盘价=1日前的ZTJ
两连板赋值:最近2日一直存在涨停
五连板赋值:最近5日一直存在涨停
昨日非涨停赋值:1日前的收盘价/2日前的收盘价<1.098并且1日前的最高价>1日前的收盘价
不存在五连板赋值:取反
不存在二连板赋值:取反
最低跌停赋值:最低价=DTJ
双倍放量赋值:成交量(手)/1日前的成交量(手)>=2并且成交量(手)/成交量(手)的100日简单移动平均>=2
三倍放量赋值:成交量(手)/1日前的成交量(手)>=3并且成交量(手)/成交量(手)的100日简单移动平均>1.1
主力上班量0赋值:(三倍放量 OR 双倍放量)并且不存在五连板并且不存在二连板并且不存在五连板并且统计10日中满足最低跌停的天数<2并且昨日非涨停并且阳线
主力上班量赋值:主力上班量0的3日过滤
SPX0赋值:最高价/1日前的收盘价>=1.07并且阳线并且昨日非涨停并且最高价>收盘价并且最近5日存在主力上班量并且上影线>0.01并且不存在二连板并且不存在五连板并且成交量(手)=5日内成交量(手)的最高值
试盘K线赋值:SPX0的15日过滤
SPZQ赋值:上次试盘K线距今天数
KK1赋值:试盘K线累加至1的天数
昨日长实体涨停赋值:昨日涨停并且1日前的K线实体>0.05
组合试盘赋值:昨日长实体涨停并且取反并且统计2日中满足主力上班量的天数>=1并且开盘价>1日前的收盘价并且上影线>0.02并且成交量(手)/1日前的成交量(手)>2并且最低价>1日前的开盘价并且收阴线
ZHSPZQ赋值:上次组合试盘距今天数
试盘无新低赋值:统计SPZQ日中满足收盘价=ZHSPZQ+1日前的开盘价并且统计ZHSPZQ日中满足涨停的天数=1
起爆点3赋值:最近14日存在起爆点1并且涨停并且收阳线并且试盘无新低并且统计SPZQ日中满足涨停的天数=2并且昨日非涨停
起爆点赋值:起爆点1 OR 起爆点2 OR 起爆点3
两连板1赋值:最近2日一直存在涨停并且最近2日存在收阳线
三连板赋值:最近3日一直存在涨停
四连板赋值:最近4日一直存在涨停
三天两板赋值:统计3日中满足涨停并且收阳线的天数=2并且收盘价>2日前的收盘价并且取反
强庄10赋值:最近6日一直存在收阳线并且最高价<90日内最高价的最高值并且取反并且最近5日存在成交量(手)>成交量(手)的100日简单移动平均
强庄1赋值:强庄10的30日过滤
强庄20赋值:(两连板1 OR 三天两板)并且取反并且取反并且取反
强庄2赋值:强庄20的30日过滤
强庄3赋值:最近2日一直存在最高价=ZTJ并且最近2日存在收盘价0.07并且最近2日一直存在成交量(手)=60日内成交量(手)的最高值并且取反并且取反
输出爆量阳抢筹:强庄3

演示图片

s_15642.png

相关选股公式

  1. 超级主力选股公式
  2. 筹码分布拉升选股公式
  3. 猛虎抓龙头选股公式
  4. 倍量龙妖选股公式
  5. 主力筹码控盘选股公式
  6. 游资涨停选股公式
  7. 金牛座引擎选股公式
  8. 首板捉妖选股公式
  9. 私募强庄选股公式
  10. 主力扫盘选股公式