波段抄底选股公式

发布时间:2023-09-10

选股公式源码

VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR1E:=AMOUNT/VOL/100;
VAR1F:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR28:=(VAR1E-MA(VAR1E,21))/(0.015*AVEDEV(VAR1E,21));
VAR29:=(VAR1F-MA(VAR1F,90))/(0.015*AVEDEV(VAR1F,90));
VAR2A:=((VAR29+VAR28+VAR27+VAR26+VAR20)/5+165)/4;
VAR2B:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
持股:=(VAR2A+VAR2B)/2/1.1;
安全:=MA(持股,21);
底:=安全-2*STD(持股,21);
波段底:CROSS(持股,底);

选股公式翻译

VAR1赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*200
VAR2赋值:VAR1的3日[1日权重]移动平均
VAR3赋值:VAR2的3日[1日权重]移动平均
VAR4赋值:3*VAR2-2*VAR3
VAR5赋值:5日内最低价的最低值
VAR6赋值:5日内最高价的最高值
VAR7赋值:(收盘价-VAR5)/(VAR6-VAR5)*100的4日指数移动平均*2
VAR8赋值:0.667*1日前的VAR7+0.333*VAR7的2日指数移动平均
VAR9赋值:3*VAR7-2*VAR8
VARA赋值:收盘价的5日简单移动平均的2乘幂+收盘价的5日简单移动平均
VARB赋值:最低价的5日简单移动平均的2乘幂+最低价的5日简单移动平均
VARC赋值:最高价的5日简单移动平均的2乘幂+最高价的5日简单移动平均
VARD赋值:(VARA-64日内VARB的最低值)/(64日内VARC的最高值-64日内VARB的最低值)*150+65-10
VARE赋值:VARD的3日[1日权重]移动平均*1.5-100
VARF赋值:VARE的3日[1日权重]移动平均
VAR10赋值:3*VARE-2*VARF
VAR11赋值:(最高价+最低价+收盘价*2)/4
VAR12赋值:VAR11的13日指数移动平均
VAR13赋值:VAR11的13日估算标准差
VAR14赋值:(VAR11-VAR12)*100/VAR13
VAR15赋值:VAR14的5日指数移动平均
VAR17赋值:VAR15的13日指数移动平均+200-100
VAR18赋值:VAR17的10日指数移动平均
VAR19赋值:3*VAR17-2*VAR18
VAR1A赋值:VAR2+VAR7+VARE+VAR17
VAR1B赋值:VAR3+VAR8+VARF+VAR18
VAR1C赋值:VAR4+VAR9+VAR10+VAR19
VAR1D赋值:(最高价+最低价+收盘价)/3
VAR1E赋值:成交额(元)/成交量(手)/100
VAR1F赋值:成交额(元)的5日累和/成交量(手)的5日累和/100
VAR20赋值:(VAR1D-VAR1D的34日简单移动平均)/(0.015*VAR1D的34日平均绝对偏差)
VAR22赋值:(最高价+最低价+收盘价+VAR1D)/4
VAR23赋值:VAR22的24日指数移动平均
VAR24赋值:VAR22的24日估算标准差
VAR25赋值:(VAR22-VAR23)/VAR24*100
VAR26赋值:(VAR1D-VAR1D的24日简单移动平均)/(0.015*VAR1D的24日平均绝对偏差)
VAR27赋值:VAR25的5日指数移动平均
VAR28赋值:(VAR1E-VAR1E的21日简单移动平均)/(0.015*VAR1E的21日平均绝对偏差)
VAR29赋值:(VAR1F-VAR1F的90日简单移动平均)/(0.015*VAR1F的90日平均绝对偏差)
VAR2A赋值:((VAR29+VAR28+VAR27+VAR26+VAR20)/5+165)/4
VAR2B赋值:(VAR1A+VAR1B+VAR1C*30)/32/5-15
持股赋值:(VAR2A+VAR2B)/2/1.1
安全赋值:持股的21日简单移动平均
底赋值:安全-2*持股的21日估算标准差
输出波段底:持股上穿底

演示图片

s_15659.png

相关选股公式

  1. 白武士抄底选股公式
  2. 战神抄底选股公式
  3. 换手率抄底选股公式
  4. 一夜持股选股公式
  5. 金钻抄底选股公式
  6. 泽熙抄底选股公式
  7. 妖股波段选股公式
  8. 叠倍量选股公式
  9. 短线买卖波段选股公式
  10. 波段登峰选股公式