鸭头回踩选股公式

发布时间:2023-09-24

选股公式源码

X_1:=DYNAINFO(17)>0;
X_2:=IF(INBLOCK(1),0,1) AND IF(INBLOCK(2),0,1);
X_3:=FINANCE(40)/100000000<1000;
X_4:=IF(CODELIKE(3) OR CODELIKE(4),0,1);
X_5:=IF(NAMELIKE(5),0,1);
X_6:=X_2 AND X_1 AND X_3 AND DYNAINFO(17)>0 AND X_4 AND X_5;
X_7:=MA(CLOSE,5);
X_8:=CLOSE>X_7 AND X_7>REF(X_7,1) AND REF(X_7,1)<REF(X_7,2);
X_9:=EMA(CLOSE,5)-EMA(CLOSE,15);
X_10:=EMA(X_9,5);
X_11:=2*(X_9-X_10);
X_12:=NOT(HIGH>MAX(OPEN,CLOSE)*1.02);
X_13:=VOL*10000/FINANCE(7);
X_14:=VOL/CONST(HHV(VOL,90))*100;
X_15:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
鸭头回踩:MA(CLOSE,20)>MA(CLOSE,30) AND MA(CLOSE,30)>MA(CLOSE,60) AND MA(CLOSE,5)>MA(CLOSE,20) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)<MA(CLOSE,10) AND VOL>MA(VOL,5) AND X_8=1 AND X_11>0 AND NOT(COUNT(REF(HIGH,1)/REF(CLOSE,2)>1.11,360)) AND X_6 AND X_12 AND X_13>=3 AND X_14<70 AND X_15>5,COLORYELLOW,LINETHICK3;

选股公式翻译

X_1赋值:量比>0
X_2赋值:如果属于某板块,返回0,否则返回1 AND 如果属于某板块,返回0,否则返回1
X_3赋值:流通市值/100000000<1000
X_4赋值:如果模糊匹配品种代码ORCODELIKE(4),返回0,否则返回1
X_5赋值:如果模糊匹配品种名称,返回0,否则返回1
X_6赋值:X_2 AND X_1 AND X_3 AND 量比>0 AND X_4 AND X_5
X_7赋值:收盘价的5日简单移动平均
X_8赋值:收盘价>X_7 AND X_7>1日前的X_7 AND 1日前的X_7<2日前的X_7
X_9赋值:收盘价的5日指数移动平均-收盘价的15日指数移动平均
X_10赋值:X_9的5日指数移动平均
X_11赋值:2*(X_9-X_10)
X_12赋值:取反
X_13赋值:成交量(手)*10000/流通股本(股)
X_14赋值:成交量(手)/90日内成交量(手)的最高值的最后一日取值设为常数*100
X_15赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
输出鸭头回踩:收盘价的20日简单移动平均>收盘价的30日简单移动平均 AND 收盘价的30日简单移动平均>收盘价的60日简单移动平均 AND 收盘价的5日简单移动平均>收盘价的20日简单移动平均 AND 收盘价的10日简单移动平均>收盘价的20日简单移动平均 AND 收盘价的5日简单移动平均<收盘价的10日简单移动平均 AND 成交量(手)>成交量(手)的5日简单移动平均 AND X_8=1 AND X_11>0 AND 取反 AND X_6 AND X_12 AND X_13>=3 AND X_14<70 AND X_15>5,画黄色,线宽为3

演示图片

s_15697.png

相关选股公式

  1. 突破回踩选股公式
  2. 突破平台回踩选股公式
  3. 三阴急跌回踩选股公式
  4. 上涨回踩买选股公式
  5. 三阴急跌回踩买入选股公式
  6. 回踩买入选股公式
  7. 回踩阴线买入选股公式
  8. 金股主升回踩选股公式
  9. 小妖回踩选股公式
  10. 主升浪回踩选股公式