莫贪选股公式

发布时间:2023-10-22

选股公式源码

N:=5;
F:=9;
M1:=3;
M2:=3;
X_1:=(2*CLOSE+HIGH+LOW)/4;
X_2:=EXPMA(EXPMA(EXPMA(X_1,4),4),4);
X_3:=(X_2-REF(X_2,1))/REF(X_2,1)*100;
X_4:=MA(X_3,3);
X_5:=MA((VOL-REF(VOL,1))/REF(VOL,1),5);
X_6:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
X_7:=X_6*(1+X_5);
X_8:=X_7;
X_9:=MA(X_8,N);
X_10:=(HHV(HIGH,F)-CLOSE)/(HHV(HIGH,F)-LLV(LOW,F))*100;
X_11:=SMA(X_10,M1,1);
X_12:=SMA(X_11,M2,1);
XG:CROSS(X_3,X_4) AND CROSS(X_7,X_9) AND X_3<0 AND X_9<0 AND CROSS(X_12,X_11);

选股公式翻译

N赋值:5
F赋值:9
M1赋值:3
M2赋值:3
X_1赋值:(2*收盘价+最高价+最低价)/4
X_2赋值:X_1的4日指数移动平均的4日指数移动平均的4日指数移动平均
X_3赋值:(X_2-1日前的X_2)/1日前的X_2*100
X_4赋值:X_3的3日简单移动平均
X_5赋值:(成交量(手)-1日前的成交量(手))/1日前的成交量(手)的5日简单移动平均
X_6赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100
X_7赋值:X_6*(1+X_5)
X_8赋值:X_7
X_9赋值:X_8的N日简单移动平均
X_10赋值:(F日内最高价的最高值-收盘价)/(F日内最高价的最高值-F日内最低价的最低值)*100
X_11赋值:X_10的M1日[1日权重]移动平均
X_12赋值:X_11的M2日[1日权重]移动平均
输出XG:X_3上穿X_4 AND X_7上穿X_9 AND X_3<0 AND X_9<0 AND X_12上穿X_11

演示图片

s_15724.png

相关选股公式

  1. 起飞加速选股公式
  2. 搏涨成交量选股公式
  3. 擒牛成交量选股公式
  4. 妖成龙选股公式
  5. 精品擒妖选股公式
  6. 太极乾坤选股公式
  7. 尾进明早出挣选股公式
  8. 圣火选股公式
  9. 强庄起爆点选股公式
  10. 大阳不破选股公式