突破主升狙击选股公式

发布时间:2023-12-10

选股公式源码

M1:=5;
M2:=10;
M3:=20;
M4:=60;
M5:=120;
N:=10;
XA_1:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);
XA_2:=IF(DATETODAY(DATE)<9890,1,1);
XA_3:=EMA(CLOSE,5);
XA_4:=EMA(CLOSE,10);
XA_5:=EMA(CLOSE,14);
XA_6:=EMA(CLOSE,18);
XA_7:=EMA(CLOSE,40);
XA_8:=EMA(CLOSE,60);
XA_9:=IF(DATE<2342.459961*500,1,1);
XA_10:=MAX(XA_7,XA_8);
XA_11:=CLOSE>XA_10 AND XA_1 AND (CLOSE>REF(HHV(HIGH,3),1)*XA_2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07);
XA_12:=VOL;
XA_13:=MA(XA_12,5);
XA_14:=XA_13+XA_13>XA_12;
XA_15:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85)*XA_2 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10)*XA_9;
XA_16:=(CLOSE>REF(HHV(HIGH,3),1)*XA_2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07)*XA_2 AND XA_15 AND XA_14;
XA_17:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)*XA_2<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);
XA_18:=(CLOSE-REF(CLOSE,1)*XA_2)/REF(CLOSE,1)*100>7;
XA_19:=XA_17 AND XA_18;
XA_22:=(XA_11 AND XA_19);
XA_23:=EMA(CLOSE,5);
XA_24:=EMA(CLOSE,10);
XA_25:=EMA(CLOSE,14);
XA_26:=EMA(CLOSE,18);
XA_27:=EMA(CLOSE,40);
XA_28:=EMA(CLOSE,60);
XA_29:=MAX(MAX(MAX(MAX(MAX(XA_23,XA_4),XA_25),XA_26),XA_27),XA_28)*XA_9;
XA_30:=MIN(MIN(MIN(MIN(MIN(XA_23,XA_4),XA_25),XA_26),XA_27),XA_28)*XA_9;
XA_31:=CLOSE>XA_29 AND LOW<XA_30 AND (CLOSE>REF(HHV(HIGH,3),1) AND (CLOSE-REF(CLOSE,1)*XA_2)/REF(CLOSE,1)>0.09);
XA_32:=FILTER(XA_31>0,0)=1;
XA_35:=XA_32;
XA_36:=MA(REF(HHV(CLOSE,26),1),2);
XA_37:=MA(CLOSE,26);
XA_38:=POW(CLOSE-XA_37,2);
XA_39:=MA(XA_38,13);
XA_40:=SQRT(XA_39);
XA_41:=XA_37+2*XA_40;
XA_42:=REF(XA_41,1);
XA_43:=CROSS(CLOSE,XA_36) AND HIGH>REF(XA_41,1) OR (CLOSE>XA_36 AND CROSS(CLOSE,REF(XA_41,1))) AND CLOSE/OPEN>0.998;
XA_44:=MACD.macd;
XA_45:=KD.K;
XA_46:=KD.D;
XA_47:=RSI.RSI1;
XA_48:=RSI.RSI3;
XA_49:=CLOSE-REF(CLOSE,1);
XA_50:=IF(XA_49>=0,XA_49,0)*XA_9;
XA_51:=IF(XA_49<0,-XA_49,0)*XA_9;
XA_52:=MEMA(XA_50,10);
XA_53:=MEMA(XA_51,10);
XA_54:=MEMA(XA_50,6);
XA_55:=MEMA(XA_51,6);
XA_56:=MA(100*XA_52/(XA_52+XA_53),10)*XA_9;
XA_57:=MA(100*XA_54/(XA_54+XA_55),6)*XA_9;
XA_58:=MA(CLOSE,5)/MA(CLOSE,10)>0.999 AND MA(CLOSE,10)/MA(CLOSE,20)>0.9847 AND MA(CLOSE,20)>MA(CLOSE,60) AND REF(COUNT(MA(CLOSE,10)/MA(CLOSE,20)<1.017 OR MA(CLOSE,5)/MA(CLOSE,10)<1.017,8)>=1,1) AND MA(CLOSE,20)/MA(CLOSE,60)<1.121;
XA_59:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100;
XA_60:=COUNT(XA_59<35,100)>=95;
XA_61:=XA_43 AND XA_58>0 AND NOT(DYNAINFO(4)=0) AND XA_60 AND REF(COUNT(MA(CLOSE,20)>MA(CLOSE,30),4)=4 AND COUNT(CLOSE>MA(CLOSE,5),3)>=2,1) AND VOL>REF(VOL,1) AND (REF(COUNT(CLOSE>OPEN,10)>=6 OR COUNT(CLOSE>OPEN,5)>=4,1) OR CLOSE=HIGH) AND (CROSS(XA_57,XA_56) OR CROSS(XA_44,0) OR REF(COUNT(CROSS(XA_44,0),3)=1 AND XA_44<0.15 AND CLOSE/OPEN>0.989 AND CLOSE/REF(CLOSE,1)<1.03,1) OR CROSS(XA_45,XA_46) OR CROSS(XA_47,XA_48)) AND REF(CLOSE/OPEN>0.988 AND (CLOSE>OPEN OR (CLOSE<=OPEN AND HIGH/LOW<1.049)),1) AND HIGH/CLOSE<1.013 AND CLOSE/OPEN>1.05;
XA_62:=XA_11+XA_16+XA_19+XA_32+XA_61>=2;
XA_63:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,60) AND MA(CLOSE,60)>MA(CLOSE,120) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1);
XA_64:=CLOSE>REF(CLOSE,1)*1.1-0.01;
XA_65:=HHV(HIGH,20)=HHV(CLOSE,1) AND VOL>0 AND BARSCOUNT(CLOSE)*XA_2>=20;
XA_66:=VOL/REF(VOL,1)*XA_2>1.9;
XA_67:=XA_63 AND XA_64 AND XA_65 AND XA_66;
XA_68:=MA(CLOSE,5);
XA_69:=MA(CLOSE,10);
XA_70:=MA(CLOSE,20);
XA_71:=MA(CLOSE,30);
XA_72:=MA(CLOSE,60);
XA_73:=CLOSE>XA_68 AND XA_68>XA_69 AND XA_69>XA_70 AND CLOSE>XA_72;
XA_74:=CLOSE/REF(CLOSE,1)>1.05 AND REF(CLOSE,1)/REF(CLOSE,2)<1.05 AND CLOSE/LLV(CLOSE,10)<1.4;
XA_75:=VOL/REF(VOL,1)>2 OR VOL=HHV(VOL,15);
XA_76:=CAPITAL<10000000;
XA_77:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*57.299999>40;
XA_78:=ATAN((MA(CLOSE,10)/REF(MA(CLOSE,10),1)-1)*100)*57.299999>30;
XA_79:=ATAN((MA(CLOSE,20)/REF(MA(CLOSE,20),1)-1)*100)*57.299999>20;
XA_80:=ATAN((MA(CLOSE,30)/REF(MA(CLOSE,30),1)-1)*100)*57.299999>10;
XA_81:=XA_77 AND XA_78 AND XA_79 AND XA_80;
XA_82:=KDJ.K>REF(KDJ.K,1)*XA_2;
XA_83:=KDJ.D>REF(KDJ.D,1)*XA_2 AND KDJ.D<70;
XA_84:=KDJ.J>REF(KDJ.J,1)*XA_2;
XA_85:=XA_82 AND XA_83 AND XA_84;
XA_86:=XA_7 AND XA_74 AND XA_75 AND XA_76 AND XA_81 AND XA_85;
XA_87:=FILTER(XA_86,15)*XA_2;
XA_88:=XA_67 OR XA_87;
龙头:=((XA_88 AND XA_62)*XA_2 OR XA_35 OR XA_22),COLORRED;
EXP1:=EMA(CLOSE,M1);
EXP2:=EMA(CLOSE,M2);
强势:=IF(SLOPE(EXP1,N)>0,1,0),COLORRED;
VOLUME:=VOL;
MAVOL1:=MA(VOLUME,M3);
MAVOL2:=MA(VOLUME,M4);
A11:=EXP1>EXP2;
A4:=HHV(HIGH,N);
A22:=(C-REF(C,1))/REF(C,1)>0.05;
A3:=MAVOL1>MAVOL2;
A5:=A11 AND A22 AND C>=A4 ;
突破:=FILTER(A5,M5) AND WINNER(C)*100>80 AND WIDTH <0.3 AND (C-REF(C,1))/REF(C,1)>0.094;
主升狙击:=IF(强势=1,3,0) AND MA(V,5)/CAPITAL >0.015 AND C/REF(C,1)>1.095 AND MA(C,60)>REF( MA(C,60),1) AND FILTER (C/REF(C,10)>1.15,30);
LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
主升选股:=FILTER(LS,28) AND 龙头;
XG:突破+主升狙击+主升选股>=2;

选股公式翻译

M1赋值:5
M2赋值:10
M3赋值:20
M4赋值:60
M5赋值:120
N赋值:10
XA_1赋值:开盘价>0 AND 10日内最高价的最高值/10日内最低价的最低值<1.25 AND 1日前的收盘价<15日内最低价的最低值+(15日内最高价的最高值-15日内最低价的最低值)*0.85 AND 收阳线ANDSE 收盘价>=10日内最高价的最高值
XA_2赋值:如果日期对应的转换天数<9890,返回1,否则返回1
XA_3赋值:收盘价的5日指数移动平均
XA_4赋值:收盘价的10日指数移动平均
XA_5赋值:收盘价的14日指数移动平均
XA_6赋值:收盘价的18日指数移动平均
XA_7赋值:收盘价的40日指数移动平均
XA_8赋值:收盘价的60日指数移动平均
XA_9赋值:如果日期<2342.459961*500,返回1,否则返回1
XA_10赋值:XA_7和XA_8的较大值
XA_11赋值:收盘价>XA_10 AND XA_1 AND (收盘价>1日前的3日内最高价的最高值*XA_2 AND (收盘价-1日前的收盘价)/1日前的收盘价>0.07)
XA_12赋值:成交量(手)
XA_13赋值:XA_12的5日简单移动平均
XA_14赋值:XA_13+XA_13>XA_12
XA_15赋值:开盘价>0 AND 10日内最高价的最高值/10日内最低价的最低值<1.25 AND 1日前的收盘价<(15日内最低价的最低值+(15日内最高价的最高值-15日内最低价的最低值)*0.85)*XA_2 AND 收阳线ANDSE 收盘价>=10日内最高价的最高值*XA_9
XA_16赋值:(收盘价>1日前的3日内最高价的最高值*XA_2 AND (收盘价-1日前的收盘价)/1日前的收盘价>0.07)*XA_2 AND XA_15 AND XA_14
XA_17赋值:开盘价>0 AND 10日内最高价的最高值/10日内最低价的最低值<1.25 AND 1日前的收盘价*XA_2<15日内最低价的最低值+(15日内最高价的最高值-15日内最低价的最低值)*0.85 AND 收阳线ANDSE 收盘价>=10日内最高价的最高值
XA_18赋值:(收盘价-1日前的收盘价*XA_2)/1日前的收盘价*100>7
XA_19赋值:XA_17 AND XA_18
XA_22赋值:(XA_11 AND XA_19)
XA_23赋值:收盘价的5日指数移动平均
XA_24赋值:收盘价的10日指数移动平均
XA_25赋值:收盘价的14日指数移动平均
XA_26赋值:收盘价的18日指数移动平均
XA_27赋值:收盘价的40日指数移动平均
XA_28赋值:收盘价的60日指数移动平均
XA_29赋值:XA_23和XA_4的较大值和XA_25的较大值和XA_26的较大值和XA_27的较大值和XA_28的较大值*XA_9
XA_30赋值:XA_23和XA_4的较小值和XA_25的较小值和XA_26的较小值和XA_27的较小值和XA_28的较小值*XA_9
XA_31赋值:收盘价>XA_29 AND 最低价1日前的3日内最高价的最高值 AND (收盘价-1日前的收盘价*XA_2)/1日前的收盘价>0.09)
XA_32赋值:XA_31>0的历史过滤=1
XA_35赋值:XA_32
XA_36赋值:1日前的26日内收盘价的最高值的2日简单移动平均
XA_37赋值:收盘价的26日简单移动平均
XA_38赋值:收盘价-XA_37的2乘幂
XA_39赋值:XA_38的13日简单移动平均
XA_40赋值:XA_39的开方
XA_41赋值:XA_37+2*XA_40
XA_42赋值:1日前的XA_41
XA_43赋值:收盘价上穿XA_36 AND 最高价>1日前的XA_41 OR (收盘价>XA_36 AND 收盘价上穿1日前的XA_41) AND 收盘价/开盘价>0.998
XA_44赋值:平滑异同平均线的MACD
XA_45赋值:随机指标KD的K
XA_46赋值:随机指标KD的D
XA_47赋值:RSI的RSI1
XA_48赋值:RSI的RSI3
XA_49赋值:收盘价-1日前的收盘价
XA_50赋值:如果XA_49>=0,返回XA_49,否则返回0*XA_9
XA_51赋值:如果XA_49<0,返回-XA_49,否则返回0*XA_9
XA_52赋值:XA_50的10日平滑移动平均
XA_53赋值:XA_51的10日平滑移动平均
XA_54赋值:XA_50的6日平滑移动平均
XA_55赋值:XA_51的6日平滑移动平均
XA_56赋值:100*XA_52/(XA_52+XA_53)的10日简单移动平均*XA_9
XA_57赋值:100*XA_54/(XA_54+XA_55)的6日简单移动平均*XA_9
XA_58赋值:收盘价的5日简单移动平均/收盘价的10日简单移动平均>0.999 AND 收盘价的10日简单移动平均/收盘价的20日简单移动平均>0.9847 AND 收盘价的20日简单移动平均>收盘价的60日简单移动平均 AND 1日前的统计8日中满足收盘价的10日简单移动平均/收盘价的20日简单移动平均<1.017ORMA(收盘价,5)/收盘价的10日简单移动平均<1.017的天数>=1 AND 收盘价的20日简单移动平均/收盘价的60日简单移动平均<1.121
XA_59赋值:(收盘价-收盘价的60日简单移动平均)/收盘价的60日简单移动平均*100
XA_60赋值:统计100日中满足XA_59<35的天数>=95
XA_61赋值:XA_43 AND XA_58>0 AND 取反 AND XA_60 AND 1日前的统计4日中满足收盘价的20日简单移动平均>收盘价的30日简单移动平均的天数=4ANDCOUNT(收盘价>收盘价的5日简单移动平均,3)>=2 AND 成交量(手)>1日前的成交量(手) AND (1日前的统计10日中满足收阳线的天数>=6ORCOUNT(收阳线,5)>=4 OR 收盘价=最高价) AND (XA_57上穿XA_56 OR XA_44上穿0 OR 1日前的统计3日中满足XA_44上穿0的天数=1ANDXA_44<0.15ANDCLOSE/开盘价>0.989ANDCLOSE/1日前的收盘价<1.03 OR XA_45上穿XA_46 OR XA_47上穿XA_48) AND 1日前的收盘价/开盘价>0.988AND(收盘价>OPENOR(收盘价<=OPENANDHIGH/最低价<1.049)) AND 最高价/收盘价<1.013 AND 收盘价/开盘价>1.05
XA_62赋值:XA_11+XA_16+XA_19+XA_32+XA_61>=2
XA_63赋值:收盘价的5日简单移动平均>收盘价的10日简单移动平均 AND 收盘价的10日简单移动平均>收盘价的20日简单移动平均 AND 收盘价的20日简单移动平均>收盘价的60日简单移动平均 AND 收盘价的60日简单移动平均>收盘价的120日简单移动平均 AND 收盘价的5日简单移动平均>1日前的收盘价的5日简单移动平均
XA_64赋值:收盘价>1日前的收盘价*1.1-0.01
XA_65赋值:20日内最高价的最高值=1日内收盘价的最高值 AND 成交量(手)>0 AND 收盘价的有效数据周期数*XA_2>=20
XA_66赋值:成交量(手)/1日前的成交量(手)*XA_2>1.9
XA_67赋值:XA_63 AND XA_64 AND XA_65 AND XA_66
XA_68赋值:收盘价的5日简单移动平均
XA_69赋值:收盘价的10日简单移动平均
XA_70赋值:收盘价的20日简单移动平均
XA_71赋值:收盘价的30日简单移动平均
XA_72赋值:收盘价的60日简单移动平均
XA_73赋值:收盘价>XA_68 AND XA_68>XA_69 AND XA_69>XA_70 AND 收盘价>XA_72
XA_74赋值:收盘价/1日前的收盘价>1.05 AND 1日前的收盘价/2日前的收盘价<1.05 AND 收盘价/10日内收盘价的最低值<1.4
XA_75赋值:成交量(手)/1日前的成交量(手)>2 OR 成交量(手)=15日内成交量(手)的最高值
XA_76赋值:当前流通股本(手)<10000000
XA_77赋值:(收盘价的5日简单移动平均/1日前的收盘价的5日简单移动平均-1)*100的反正切*57.299999>40
XA_78赋值:(收盘价的10日简单移动平均/1日前的收盘价的10日简单移动平均-1)*100的反正切*57.299999>30
XA_79赋值:(收盘价的20日简单移动平均/1日前的收盘价的20日简单移动平均-1)*100的反正切*57.299999>20
XA_80赋值:(收盘价的30日简单移动平均/1日前的收盘价的30日简单移动平均-1)*100的反正切*57.299999>10
XA_81赋值:XA_77 AND XA_78 AND XA_79 AND XA_80
XA_82赋值:KDJ的K>1日前的KDJ的K*XA_2
XA_83赋值:KDJ的D>1日前的KDJ的D*XA_2 AND KDJ的D<70
XA_84赋值:KDJ的J>1日前的KDJ的J*XA_2
XA_85赋值:XA_82 AND XA_83 AND XA_84
XA_86赋值:XA_7 AND XA_74 AND XA_75 AND XA_76 AND XA_81 AND XA_85
XA_87赋值:XA_86的15日过滤*XA_2
XA_88赋值:XA_67 OR XA_87
龙头赋值:((XA_88 AND XA_62)*XA_2 OR XA_35 OR XA_22),画红色
EXP1赋值:收盘价的M1日指数移动平均
EXP2赋值:收盘价的M2日指数移动平均
强势赋值:如果EXP1的N日线性回归斜率>0,返回1,否则返回0,画红色
VOLUME赋值:成交量(手)
MAVOL1赋值:VOLUME的M3日简单移动平均
MAVOL2赋值:VOLUME的M4日简单移动平均
A11赋值:EXP1>EXP2
A4赋值:N日内最高价的最高值
A22赋值:(收盘价-1日前的收盘价)/1日前的收盘价>0.05
A3赋值:MAVOL1>MAVOL2
A5赋值:A11 AND A22 AND 收盘价>=A4 
突破赋值:A5的M5日过滤 AND 以收盘价计算的获利盘比例*100>80 AND 布林极限宽 <0.3 AND (收盘价-1日前的收盘价)/1日前的收盘价>0.094
主升狙击赋值:如果强势=1,返回3,否则返回0 AND 成交量(手)的5日简单移动平均/当前流通股本(手) >0.015 AND 收盘价/1日前的收盘价>1.095 AND 收盘价的60日简单移动平均>1日前的收盘价的60日简单移动平均 AND 收盘价/10日前的收盘价>1.15的30日过滤
LS赋值:收盘价/1日前的收盘价>1.048 AND 收盘价=最高价 AND 成交量(手)的4日线性回归预测值位于0.2*成交量(手)的12日线性回归预测值和2.1*成交量(手)的12日线性回归预测值之间
主升选股赋值:LS的28日过滤 AND 龙头
输出XG:突破+主升狙击+主升选股>=2

演示图片

s_15832.png

相关选股公式

  1. N型突破选股公式
  2. 主升龙头选股公式
  3. 放量突破机会选股公式
  4. 龙头首阴选股公式
  5. 财务突破买点选股公式
  6. 起爆狙击选股公式
  7. 一阳突破选股公式
  8. 突破回踩选股公式
  9. 金牛突破选股公式
  10. 叠倍量选股公式