四项一致选股公式

发布时间:2024-01-21

选股公式源码

TR1:=MAX(Abs(H-REF(H,1)),ABS(L-REF(L,1)));
DMZ:=IF((H+L)<=(REF(H,1)+REF(L,1)),0,MAX(ABS(H-REF(H,1)),ABS(L-REF(L,1))));
DMF:=IF((H+L)>=(REF(H,1)+REF(L,1)),0,MAX(ABS(H-REF(H,1)),ABS(L-REF(L,1))));
DDZ:=SUM(DMZ,13)/(SUM(DMZ,13)+SUM(DMF,13));
DDF:=SUM(DMF,13)/(SUM(DMF,13)+SUM(DMZ,13));
ZX:=DDZ-DDF;
MZX:=SMA(ZX,30,10);
AD:=MA(MZX,30);
KX:=EMA(C,7)-EMA(C,19),COLORWHITE;
MX:=EMA(KX,9);
DX:=2*(KX-MX),COLORCYAN;
XG:CROSS(DX,KX);

选股公式翻译

TR1赋值:最高价-1日前的最高价的绝对值和最低价-1日前的最低价的绝对值的较大值
DMZ赋值:如果(最高价+最低价)<=(1日前的最高价+1日前的最低价),返回0,否则返回最高价-1日前的最高价的绝对值和最低价-1日前的最低价的绝对值的较大值
DMF赋值:如果(最高价+最低价)>=(1日前的最高价+1日前的最低价),返回0,否则返回最高价-1日前的最高价的绝对值和最低价-1日前的最低价的绝对值的较大值
DDZ赋值:DMZ的13日累和/(DMZ的13日累和+DMF的13日累和)
DDF赋值:DMF的13日累和/(DMF的13日累和+DMZ的13日累和)
ZX赋值:DDZ-DDF
MZX赋值:ZX的30日[10日权重]移动平均
AD赋值:MZX的30日简单移动平均
KX赋值:收盘价的7日指数移动平均-收盘价的19日指数移动平均,画白色
MX赋值:KX的9日指数移动平均
DX赋值:2*(KX-MX),画青色
输出XG:DX上穿KX

演示图片

s_15906.png

相关选股公式

  1. 金箍棒选股公式
  2. 步入上升选股公式
  3. 潜伏出击选股公式
  4. 只做中段选股公式
  5. 高阴量吸选股公式
  6. 底现金牛选股公式
  7. 迎新选股公式
  8. 妖龙越海选股公式
  9. 超白金喇叭选股公式
  10. 星辰启航选股公式