红色神剑选股公式

发布时间:2024-03-10

选股公式源码

SHORT:=8;
LONG:=13;
MID:=5;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
macdLINE:=IF(CROSS(DIF,DEA),1+1,IF(CROSS(DEA,DIF),1-0.5,1+0));
A1:=DIF>DEA;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
KDJLINE:=IF(CROSS(K,D) AND CROSS(J,K),1,IF(CROSS(D,K) AND CROSS(K,J),0-0.5,0));
A2:=K>D;
N1:=6; N2:=12; N3:=24;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(Abs(CLOSE-LC),N1,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100;
A3:=RSI1>RSI2;
WN:=9; WM1:=3; WM2:=3;
WRSV:=-(HHV(HIGH,WN)-CLOSE)/(HHV(HIGH,WN)-LLV(LOW,WN))*100; {威廉指标采用反向,所以加“负号”};
LWR1:=SMA(WRSV,WM1,1);
LWR2:=SMA(LWR1,WM2,1);
A4:=LWR1>LWR2;
BM1:=3; BM2:=6; BM3:=12; BM4:=24;
BBI:=(MA(CLOSE,BM1)+MA(CLOSE,BM2)+MA(CLOSE,BM3)+MA(CLOSE,BM4))/4;
A5:=CLOSE>BBI;
{MN:=12; MM:=6;
MTM:CLOSE-REF(CLOSE,MN);
MTMMA:=MA(MTM,M)};
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
A6:=MMS>MMM;
红数:=A1+A2+A3+A4+A5+A6, COLORYELLOW;
买入:(红数=6 AND REF(红数,1)<>6)*3, COLORYELLOW;

选股公式翻译

SHORT赋值:8
LONG赋值:13
MID赋值:5
DIF赋值:收盘价的SHORT日指数移动平均-收盘价的LONG日指数移动平均
DEA赋值:DIF的MID日指数移动平均
MACD赋值:(DIF-DEA)*2
MACDLINE赋值:如果DIF上穿DEA,返回1+1,否则返回如果DEA上穿DIF,返回1-0.5,否则返回1+0
A1赋值:DIF>DEA
N赋值:9
M1赋值:3
M2赋值:3
RSV赋值:(收盘价-N日内最低价的最低值)/(N日内最高价的最高值-N日内最低价的最低值)*100
K赋值:RSV的M1日[1日权重]移动平均
D赋值:K的M2日[1日权重]移动平均
J赋值:3*K-2*D
KDJLINE赋值:如果K上穿DANDCROSS(J,K),返回1,否则返回如果D上穿KANDCROSS(K,J),返回0-0.5,否则返回0
A2赋值:K>D
N1赋值:6
N2赋值:12
N3赋值:24
LC赋值:1日前的收盘价
RSI1赋值:收盘价-LC和0的较大值的N1日[1日权重]移动平均/收盘价-LC的绝对值的N1日[1日权重]移动平均*100
RSI2赋值:收盘价-LC和0的较大值的N2日[1日权重]移动平均/收盘价-LC的绝对值的N2日[1日权重]移动平均*100
RSI3赋值:收盘价-LC和0的较大值的N3日[1日权重]移动平均/收盘价-LC的绝对值的N3日[1日权重]移动平均*100
A3赋值:RSI1>RSI2
WN赋值:9
WM1赋值:3
WM2赋值:3
WRSV赋值:-(WN日内最高价的最高值-收盘价)/(WN日内最高价的最高值-WN日内最低价的最低值)*100
 
LWR1赋值:WRSV的WM1日[1日权重]移动平均
LWR2赋值:LWR1的WM2日[1日权重]移动平均
A4赋值:LWR1>LWR2
BM1赋值:3
BM2赋值:6
BM3赋值:12
BM4赋值:24
BBI赋值:(收盘价的BM1日简单移动平均+收盘价的BM2日简单移动平均+收盘价的BM3日简单移动平均+收盘价的BM4日简单移动平均)/4
A5赋值:收盘价>BBI

MTM赋值:收盘价-1日前的收盘价
MMS赋值:100*MTM的5日指数移动平均的3日指数移动平均/MTM的绝对值的5日指数移动平均的3日指数移动平均
MMM赋值:100*MTM的13日指数移动平均的8日指数移动平均/MTM的绝对值的13日指数移动平均的8日指数移动平均
A6赋值:MMS>MMM
红数赋值:A1+A2+A3+A4+A5+A6, 画黄色
输出买入:(红数=6 AND 1日前的红数不等于6)*3, 画黄色

演示图片

s_15968.png

相关选股公式

  1. 均线成交量MACD金叉选股公式
  2. 九方小牛选股公式
  3. 势如破竹选股公式
  4. 倍量龙妖选股公式
  5. 准备启动买入选股公式
  6. 搏涨成交量选股公式
  7. 九天揽月选股公式
  8. 绝密爆点选股公式
  9. 探底棒选股公式
  10. 周月CCI抓妖选股公式