探底棒选股公式

发布时间:2024-03-17

选股公式源码

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
macd:=(DIF-DEA)*2;
HH1:=(HIGH+LOW+CLOSE)/3;
HH2:=(HH1-MA(HH1,14))/(0.015*AVEDEV(HH1,14));
QQ1:=(HH1-MA(HH1,70))/(0.015*AVEDEV(HH1,70));
QQ2:=IF(HH2<=-150 AND HH2>-200 AND QQ1<=-150 AND QQ1>-200,10,0);
DD1:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);
DD2:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);
HH3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
HH4:=3*SMA(HH3,3,1)-2*SMA(SMA(HH3,3,1),3,1);
DD3:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
DD6:=REF(C>O OR O>C,40) AND REF(C>O OR O>C,45);
DD4:=crOSS(CLOSE,REF(EMA(DD3,3),1)) AND HH4<50 AND REF(HH4<0 ,1);
DD5:= HH4>0 AND REF(C<O,1);EQ:=C>O AND H/C<1.01;
ZZ3:=C>REF(C,3) AND C/REF(C,1)>1.03 ;ZZ4:= REF(H>O,1) AND REF(L<O,1);
ZZ5:="MACD.macd">REF("MACD.MACD",1) AND"MACD.MACD"<0;
ZZ6:=DD4 AND DD5 AND EQ AND ZZ3 AND ZZ4 AND ZZ5 AND DD6;
ZZ1:=IF(BARSCOUNT(CLOSE)<70,-120,IF(QQ1<=-200 AND HH2<=-150,15,QQ2)-120);
ZZ2:=SMA((DD2-50)*2,3,1)+SMA((DD1-50)*2,3,1)/2;
HH5:=(REF(H,3)-REF(L,1))/C*100>8;
探底棒:=ZZ6 AND ZZ1 AND ZZ2 AND HH5;
XG:FILTER(探底棒=1,3);

选股公式翻译

DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD赋值:(DIF-DEA)*2
HH1赋值:(最高价+最低价+收盘价)/3
HH2赋值:(HH1-HH1的14日简单移动平均)/(0.015*HH1的14日平均绝对偏差)
QQ1赋值:(HH1-HH1的70日简单移动平均)/(0.015*HH1的70日平均绝对偏差)
QQ2赋值:如果HH2<=-150ANDHH2>-200ANDQQ1<=-150ANDQQ1>-200,返回10,否则返回0
DD1赋值:(收盘价-14日内最低价的最低值)/(14日内最高价的最高值-14日内最低价的最低值)*100的4日[1日权重]移动平均
DD2赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100的4日[1日权重]移动平均
HH3赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
HH4赋值:3*HH3的3日[1日权重]移动平均-2*HH3的3日[1日权重]移动平均的3日[1日权重]移动平均
DD3赋值:以0.9为权重(((最高价+最低价)+(收盘价*2))/4.15)的动态移动平均
DD6赋值:40日前的收盘价>OORO>收盘价 AND 45日前的收盘价>OORO>收盘价
DD4赋值:收盘价上穿1日前的DD3的3日指数移动平均 AND HH4<50 AND 1日前的HH4<0
DD5赋值: HH4>0 AND 1日前的收阴线
EQ赋值:收阳线AND 最高价/收盘价<1.01
ZZ3赋值:收盘价>3日前的收盘价 AND 收盘价/1日前的收盘价>1.03 
ZZ4赋值: 1日前的最高价>开盘价 AND 1日前的最低价<开盘价
ZZ5赋值:"MACD.MACD">1日前的"MACD.MACD" AND"MACD.MACD"<0
ZZ6赋值:DD4 AND DD5 AND EQ AND ZZ3 AND ZZ4 AND ZZ5 AND DD6
ZZ1赋值:如果收盘价的有效数据周期数<70,返回-120,否则返回如果QQ1<=-200ANDHH2<=-150,返回15,否则返回QQ2-120
ZZ2赋值:(DD2-50)*2的3日[1日权重]移动平均+(DD1-50)*2的3日[1日权重]移动平均/2
HH5赋值:(3日前的最高价-1日前的最低价)/收盘价*100>8
探底棒赋值:ZZ6 AND ZZ1 AND ZZ2 AND HH5
输出XG:探底棒=1的3日过滤

演示图片

s_15973.png

相关选股公式

  1. 均线成交量MACD金叉选股公式
  2. 九方小牛选股公式
  3. 势如破竹选股公式
  4. 倍量龙妖选股公式
  5. 九天揽月选股公式
  6. 绝密爆点选股公式
  7. 红色神剑选股公式
  8. 黎明之星选股公式
  9. MACD绿柱翻红选股公式
  10. MACD资金量能选股公式