潜龙起飞选股公式

发布时间:2023-08-06

选股公式源码

VAR1:=REF(CLOSE,13);
VAR2:=SMA(MAX(CLOSE-VAR1,0),34,1)/SMA(Abs(CLOSE-VAR1),34,1)*1000;
VAR3:=VAR2-LLV(VAR2,11);
VAR4:=(MA(VAR3,21)*3+VAR3*13)/16;
VAR6:=(CLOSE+HIGH+LOW)/3;
VAR7:=MA(VAR6,4);
VAR8:=VAR7;
VAR9:=LLV(VAR7,8);
VAR10:=VAR8-VAR9>0 AND REF(VAR8-VAR9,1)=0;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*10;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=IF(VAR13>=REF(VAR13,1),VAR13,0);
VAR15:=VAR13=VAR14 AND VAR13<5.5 AND REF(VAR14,1)=0 AND VAR13>=REF(VAR13,1);
VAR16:=VAR15 AND VAR10;
潜龙起飞:VAR16=1 AND VAR4<5 AND EVERY(MA(CLOSE,5)<MA(CLOSE,10),7) AND EVERY(MA(CLOSE,5)<MA(CLOSE,20),5) AND EVERY(MA(VOL,5)<MA(VOL,10),4) AND EVERY(MA(CLOSE,5)<REF(MA(CLOSE,5),1),5) AND EVERY(MA(CLOSE,10)<REF(MA(CLOSE,10),1),5) AND EVERY(MA(CLOSE,20)<REF(MA(CLOSE,20),1),5);

选股公式翻译

VAR1赋值:13日前的收盘价
VAR2赋值:收盘价-VAR1和0的较大值的34日[1日权重]移动平均/收盘价-VAR1的绝对值的34日[1日权重]移动平均*1000
VAR3赋值:VAR2-11日内VAR2的最低值
VAR4赋值:(VAR3的21日简单移动平均*3+VAR3*13)/16
VAR6赋值:(收盘价+最高价+最低价)/3
VAR7赋值:VAR6的4日简单移动平均
VAR8赋值:VAR7
VAR9赋值:8日内VAR7的最低值
VAR10赋值:VAR8-VAR9>0 AND 1日前的VAR8-VAR9=0
VAR11赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*10
VAR12赋值:VAR11的3日[1日权重]移动平均
VAR13赋值:VAR12的3日[1日权重]移动平均
VAR14赋值:如果VAR13>=1日前的VAR13,返回VAR13,否则返回0
VAR15赋值:VAR13=VAR14 AND VAR13<5.5 AND 1日前的VAR14=0 AND VAR13>=1日前的VAR13
VAR16赋值:VAR15 AND VAR10
输出潜龙起飞:VAR16=1 AND VAR4<5 AND 最近7日一直存在收盘价的5日简单移动平均<收盘价的10日简单移动平均 AND 最近5日一直存在收盘价的5日简单移动平均<收盘价的20日简单移动平均 AND 最近4日一直存在成交量(手)的5日简单移动平均<成交量(手)的10日简单移动平均 AND 最近5日一直存在收盘价的5日简单移动平均<1日前的收盘价的5日简单移动平均 AND 最近5日一直存在收盘价的10日简单移动平均<1日前的收盘价的10日简单移动平均 AND 最近5日一直存在收盘价的20日简单移动平均<1日前的收盘价的20日简单移动平均

演示图片

s_15590.png

相关选股公式

  1. 金箍棒选股公式
  2. 步入上升选股公式
  3. 潜伏出击选股公式
  4. 只做中段选股公式
  5. 高阴量吸选股公式
  6. 底现金牛选股公式
  7. 迎新选股公式
  8. 妖龙越海选股公式
  9. 超白金喇叭选股公式
  10. 星辰启航选股公式