圆弧突破选股公式

发布时间:2023-11-26

选股公式源码

低天:=15;
高天:=5;
CURR:=CURRBARSCOUNT;
SH:=CONST(REF(H,BARSLAST(CURR=高天)));
SL:=CONST(REF(L,BARSLAST(CURR=低天)));
高低距:=SH-SL;
天距:=Abs(低天-高天);
PR:=ABS(低天-高天)/2+IF(高天>低天,低天,高天);
RN:=(SH+SL)/2;
Y弧:=(SH*SL);
BX:=2*(SH*SL)/天距;
BY:=(SH*SL)/高低距;
XW:=IF(CURR<PR,PR-CURR,CURR-PR)*BX;
SY:=IF(XW<Y弧,SQRT(Y弧*Y弧-XW*XW),0)/BY;
Y震谱1:=IF(高天<低天,RN+SY,RN-SY),COLORRED;
高点:=HHV(Y震谱1,10);
Y弧1:=(SH*SL)/2;
BX1:=2*(SH*SL)/天距;
BY1:=(SH*SL)/高低距;
XW1:=IF(CURR<PR,PR-CURR,CURR-PR)*BX1;
SY1:=IF(XW<Y弧,SQRT(Y弧1*Y弧1-XW1*XW1),0)/BY1;
Y震谱3:=IF(高天<低天,RN+SY1,RN-SY1),COLORRED;
高点1:=HHV(Y震谱3,10),COLORBLUE;
XG:=CROSS(C,高点) OR CROSS(C,高点1) AND V/REF(MA(V,5),1)>1.2;
圆弧突破:CURRBARSCOUNT<10 AND XG;

选股公式翻译

低天赋值:15
高天赋值:5
CURR赋值:到最后交易的周期
SH赋值:上次CURR=高天距今天数日前的最高价的最后一日取值设为常数
SL赋值:上次CURR=低天距今天数日前的最低价的最后一日取值设为常数
高低距赋值:SH-SL
天距赋值:低天-高天的绝对值
PR赋值:低天-高天的绝对值/2+如果高天>低天,返回低天,否则返回高天
RN赋值:(SH+SL)/2
Y弧赋值:(SH*SL)
BX赋值:2*(SH*SL)/天距
BY赋值:(SH*SL)/高低距
XW赋值:如果CURR1.2
输出圆弧突破:到最后交易的周期<10 AND XG

演示图片

s_15813.png

相关选股公式

  1. 突破回踩选股公式
  2. 金牛突破选股公式
  3. 突破主升狙击选股公式
  4. 出击捉庄选股公式
  5. 倍量突破选股公式
  6. 接力涨选股公式
  7. 红妖突破选股公式
  8. 有效突破追入选股公式
  9. 突破上影选股公式
  10. 突破假阴选股公式