潜龙升天中线选股公式

发布时间:2023-11-26

选股公式源码

LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(Abs(CLOSE-LC),2,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;
RSI4:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI5:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI6:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
RSI7:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
RSI8:=SMA(MAX(CLOSE-LC,0),9,1)/SMA(ABS(CLOSE-LC),9,1)*100;
RSI9:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100;
RSI10:=SMA(MAX(CLOSE-LC,0),11,1)/SMA(ABS(CLOSE-LC),11,1)*100;
RSI11:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI12:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
RSI13:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
RSI14:=SMA(MAX(CLOSE-LC,0),15,1)/SMA(ABS(CLOSE-LC),15,1)*100;
RSI15:=SMA(MAX(CLOSE-LC,0),16,1)/SMA(ABS(CLOSE-LC),16,1)*100;
RSI16:=SMA(MAX(CLOSE-LC,0),17,1)/SMA(ABS(CLOSE-LC),17,1)*100;
RSI17:=SMA(MAX(CLOSE-LC,0),18,1)/SMA(ABS(CLOSE-LC),18,1)*100;
RSI18:=SMA(MAX(CLOSE-LC,0),19,1)/SMA(ABS(CLOSE-LC),19,1)*100;
RSI19:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
RSI21:=SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*100;
RSI30:=SMA(MAX(CLOSE-LC,0),30,1)/SMA(ABS(CLOSE-LC),30,1)*100;
RSI40:=SMA(MAX(CLOSE-LC,0),40,1)/SMA(ABS(CLOSE-LC),40,1)*100;
RSI50:=SMA(MAX(CLOSE-LC,0),50,1)/SMA(ABS(CLOSE-LC),50,1)*100;
RSI60:=SMA(MAX(CLOSE-LC,0),60,1)/SMA(ABS(CLOSE-LC),60,1)*100;
RSI70:=SMA(MAX(CLOSE-LC,0),70,1)/SMA(ABS(CLOSE-LC),70,1)*100;
RSI80:=SMA(MAX(CLOSE-LC,0),80,1)/SMA(ABS(CLOSE-LC),80,1)*100;
RSI90:=SMA(MAX(CLOSE-LC,0),90,1)/SMA(ABS(CLOSE-LC),90,1)*100;
RSI100:=SMA(MAX(CLOSE-LC,0),100,1)/SMA(ABS(CLOSE-LC),100,1)*100;
RSI110:=SMA(MAX(CLOSE-LC,0),110,1)/SMA(ABS(CLOSE-LC),110,1)*100;
RSI120:=SMA(MAX(CLOSE-LC,0),120,1)/SMA(ABS(CLOSE-LC),120,1)*100;
短线RSI:=(RSI1+RSI2+RSI3+RSI4+RSI5)/5,COLORWHITE;
中线RSI:=(RSI6+ RSI7+ RSI8+ RSI9+ RSI10+ RSI11+ RSI12+ RSI13+ RSI14+ RSI15+ RSI16+ RSI17+ RSI18+ RSI19+ RSI21)/15,COLORYELLOW;
长线RSI:=(RSI21+RSI30+RSI40+RSI50+RSI60+RSI70+RSI80+RSI90+RSI100+RSI110+RSI120)/11;
A:=CROSS(短线RSI,中线RSI);
B:=CROSS(中线RSI,短线RSI);
A11:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
A21:=LLV(L,21);
A31:=LLV(L,30);
A41:=EMA(A11,5);
A51:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
基础:=DIFF< -0.1 AND DIFF>DEA;
中线买入:CROSS(A11,A41) AND (A51-A41)>40 AND 基础;

选股公式翻译

LC赋值:1日前的收盘价
RSI1赋值:收盘价-LC和0的较大值的2日[1日权重]移动平均/收盘价-LC的绝对值的2日[1日权重]移动平均*100
RSI2赋值:收盘价-LC和0的较大值的3日[1日权重]移动平均/收盘价-LC的绝对值的3日[1日权重]移动平均*100
RSI3赋值:收盘价-LC和0的较大值的4日[1日权重]移动平均/收盘价-LC的绝对值的4日[1日权重]移动平均*100
RSI4赋值:收盘价-LC和0的较大值的5日[1日权重]移动平均/收盘价-LC的绝对值的5日[1日权重]移动平均*100
RSI5赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
RSI6赋值:收盘价-LC和0的较大值的7日[1日权重]移动平均/收盘价-LC的绝对值的7日[1日权重]移动平均*100
RSI7赋值:收盘价-LC和0的较大值的8日[1日权重]移动平均/收盘价-LC的绝对值的8日[1日权重]移动平均*100
RSI8赋值:收盘价-LC和0的较大值的9日[1日权重]移动平均/收盘价-LC的绝对值的9日[1日权重]移动平均*100
RSI9赋值:收盘价-LC和0的较大值的10日[1日权重]移动平均/收盘价-LC的绝对值的10日[1日权重]移动平均*100
RSI10赋值:收盘价-LC和0的较大值的11日[1日权重]移动平均/收盘价-LC的绝对值的11日[1日权重]移动平均*100
RSI11赋值:收盘价-LC和0的较大值的12日[1日权重]移动平均/收盘价-LC的绝对值的12日[1日权重]移动平均*100
RSI12赋值:收盘价-LC和0的较大值的13日[1日权重]移动平均/收盘价-LC的绝对值的13日[1日权重]移动平均*100
RSI13赋值:收盘价-LC和0的较大值的14日[1日权重]移动平均/收盘价-LC的绝对值的14日[1日权重]移动平均*100
RSI14赋值:收盘价-LC和0的较大值的15日[1日权重]移动平均/收盘价-LC的绝对值的15日[1日权重]移动平均*100
RSI15赋值:收盘价-LC和0的较大值的16日[1日权重]移动平均/收盘价-LC的绝对值的16日[1日权重]移动平均*100
RSI16赋值:收盘价-LC和0的较大值的17日[1日权重]移动平均/收盘价-LC的绝对值的17日[1日权重]移动平均*100
RSI17赋值:收盘价-LC和0的较大值的18日[1日权重]移动平均/收盘价-LC的绝对值的18日[1日权重]移动平均*100
RSI18赋值:收盘价-LC和0的较大值的19日[1日权重]移动平均/收盘价-LC的绝对值的19日[1日权重]移动平均*100
RSI19赋值:收盘价-LC和0的较大值的20日[1日权重]移动平均/收盘价-LC的绝对值的20日[1日权重]移动平均*100
RSI21赋值:收盘价-LC和0的较大值的21日[1日权重]移动平均/收盘价-LC的绝对值的21日[1日权重]移动平均*100
RSI30赋值:收盘价-LC和0的较大值的30日[1日权重]移动平均/收盘价-LC的绝对值的30日[1日权重]移动平均*100
RSI40赋值:收盘价-LC和0的较大值的40日[1日权重]移动平均/收盘价-LC的绝对值的40日[1日权重]移动平均*100
RSI50赋值:收盘价-LC和0的较大值的50日[1日权重]移动平均/收盘价-LC的绝对值的50日[1日权重]移动平均*100
RSI60赋值:收盘价-LC和0的较大值的60日[1日权重]移动平均/收盘价-LC的绝对值的60日[1日权重]移动平均*100
RSI70赋值:收盘价-LC和0的较大值的70日[1日权重]移动平均/收盘价-LC的绝对值的70日[1日权重]移动平均*100
RSI80赋值:收盘价-LC和0的较大值的80日[1日权重]移动平均/收盘价-LC的绝对值的80日[1日权重]移动平均*100
RSI90赋值:收盘价-LC和0的较大值的90日[1日权重]移动平均/收盘价-LC的绝对值的90日[1日权重]移动平均*100
RSI100赋值:收盘价-LC和0的较大值的100日[1日权重]移动平均/收盘价-LC的绝对值的100日[1日权重]移动平均*100
RSI110赋值:收盘价-LC和0的较大值的110日[1日权重]移动平均/收盘价-LC的绝对值的110日[1日权重]移动平均*100
RSI120赋值:收盘价-LC和0的较大值的120日[1日权重]移动平均/收盘价-LC的绝对值的120日[1日权重]移动平均*100
短线RSI赋值:(RSI1+RSI2+RSI3+RSI4+RSI5)/5,画白色
中线RSI赋值:(RSI6+ RSI7+ RSI8+ RSI9+ RSI10+ RSI11+ RSI12+ RSI13+ RSI14+ RSI15+ RSI16+ RSI17+ RSI18+ RSI19+ RSI21)/15,画黄色
长线RSI赋值:(RSI21+RSI30+RSI40+RSI50+RSI60+RSI70+RSI80+RSI90+RSI100+RSI110+RSI120)/11
A赋值:短线RSI上穿中线RSI
B赋值:中线RSI上穿短线RSI
A11赋值:3*(收盘价-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100的5日指数移动平均-2*(收盘价-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100的5日指数移动平均
A21赋值:21日内最低价的最低值
A31赋值:30日内最低价的最低值
A41赋值:A11的5日指数移动平均
A51赋值:(34日内最高价的最高值-收盘价)/(34日内最高价的最高值-34日内最低价的最低值)*100
赋值: 收盘价的12日指数移动平均 - 收盘价的26日指数移动平均
赋值:DIFF的9日指数移动平均
基础赋值:DIFF< -0.1 AND DIFF>DEA
输出中线买入:A11上穿A41 AND (A51-A41)>40 AND 基础

演示图片

s_15814.png

相关选股公式

  1. 左膀右臂选股公式
  2. 招招绝选股公式
  3. 金牌短线选股公式
  4. 盘口异动选股公式
  5. 短线小天使选股公式
  6. 放量上攻OBV选股公式
  7. 叠倍量选股公式
  8. 短线起爆点选股公式
  9. 短线主力资金选股公式
  10. 短线买卖波段选股公式