八指标共振选股公式

发布时间:2023-12-17

选股公式源码

DIF60:=EMA(CLOSE,12/4)-EMA(CLOSE,26/4);
DEA60:=EMA(DIF60,9/2);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
周MD:=MACD.DIF#WEEK;
周MA:=macd.DEA#WEEK;
月MD:=MACD.DIF#MONTH;
月MA:=MACD.DEA#MONTH;
RSV60:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36));
K60:=SMA(RSV60,3,1);
D60:=SMA(K60,3,1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
周K:="KDJ.K#WEEK";
周D:="KDJ.D#WEEK";
月K:="KDJ.K#MONTH";
月D:="KDJ.D#MONTH";
XG1:=DIF60>=DEA60;
XG2:=DIF>=DEA;
XG3:=周MD>=周MA;
XG4:=月MD>=月MA;
XG5:=K60>= D60;
XG6:=K>=D;
XG7:=周K>=周D;
XG8:=月K>=月D;
XG9:=XG1 AND XG2 AND XG3 AND XG4 AND XG5 AND XG6 AND XG7 AND XG8;
XG:REF(XG9,1)<>1 AND XG9=1;

选股公式翻译

DIF60赋值:收盘价的12/4日指数移动平均-收盘价的26/4日指数移动平均
DEA60赋值:DIF60的9/2日指数移动平均
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
周MD赋值:平滑异同平均线的DIF[取周线数据]
周MA赋值:平滑异同平均线的DEA[取周线数据]
月MD赋值:平滑异同平均线的DIF[取月线数据]
月MA赋值:平滑异同平均线的DEA[取月线数据]
RSV60赋值:(收盘价-36日内最低价的最低值)/(36日内最高价的最高值-36日内最低价的最低值)
K60赋值:RSV60的3日[1日权重]移动平均
D60赋值:K60的3日[1日权重]移动平均
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
周K赋值:"KDJ的K[取周线数据]"
周D赋值:"KDJ的D[取周线数据]"
月K赋值:"KDJ的K[取月线数据]"
月D赋值:"KDJ的D[取月线数据]"
XG1赋值:DIF60>=DEA60
XG2赋值:DIF>=DEA
XG3赋值:周MD>=周MA
XG4赋值:月MD>=月MA
XG5赋值:K60>= D60
XG6赋值:K>=D
XG7赋值:周K>=周D
XG8赋值:月K>=月D
XG9赋值:XG1 AND XG2 AND XG3 AND XG4 AND XG5 AND XG6 AND XG7 AND XG8
输出XG:1日前的XG9不等于1 AND XG9=1

演示图片

s_15850.png

相关选股公式

  1. 起爆捉妖选股公式
  2. 搏涨成交量选股公式
  3. 九天揽月选股公式
  4. 庄家共振选股公式
  5. 黄金共振波选股公式
  6. 绝密爆点选股公式
  7. 探底棒选股公式
  8. 红色神剑选股公式
  9. 黎明之星选股公式
  10. MACD绿柱翻红选股公式