阴线低吸模式选股公式

发布时间:2023-12-17

选股公式源码

GXS_1:=MA(CLOSE,1)/MA(REF(CLOSE,18),18)*100;
GXS_2:=MA(FORCAST(GXS_1,20),6);
GXS_3:=EMA(CLOSE,240)-EMA(CLOSE,520);
GXS_4:=EMA(GXS_3,180);
GXS_5:=GXS_3*2-GXS_4;
GXS_6:=SMA(GXS_5,3,1);
GXS_7:=60;
GXS_8:=130;
GXS_9:=45;
GXS_10:=EMA(CLOSE,GXS_7)-EMA(CLOSE,GXS_8);
GXS_11:=EMA(GXS_10,GXS_9);
GXS_12:=GXS_10*2-GXS_11;
GXS_13:=SMA(GXS_12,3,1);
GXS_14:=EMA(CLOSE,12)-EMA(CLOSE,26);
GXS_15:=EMA(GXS_14,9);
GXS_16:=GXS_14*2-GXS_15;
GXS_17:=SMA(GXS_16,3,1);
GXS_18:=LLV(LOW,9);
GXS_19:=HHV(HIGH,9);
GXS_20:=EMA((CLOSE-GXS_18)/(GXS_19-GXS_18)*100,3);
GXS_21:=EMA(GXS_20,3);
GXS_22:=MA(GXS_21,3);
GXS_23:=IF(CLOSE/REF(CLOSE,1)>1+0.01*9+EXIST(CLOSE/REF(CLOSE,1)>1+0.01*9,10)+CLOSE/REF(CLOSE,1)>1+0.01*9=3,1,0);
GXS_24:=EMA(2.055*EMA(EMA(HIGH,34),34)-EMA(EMA(LOW,34),34),5)>CLOSE;
GXS_25:=CLOSE/REF(CLOSE,1)-1>=0.08;
GXS_26:=LOW<REF(LOW,2);
GXS_27:=LOW<REF(LOW,1);
GXS_28:=(OPEN-LOW)/(CLOSE-OPEN)>=1.48;
GXS_29:=CLOSE>REF(CLOSE,1);
GXS_30:=CLOSE/REF(CLOSE,1)-1>=0.0502;
GXS_31:=(HIGH-CLOSE)/(CLOSE-OPEN)<0.33;
GXS_32:=VOL>REF(VOL,1)*2.5;
GXS_33:=VOL>REF(VOL,1);
GXS_34:=CLOSE>REF(CLOSE,1);
GXS_35:=CLOSE/REF(CLOSE,1)-1>=0.0502;
GXS_36:=(HIGH-CLOSE)/(CLOSE-OPEN)<0.33;
GXS_37:=CLOSE/REF(CLOSE,1)-1>=0.049;
GXS_38:=CLOSE>REF(CLOSE,1);
GXS_39:=VOL>REF(VOL,1)*1.9;
GXS_40:=IF(FILTER(GXS_39 AND GXS_38 AND GXS_37 AND GXS_36 OR (GXS_35 AND GXS_34 AND GXS_33 AND GXS_32 AND GXS_31) OR (GXS_30 AND GXS_29 AND GXS_28 AND GXS_27 AND GXS_26) OR GXS_25 AND GXS_24,34),1,0) AND GXS_23;
GXS_41:=CLOSE/REF(CLOSE,1)>1.048;
GXS_42:=CLOSE=HIGH;
GXS_43:=BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
GXS_44:=LOW>REF(CLOSE,1)*0.93;
GXS_45:=KDJ.J-REF(KDJ.J,1)>30;
GXS_46:=CLOSE/REF(CLOSE,1)>1.043;
GXS_47:=MACD.macd>0;
GXS_48:=MACD.DEA>0;
GXS_49:=SMA(20*(DMA(CLOSE,2.5*MAX(VOL/700000000,1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1)))/REF(DMA(CLOSE,2.5*MAX(VOL/700000000,1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1))),1)-1),2,1);
GXS_50:=EMA(SMA(20*(DMA(CLOSE,2.5*MAX(VOL/700000000,1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1)))/REF(DMA(CLOSE,2.5*MAX(VOL/700000000,1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1))),1)-1),2,1),2);
GXS_51:=CLOSE>=REF(CLOSE,1);
GXS_52:=SMA(20*(DMA(CLOSE,2.5*MAX(VOL/700000000,1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1)))/REF(DMA(CLOSE,2.5*MAX(VOL/700000000,1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1))),1)-1),2,1);
GXS_53:=EMA(SMA(20*(DMA(CLOSE,2.5*MAX(VOL/700000000,1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1)))/REF(DMA(CLOSE,2.5*MAX(VOL/700000000,1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1))),1)-1),2,1),2);
GXS_54:=CLOSE>=REF(CLOSE,1);
GXS_55:=FILTER(GXS_41 AND GXS_42 AND GXS_43,28)*100 AND GXS_44 OR (GXS_45 AND GXS_46 AND GXS_47 AND GXS_48) AND CROSS(IF(GXS_49>0.24 AND GXS_50>=0.005 AND GXS_51,1,0),0.5) AND COUNT(IF(GXS_52>0.24 AND GXS_53>=0.005 AND GXS_54,1,0)>0.5,10)=1 OR GXS_40;
GXS_56:=2;
GXS_57:=CLOSE>=ZTPRICE(REF(CLOSE,1),0.1);
GXS_58:=COUNT(GXS_57,GXS_56)=1 AND GXS_57;
GXS_59:=VOL;
GXS_60:=GXS_59>MA(VOL,89);
GXS_61:=EXPMA(CLOSE,5);
GXS_62:=EXPMA(CLOSE,29);
GXS_63:=GXS_61>GXS_62;
GXS_64:=REF(CLOSE,1);
GXS_65:=SMA(MAX(CLOSE-GXS_64,0),12,1)/SMA(Abs(CLOSE-GXS_64),12,1)*100;
GXS_66:=SMA(MAX(CLOSE-GXS_64,0),56,1)/SMA(ABS(CLOSE-GXS_64),56,1)*100;
GXS_67:=GXS_65>GXS_66 AND GXS_63 AND GXS_60;
GXS_68:=HHV(HIGH,30);
GXS_69:=LLV(LOW,30);
GXS_70:=REF((GXS_68/GXS_69-1)*100<=30,1);
GXS_71:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
GXS_72:=DMA((2.15*CLOSE+LOW+HIGH)/4,GXS_71);
GXS_73:=EMA(GXS_72,200)*1.1;
GXS_74:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
GXS_75:=CROSS(CLOSE,GXS_73) AND REF(CLOSE*1.097,1)<CLOSE AND GXS_67 AND GXS_70 AND GXS_58;
GXS_76:=CROSS(GXS_1,GXS_2) AND IF(GXS_16>GXS_17 AND GXS_12>GXS_13 AND GXS_5>GXS_6,1,0) AND GXS_58 AND GXS_21-GXS_22>=(-1);
GXS_77:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
GXS_78:=FILTER(GXS_77,28) AND GXS_58 AND GXS_21-GXS_22>=(-1) AND GXS_55;
GXS_79:=HIGH=CLOSE;
GXS_80:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>=0.93 AND GXS_79;
GXS_81:=BARSLAST(GXS_76 OR GXS_78 OR GXS_75);
GXS_82:=GXS_81=2 AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<MA(CLOSE,5) AND HIGH>MA(CLOSE,3) AND CLOSE>REF(OPEN,2);
GXS_83:=GXS_81=2 AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND LOW<REF(LOW,1) AND REF(LOW,1)<REF(CLOSE,2);
低吸模式:GXS_82 OR GXS_83,COLORGREEN;

选股公式翻译

GXS_1赋值:收盘价的1日简单移动平均/18日前的收盘价的18日简单移动平均*100
GXS_2赋值:GXS_1的20日线性回归预测值的6日简单移动平均
GXS_3赋值:收盘价的240日指数移动平均-收盘价的520日指数移动平均
GXS_4赋值:GXS_3的180日指数移动平均
GXS_5赋值:GXS_3*2-GXS_4
GXS_6赋值:GXS_5的3日[1日权重]移动平均
GXS_7赋值:60
GXS_8赋值:130
GXS_9赋值:45
GXS_10赋值:收盘价的GXS_7日指数移动平均-收盘价的GXS_8日指数移动平均
GXS_11赋值:GXS_10的GXS_9日指数移动平均
GXS_12赋值:GXS_10*2-GXS_11
GXS_13赋值:GXS_12的3日[1日权重]移动平均
GXS_14赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
GXS_15赋值:GXS_14的9日指数移动平均
GXS_16赋值:GXS_14*2-GXS_15
GXS_17赋值:GXS_16的3日[1日权重]移动平均
GXS_18赋值:9日内最低价的最低值
GXS_19赋值:9日内最高价的最高值
GXS_20赋值:(收盘价-GXS_18)/(GXS_19-GXS_18)*100的3日指数移动平均
GXS_21赋值:GXS_20的3日指数移动平均
GXS_22赋值:GXS_21的3日简单移动平均
GXS_23赋值:如果收盘价/1日前的收盘价>1+0.01*9+最近10日存在收盘价/1日前的收盘价>1+0.01*9+收盘价/1日前的收盘价>1+0.01*9=3,返回1,否则返回0
GXS_24赋值:2.055*最高价的34日指数移动平均的34日指数移动平均-最低价的34日指数移动平均的34日指数移动平均的5日指数移动平均>收盘价
GXS_25赋值:收盘价/1日前的收盘价-1>=0.08
GXS_26赋值:最低价<2日前的最低价
GXS_27赋值:最低价<1日前的最低价
GXS_28赋值:(开盘价-最低价)/(收盘价-开盘价)>=1.48
GXS_29赋值:收盘价>1日前的收盘价
GXS_30赋值:收盘价/1日前的收盘价-1>=0.0502
GXS_31赋值:(最高价-收盘价)/(收盘价-开盘价)<0.33
GXS_32赋值:成交量(手)>1日前的成交量(手)*2.5
GXS_33赋值:成交量(手)>1日前的成交量(手)
GXS_34赋值:收盘价>1日前的收盘价
GXS_35赋值:收盘价/1日前的收盘价-1>=0.0502
GXS_36赋值:(最高价-收盘价)/(收盘价-开盘价)<0.33
GXS_37赋值:收盘价/1日前的收盘价-1>=0.049
GXS_38赋值:收盘价>1日前的收盘价
GXS_39赋值:成交量(手)>1日前的成交量(手)*1.9
GXS_40赋值:如果GXS_39ANDGXS_38ANDGXS_37ANDGXS_36OR(GXS_35ANDGXS_34ANDGXS_33ANDGXS_32ANDGXS_31)OR(GXS_30ANDGXS_29ANDGXS_28ANDGXS_27ANDGXS_26)ORGXS_25ANDGXS_24的34日过滤,返回1,否则返回0 AND GXS_23
GXS_41赋值:收盘价/1日前的收盘价>1.048
GXS_42赋值:收盘价=最高价
GXS_43赋值:成交量(手)的4日线性回归预测值位于0.2*成交量(手)的12日线性回归预测值和2.1*成交量(手)的12日线性回归预测值之间
GXS_44赋值:最低价>1日前的收盘价*0.93
GXS_45赋值:KDJ的J-1日前的KDJ的J>30
GXS_46赋值:收盘价/1日前的收盘价>1.043
GXS_47赋值:平滑异同平均线的MACD>0
GXS_48赋值:平滑异同平均线的DEA>0
GXS_49赋值:20*(以2.5*成交量(手)/700000000和1.1*(最高价和1日前的收盘价的较大值/最低价和1日前的收盘价的较小值-1)的较大值为权重收盘价的动态移动平均/?日前的以2.5*成交量(手)/700000000和1.1*(最高价和1日前的收盘价的较大值/?和?的较小值的较大值为权重收盘价的动态移动平均的OW,1日前的收盘价)-1))),1)-1)日[2日权重]移动平均
GXS_50赋值:20*(以2.5*成交量(手)/700000000和1.1*(最高价和1日前的收盘价的较大值/最低价和1日前的收盘价的较小值-1)的较大值为权重收盘价的动态移动平均/?日前的以2.5*成交量(手)/700000000和1.1*(最高价和1日前的收盘价的较大值/的较大值为权重收盘价的动态移动平均的?日[?日权重]移动平均的IN(最低价,1日前的收盘价)-1))),1)-1),2,1)日指数移动平均
GXS_51赋值:收盘价>=1日前的收盘价
GXS_52赋值:20*(以2.5*成交量(手)/700000000和1.1*(最高价和1日前的收盘价的较大值/最低价和1日前的收盘价的较小值-1)的较大值为权重收盘价的动态移动平均/?日前的以2.5*成交量(手)/700000000和1.1*(最高价和1日前的收盘价的较大值/?和?的较小值的较大值为权重收盘价的动态移动平均的OW,1日前的收盘价)-1))),1)-1)日[2日权重]移动平均
GXS_53赋值:20*(以2.5*成交量(手)/700000000和1.1*(最高价和1日前的收盘价的较大值/最低价和1日前的收盘价的较小值-1)的较大值为权重收盘价的动态移动平均/?日前的以2.5*成交量(手)/700000000和1.1*(最高价和1日前的收盘价的较大值/的较大值为权重收盘价的动态移动平均的?日[?日权重]移动平均的IN(最低价,1日前的收盘价)-1))),1)-1),2,1)日指数移动平均
GXS_54赋值:收盘价>=1日前的收盘价
GXS_55赋值:GXS_41ANDGXS_42ANDGXS_43的28日过滤*100 AND GXS_44 OR (GXS_45 AND GXS_46 AND GXS_47 AND GXS_48) AND 如果GXS_49>0.24ANDGXS_50>=0.005ANDGXS_51,返回1,否则返回0上穿0.5 AND 统计10日中满足如果GXS_52>0.24ANDGXS_53>=0.005ANDGXS_54,返回1,否则返回0>0.5的天数=1 OR GXS_40
GXS_56赋值:2
GXS_57赋值:收盘价>=计算涨停价
GXS_58赋值:统计GXS_56日中满足GXS_57的天数=1 AND GXS_57
GXS_59赋值:成交量(手)
GXS_60赋值:GXS_59>成交量(手)的89日简单移动平均
GXS_61赋值:收盘价的5日指数移动平均
GXS_62赋值:收盘价的29日指数移动平均
GXS_63赋值:GXS_61>GXS_62
GXS_64赋值:1日前的收盘价
GXS_65赋值:收盘价-GXS_64和0的较大值的12日[1日权重]移动平均/收盘价-GXS_64的绝对值的12日[1日权重]移动平均*100
GXS_66赋值:收盘价-GXS_64和0的较大值的56日[1日权重]移动平均/收盘价-GXS_64的绝对值的56日[1日权重]移动平均*100
GXS_67赋值:GXS_65>GXS_66 AND GXS_63 AND GXS_60
GXS_68赋值:30日内最高价的最高值
GXS_69赋值:30日内最低价的最低值
GXS_70赋值:1日前的(GXS_68/GXS_69-1)*100<=30
GXS_71赋值:((3.48*收盘价+最高价+最低价)/4-收盘价的23日指数移动平均)/收盘价的23日指数移动平均的绝对值
GXS_72赋值:以GXS_71为权重(2.15*收盘价+最低价+最高价)/4的动态移动平均
GXS_73赋值:GXS_72的200日指数移动平均*1.1
GXS_74赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>5
GXS_75赋值:收盘价上穿GXS_73 AND 1日前的收盘价*1.097<收盘价 AND GXS_67 AND GXS_70 AND GXS_58
GXS_76赋值:GXS_1上穿GXS_2 AND 如果GXS_16>GXS_17ANDGXS_12>GXS_13ANDGXS_5>GXS_6,返回1,否则返回0 AND GXS_58 AND GXS_21-GXS_22>=(-1)
GXS_77赋值:收盘价/1日前的收盘价>1.048 AND 收盘价=最高价 AND 成交量(手)的4日线性回归预测值位于0.2*成交量(手)的12日线性回归预测值和2.1*成交量(手)的12日线性回归预测值之间
GXS_78赋值:GXS_77的28日过滤 AND GXS_58 AND GXS_21-GXS_22>=(-1) AND GXS_55
GXS_79赋值:最高价=收盘价
GXS_80赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>=0.93 AND GXS_79
GXS_81赋值:上次GXS_76ORGXS_78ORGXS_75距今天数
GXS_82赋值:GXS_81=2 AND 1日前的收盘价<1日前的开盘价 AND 收阴线ANDSE 收盘价<1日前的收盘价 AND 1日前的收盘价<2日前的收盘价 AND 收盘价<收盘价的5日简单移动平均 AND 最高价>收盘价的3日简单移动平均 AND 收盘价>2日前的开盘价
GXS_83赋值:GXS_81=2 AND 1日前的收盘价>1日前的开盘价 AND 收阴线ANDSE 最低价<1日前的最低价 AND 1日前的最低价<2日前的收盘价
输出低吸模式:GXS_82 OR GXS_83,画绿色

演示图片

s_15854.png

相关选股公式

  1. 九天揽月选股公式
  2. 绝密爆点选股公式
  3. 探底棒选股公式
  4. 红色神剑选股公式
  5. 黎明之星选股公式
  6. MACD绿柱翻红选股公式
  7. MACD资金量能选股公式
  8. 金叉发财选股公式
  9. 主控力度选股公式
  10. 无敌战狼选股公式